Skip to main content
Topic: foo_discogs (Read 826502 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: foo_discogs

Reply #2575
Hi !

In Configuration->tagging tab i have selected "remove any pre-existing tags" but wanted exclude some tags from this process.
So i wrote in exclusions field following string:
"LYRICS,UNSYNCED LYRICS,MP3GAIN_MINMAX,MP3GAIN_UNDO,ENCODER,RATING,REPLAYGAIN_TRACK_GAIN,REPLAYGAIN_TRACK_PEAK"
and it seems not working properly.
First time all excluded tags stay in place but when i repeat this action again (get tags for the same album again) all tags disapearing.

Is that some bug or i'm doing sth wrong?

P.S. I'm using tagging scheme APE+ID3v1
Strange. foo_discogs shouldn't be removing tags. Perhaps it's something specific to your tagging scheme....


Wow! This is all that I can get?
I know that this is free developement but
why bother when nobody cares.
The only reason I posted info about tagging scheme was
to help developer to recreate problem and fix the bug.
This is not some strange tagging scheme or big error.
It's just a bug. I would understand if You wrote "sorry , can't recreate this bug, need more info or sample"
But this answer?!!! Really? Well. Thanks. Sorry for idiotic thinking that sb fix problem or even try.
Bye. Have a nice life.

Re: foo_discogs

Reply #2576
Just logged in just to throw in a random opinion/comment:
I get you're frustrated, we all can if things don't quite work our way... but that was rude, way out of line & borderline offensive @sfman
c.

Re: foo_discogs

Reply #2577
Just logged in just to throw in a random opinion/comment:
I get you're frustrated, we all can if things don't quite work our way... but that was rude, way out of line & borderline offensive @sfman
c.

Well.
Maybe You're right. It can look like this.
My apologize to All. This wasn't my intention.
And i'm not frustrated because some bug is not fixed. Really. I understand that this
plugin is only because some people share their time and knowledge to community.
It was about lack of any info about the problem. Is sb trying to fix it or it won't be fixed?
Anything that tell me I should wait or try to workout the problem another way.
I'm not demanding. I'm only trying to get info if problem can be fixed or maybe there is no problem,
or its only something on my machine.
So when i waited for any update info for two weeks, not even knowing if somebody analyses it, decided to resign waiting and thats all.
Maybe my post was looking to emotional. Sorry. I'm not blaming anybody, and again, apologize. Don't want people think about me bad.

best regards

Re: foo_discogs

Reply #2578
Hello.
A week ago I started to get this error
Code: [Select]
(FATAL) Error: Network exceptionSecurity error

I thought it might be on discogs end but a week passed and I still get the same error and can't use foo_discogs.
Any suggestions? I relied heavily on this plugin, I used it basically everyday. Any help will be greatly appreciable.

Re: foo_discogs

Reply #2579
Hi !

In Configuration->tagging tab i have selected "remove any pre-existing tags" but wanted exclude some tags from this process.
So i wrote in exclusions field following string:
"LYRICS,UNSYNCED LYRICS,MP3GAIN_MINMAX,MP3GAIN_UNDO,ENCODER,RATING,REPLAYGAIN_TRACK_GAIN,REPLAYGAIN_TRACK_PEAK"
and it seems not working properly.
First time all excluded tags stay in place but when i repeat this action again (get tags for the same album again) all tags disapearing.

Is that some bug or i'm doing sth wrong?

P.S. I'm using tagging scheme APE+ID3v1
Strange. foo_discogs shouldn't be removing tags. Perhaps it's something specific to your tagging scheme....


Wow! This is all that I can get?
I know that this is free developement but
why bother when nobody cares.
The only reason I posted info about tagging scheme was
to help developer to recreate problem and fix the bug.
This is not some strange tagging scheme or big error.
It's just a bug. I would understand if You wrote "sorry , can't recreate this bug, need more info or sample"
But this answer?!!! Really? Well. Thanks. Sorry for idiotic thinking that sb fix problem or even try.
Bye. Have a nice life.
You can make your own tagging program if you're unhappy with the level of service here, or you can offer to pay me to solve your problem! I doubt it's a problem with foo_discogs. As nobody else has reported such a problem before, you should take some initiative to investigate it yourself and provide more info (eg. does it affect different "tagging schemes"?). The more effort you put in, the more likely others will put in effort to help you.

Re: foo_discogs

Reply #2580
Hello.
A week ago I started to get this error
Code: [Select]
(FATAL) Error: Network exceptionSecurity error

I thought it might be on discogs end but a week passed and I still get the same error and can't use foo_discogs.
Any suggestions? I relied heavily on this plugin, I used it basically everyday. Any help will be greatly appreciable.
Sounds like an SSL issue of some sort, but not sure what else to say about it. What OS are you on? Discogs said they'd be disabling TLS 1.0 and 1.1 support as of today - that could be an issue for some people.

Re: foo_discogs

Reply #2581
Hello.
A week ago I started to get this error
Code: [Select]
(FATAL) Error: Network exceptionSecurity error

I thought it might be on discogs end but a week passed and I still get the same error and can't use foo_discogs.
Any suggestions? I relied heavily on this plugin, I used it basically everyday. Any help will be greatly appreciable.
Sounds like an SSL issue of some sort, but not sure what else to say about it. What OS are you on? Discogs said they'd be disabling TLS 1.0 and 1.1 support as of today - that could be an issue for some people.
OK, I tried it on my another computer and it worked. I installed and authorized there for the first time.
It has to do with the fact that I reinstalled OS several times on my current computer before I got "Network exceptionSecurity error". I reinstalled foobar, restored configuration and components folders every time I reinstalled OS.
So, is it SSL certificate issue? Is there any way it can be solved?

Re: foo_discogs

Reply #2582
OK, I tried it on my another computer and it worked. I installed and authorized there for the first time.
It has to do with the fact that I reinstalled OS several times on my current computer before I got "Network exceptionSecurity error". I reinstalled foobar, restored configuration and components folders every time I reinstalled OS.
So, is it SSL certificate issue? Is there any way it can be solved?
Can you not just de-authorize your PC on the discogs website and then re-authorize on foobar? (Changing the OS probably changes the key that OAuth uses to ID you).

Alternatively you could always try to remove the discogs component and reinstall a fresh version. (Probably losing your settings though).

Re: foo_discogs

Reply #2583
Hello.
A week ago I started to get this error
Code: [Select]
(FATAL) Error: Network exceptionSecurity error

I thought it might be on discogs end but a week passed and I still get the same error and can't use foo_discogs.
Any suggestions? I relied heavily on this plugin, I used it basically everyday. Any help will be greatly appreciable.
Sounds like an SSL issue of some sort, but not sure what else to say about it. What OS are you on? Discogs said they'd be disabling TLS 1.0 and 1.1 support as of today - that could be an issue for some people.

I'm not frogjab myself, but I'm actually facing the same issue (running on Windows 10 x64 1803, a somewhat fresh install).
Using foobar v1.3.19, foo_discogs 2.14.

Logs show this (long URLs shortened for better readability):
Code: [Select]
foo_discogs: Networking Error: Security error - Retrying: 1
foo_discogs: Networking Error: Security error - Retrying: 2
foo_discogs: https://api.discogs.com/oauth/request_token?oauth_consumer_key=kQFLKuHX...
foo_discogs: Networking Error: Security error - Retrying: 1
foo_discogs: Networking Error: Security error - Retrying: 2
foo_discogs: Networking Error: Security error - Retrying: 3
foo_discogs: Networking Error: Security error - Retrying: 4
foo_discogs: Networking Error: Security error - Retrying: 5
foo_discogs: Network exception handling: https://api.discogs.com/oauth/request_token?oauth_consumer_key=kQFLKuHX...

Re: foo_discogs

Reply #2584
OK, I tried it on my another computer and it worked. I installed and authorized there for the first time.
It has to do with the fact that I reinstalled OS several times on my current computer before I got "Network exceptionSecurity error". I reinstalled foobar, restored configuration and components folders every time I reinstalled OS.
So, is it SSL certificate issue? Is there any way it can be solved?
Can you not just de-authorize your PC on the discogs website and then re-authorize on foobar? (Changing the OS probably changes the key that OAuth uses to ID you).

Alternatively you could always try to remove the discogs component and reinstall a fresh version. (Probably losing your settings though).

Actually, the OAuth key from one computer should work on another (copy the "token" and "secret" fields from the settings). That is a possible workaround if only setting up OAuth is giving this error.

This is an OS level issue, not specific to foo_discogs, so there would be no benefit in reinstalling the component.

Is the time set correctly on your OS? That has been known to cause this problem in the past.

Re: foo_discogs

Reply #2585
Hi there

I got problems here...


Up until today the discogs plugin was working but now it is jammed on loading release... and has been for the last 3 hours.

I tried reinstalling the plugin but no luck.

Please see screenshot and please help.

thanks.


Re: foo_discogs

Reply #2586
Going to what you said up there... I am happy to pay you to help me with this issue. I swear by this software. Nothing will load now with discogs.

Re: foo_discogs

Reply #2587
Starting today:
(FATAL) Error: Network exceptionNetwork authentication error
[ESCAPE to close]

Re: foo_discogs

Reply #2588
same here.
Code: [Select]
(FATAL) Error: Network exceptionNetwork authentication error (url: https://api.discogs.com/database/search)

[ESCAPE to close]

Re: foo_discogs

Reply #2589
I'm currently getting the same. Just started happening today.

Re: foo_discogs

Reply #2590
Doesn't look like it's the certificate, unless your machines can't process the DigiCert SHA-256 signing authority.

Re: foo_discogs

Reply #2591
From https://www.discogs.com/forum/thread/521520689469733cfcfd2089
Quote
This is a reminder that on June 30th, 2018, TLS 1.0 and 1.1 will be disabled for api.discogs.com. Please make sure your applications are capable of TLS 1.2 connections by this date.

I wonder is it related or not. Anyway, foo_discogs also doesn't work for me (Win 7).

foobar2000 1.3.19: just hangs on "Fetching artist list...".

foobar2000 1.14 b17: shows error window "(FATAL) Error: Network exceptionNetwork authentication error (url: https://api.discogs.com/database/search)"

P.S. When foo_discogs tries to connect to the server, it prints current URL to console. I can open this URL in both Chrome and IE11, so I suppose the error is not Windows-related.

 

Re: foo_discogs

Reply #2593
I only enabled Client part of TLS (see below), and foo_discogs now works, thanks!

Code: [Select]
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client]
"DisabledByDefault"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]
"DisabledByDefault"=dword:00000000


P.S. Yet another reminder that Windows 7 is not exactly an up-to-date system.

Re: foo_discogs

Reply #2594


Code: [Select]
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client]
"DisabledByDefault"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]
"DisabledByDefault"=dword:00000000
 
 Thanks, that worked. Just copied the code above into a 'filename.reg' file and run it to add to the registry.

Re: foo_discogs

Reply #2595
P.S. Yet another reminder that Windows 7 is not exactly an up-to-date system.
This is intentionally done, but we are still successfully resisting  ;)

Re: foo_discogs

Reply #2596
This is a TLS issue as guessed above.

To solve it, you must enabled TLS 1.2 by downloading TLS 1.x on Windows 7.zip and double-click to import the file: Enable TLS 1.x on Windows 7.reg.

See : https://support.cybersource.com/s/article/How-do-I-enable-TLS-1-2-on-Windows-7
If you enable the "Fetch Album Art" or "Display Preview in release dialog" error

Quote
(FATAL) Error: Network exceptionSecurity error (url: https://img.discogs.com/yakz61ovxn3jousDzaAsgw-Dd1Q=/fit-in/150x150/filters:strip_icc():format(jpeg):mode_rgb():quality(40)/discogs-images/R-6526838-1421263634-4823.jpeg.jpg)
[ESCAPE to close]

Re: foo_discogs

Reply #2597
Try 1.4 beta 17, works for me.

Re: foo_discogs

Reply #2598
Try 1.4 beta 17, works for me.
I have 2.14.

If I put 1.4 then the tag card will need to be changed again? - I just set up a tag card for myself

Re: foo_discogs

Reply #2599
Doesn't work anymore. I use latest Foobar2000 on Windows 10 and every time I try to fetch data from discogs I get this type of error:

Code: [Select]
(FATAL) Error: Network exceptionSecurity error (url: https://img.discogs.com/nbbu00fARcGUc6a9Ij7X63r7new=/fit-in/150x150/filters:strip_icc():format(jpeg):mode_rgb():quality(40)/discogs-images/R-12229042-1530965508-2883.jpeg.jpg)

[ESCAPE to close]

 
SimplePortal 1.0.0 RC1 © 2008-2019