Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: REACT 2 Released (Read 1256844 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

REACT 2 Released

Reply #1500
However, I also recently installed "Sony Ericsson PC Suite". And you were right, closing the systray icon solved the problem 

That's really a strange problem, isn't it? Anyway, thank you so much for quick reply and solving my problem.

Yes it is! Very strange indeed. You're the 3rd user to confirm something like this happening. I've known this peculiarity for couple of months now, unfortunately I haven't had any time to look in to this issue.. yet. I just have started the work for next mod release (finally) and I might check out this problem.. but it seems to be a problem between AutoIt (language used to code REACT) and Sony Ericsson PC Suite, I fear that all I can do is to investigate and report to AutoIt team.

REACT 2 Released

Reply #1501
Hi,
i'm not using Sony Ericsson PC Suite, still i had the Problems. Changing back to 4 solved the problem. All i could see from debug was that the temp file could not be found. you know, after extracting the wav it is moved to a temporary file name. This could not be found.

Greetings
difool

REACT 2 Released

Reply #1502
Changing back to 4 solved the problem. All i could see from debug was that the temp file could not be found. you know, after extracting the wav it is moved to a temporary file name. This could not be found.

Yes? Two days ago I warned not to use pb5.. did you miss that big red warning couple of post back?

REACT 2 Released

Reply #1503
Akkurat:
First:
i had the 5 installed two days before you left your RED WARNING
second:
perhaps i have problems with my english but tihs

. but it seems to be a problem between AutoIt (language used to code REACT) and Sony Ericsson PC Suite, I fear that all I can do is to investigate and report to AutoIt team.

hints to me that you think the problems occurs between AutoIt and the Sony Ericcson Suite _ALONE_.

Well, i'm not using the Suite and still have the Problems. Perhaps i didn't see that the command line switches and the Suite are two separate issues concerning REACT.

Greetings
difool

REACT 2 Released

Reply #1504
The red warning message is purely regarding the new prebeta.  There are two completely separate issues here:

  • REACT is not compatible with prebeta 5.
  • The Sony Ericcson Suite thing.


Until a new release of REACT you will need to roll back to prebeta 4, or not use REACT.
I'm on a horse.

REACT 2 Released

Reply #1505
Sorry if i have seem to overreact and thanks for the clarification.

Yes, that is what i wanted to tell, two issues concering react.

I'd rather stick with prebeta 4 then not using REACT 

REACT 2 Released

Reply #1506
i had the 5 installed two days before you left your RED WARNING

Ok, it seems that the issue is cleared now.. but, I always expect people to read at least couple of previous posts before posting their problems. That's why I wrote the "did you miss the warning" question, it doesn't matter if it was before or after you installed pb5. Too bad that REACT doesn't have its own forum, it would be easier to search topics instead, still, reading couple of posts back should not be a problem. Anyways, pb5 support is coming..

REACT 2 Released

Reply #1507
Hi
Couple of questions:

1. I want to add the ALBUMSORTORDER tag to my MP3's populated with the album year, so that the albums sort by year (rather than alphabetically) on my iPod. What should I add to the MP3 section of the REACT2 file to do this please.

2. Will REACT2 work on a Vista machine or are there problems. My XP machine has finally died on me and I need to continue my ripping on my newer Vista machine. Are there any particular problems I should be aware off.

Thanks

REACT 2 Released

Reply #1508
1. I want to add the ALBUMSORTORDER tag to my MP3's populated with the album year, so that the albums sort by year (rather than alphabetically) on my iPod. What should I add to the MP3 section of the REACT2 file to do this please.

I'm very noobie with lame tags, but I googled something (also your old sort problems from 2007 ), ID3v2.3.0 standard doesn't have dedicated frame for this but ID3v2.4.0 standard has TSOA frame. AND, then there is the "iTunes id3 implementation" with "Support of the (theoretically »illegal«) fields TSOA, TSOP and TSOT within ID3v2.3 tags".  You also might want to read this: Sorting tags in iTunes. For more information, googlerator is your friend.

Now my suggestion is to try tagging both, if that doesn't work, try both individually.

Were you using the image mode? Try adding these:

--user-text $q[albumsortorder]@year@$q

--frame TSOA:$q@year@$q

The metamp3 could croak with the TSOA frame..

P.S. Any "--user-text" commands need to be changed to TXXX frames in the upcoming REACT mod with the updated metamp3! (it's coming, I already have fixed some bugs/issues (incl. EAC0.99pb5 issue))

2. Will REACT2 work on a Vista machine or are there problems. My XP machine has finally died on me and I need to continue my ripping on my newer Vista machine. Are there any particular problems I should be aware off.

AFAIK, only this.

REACT 2 Released

Reply #1509
One problem. Why react writes in the filename .wav extension?


REACT config file:

Code: [Select]
[Settings]
Version=2.0.akku.b03
ImageExt=flac
ImageNaming=$artist$ - [$year$] $album$
ImageHotKey={F10}
TracksHotKey={F4}
TracksHotVal=+{F5}
VA=Various Artists
CreateCuesheet=mg
RunCoverDownloader=1
CoverDownloader=C:\Programs\AlbumArtDownloader\albumart.exe
CoverDownloaderXUI=0
CoverDownloaderLocalPath=@OutRoot@
OpenAddMetaDataDiag=0
EAC=C:\Programs\Exact Audio Copy\EAC.exe
Tools=C:\Programs\REACT2\tools
MinimizeCompressionWindow=1
ProcessPriority=1
Sla_Bks_Col_Qst_Bar_Quo_Ast_Lt_Gt=-|-|-||!|'|#|[|]
Test=0

[UserTrackFormats]
Flac=0
Wavpack=0
LameMP3=1
NeroAac=0
iTunesAac=0
OggEnc2=0
Tak=0

[UserOutputNames]
OutRoot=m:\music
ImageDir_Flac=@OutRoot@\FLAC\$cdartist$\[$year$] $album$
ImageDir_Wavpack=@OutRoot@\WV Images\$cdartist$\[$year$] $album$
ImageDir_MP3=@OutRoot@\MP3 Images\$cdartist$\[$year$] $album$
ImageDir_Tak=@OutRoot@\TAK Images\$cdartist$\[$year$] $album$
TrackDir_Flac=@OutRoot@\FLAC\$cdartist$\[$year$] $album$
TrackDir_Wavpack=@OutRoot@\WV\$cdartist$\[$year$] $album$
TrackDir_MP3=@OutRoot@\MP3\$cdartist$\[$year$] $album$
TrackDir_AAC=@OutRoot@\AAC\$cdartist$\[$year$] $album$
TrackDir_OGG=@OutRoot@\OGG\$cdartist$\[$year$] $album$
TrackDir_Tak=@OutRoot@\TAK\$cdartist$\[$year$] $album$
TrackName_SA=$track$ - $title$
TrackName_VA=$track$ - $title$ [$artist$]
TrackName_SA_acdir=$n - $~t
TrackName_VA_acdir=$n - $~t [$~a]

[UserSettings]
DebugMode=0
Debug=0
Comment=Created with EAC/@reactversion@, @curdate@
EmbedCover=1
ReplayGain=0
ApplyAlbumGain=0
AdjustAlbumGain_dB=+3.0
AddCuesheetAG=0
UseWaveGainAG=0
Opt_Flac=-8 -f
Opt_Wavpack=-hmy
Opt_LameMP3=-V0 --vbr-new --noreplaygain --nohist
Opt_NeroAac=-lc -q 0.21
Opt_iTunesAac=-d -s 2000
Opt_OggEnc2=-q 3.0
Opt_Tak=-pN -overwrite
Ver_Flac=1.2.1
Ver_Wavpack=4.40
Ver_LameMP3=3.98.2
Ver_NeroAac=1.0.0.2
Ver_OggEnc2=2.83 Lancer aoTuV b5
Ver_Tak=1.0.1

[DefaultMetaData]
discnumber=1
totaldiscs=1
discname=

REACT 2 Released

Reply #1510
One problem. Why react writes in the filename .wav extension?

Huh, hard to say. Did a bit of testing and couldn't reproduce, what a surprise.

1) Was that album really ripped with pressing F10?
2) Did you happen to notice that the filenames do NOT have the year as configured in ImageNaming INI setting? (now, I know that this is a problem for few users in Vista, the fix for it comes in the next release which is under work, I just wanted to know if you knew about this problem and/or noticed the missing year)
3) Does this happen with every rip?
4) Have you recently done some changes to your OS? REACT? (options, installed programs, etc.)
5) Are you using the newest EAC 0.99prebeta5?
6) You're using Vista or Win7? Try putting on the "file name extensions" and rip again, did that fix it?
7) If nothing helps, put DebugMode=1 in INI, rip once and post the debugging.txt file contents here.

Let's start with these.

REACT 2 Released

Reply #1511
One problem. Why react writes in the filename .wav extension?

Huh, hard to say. Did a bit of testing and couldn't reproduce, what a surprise.

1) Was that album really ripped with pressing F10?
2) Did you happen to notice that the filenames do NOT have the year as configured in ImageNaming INI setting? (now, I know that this is a problem for few users in Vista, the fix for it comes in the next release which is under work, I just wanted to know if you knew about this problem and/or noticed the missing year)
3) Does this happen with every rip?
4) Have you recently done some changes to your OS? REACT? (options, installed programs, etc.)
5) Are you using the newest EAC 0.99prebeta5?
6) You're using Vista or Win7? Try putting on the "file name extensions" and rip again, did that fix it?
7) If nothing helps, put DebugMode=1 in INI, rip once and post the debugging.txt file contents here.

Let's start with these.


1. Yes. Every album is ripped with F10. Actually i am going to re-rip my entire collection.
2. Yes. It was problem before. Its not so important as i dont need this.
3. Yes in every rip.
4. Yes. Installed new, fresh system. Completely formatted drive and created new partitions. Clean install. Vista SP2. Because of problems with EAC under W7. Or should i go with XP SP3? I can have for now dual boot if i must go this way for now. I would like to rip my entire collection this way so EAC & REACT are must have tools.
5. No i am using REACT with EAC  0.95 beta 4.
6. As said Vista SP2. i will try that. Under Windows 7 RC EAC crash.
7. Will do



REACT 2 Released

Reply #1512
Ok it seems that changing to show filename extension in explorer did work. I enabled "show filename extensions" and rip one cd. It seems to be ok.

One more question: can i somehow create that MP3 folder would have playlist created as in FLAC image folder?

REACT 2 Released

Reply #1513
Ok it seems that changing to show filename extension in explorer did work. I enabled "show filename extensions" and rip one cd. It seems to be ok.

Hmm, I tested this with my WinXPSP3 before I posted the advice and couldn't reproduce. And after studying the REACT code, I'm baffled what could be the cause of this. I suspect that the problem I mentioned in the 2nd question earlier is the one to blame.. but I'm not sure. Care to help me test this? It shouldn't take too much of your time, about 10-15 minutes. PM me your email address and I'll get back to you with instructions.

can i somehow create that MP3 folder would have playlist created as in FLAC image folder?

Default REACT doesn't create playlists. Here's a guide: REACT:Creating A Playlist. It's for track.cfg but you can do it for the image.cfg too. Remember to download Tag.exe and put in REACT Tools folder.

 

REACT 2 Released

Reply #1514
Hello Akkurat.

Can you please tell me if you plan to release an updated version of your REACT2 mod soon? There are four CDs in my collection that are problematic, and I want to rip them using EAC 0.99 Prebeta5, but I just can't do that without REACT2 and your mod.
If not, then can you please do us all a favour and release an update that fixes the compatibility issue?

Thanks.

REACT 2 Released

Reply #1515
I guess this is only useful for image ripping; however, to rip my new "Hombre Lobo" CD I fired up EAC as normal (no REACT) and ripped to uncompressed image with cue sheet.  I then ran REACT from the command line using:

Code: [Select]
REACT "<path to cue sheet>"

This is functionality that I added in 2.0.ssb16g.
I'm on a horse.

REACT 2 Released

Reply #1516
Thanks Synthetic Soul!!!

This is exactly what I am looking for. Will try this tonight.

REACT 2 Released

Reply #1517
A user asked the following by PM and I thought that it would be useful to post it and my reply here too.

Quote
I was just trying to download the REACT 2.0.ssb16p file, but my firewall won't let me.
It says that the file is infected with AutoIt.I (Worm).
Is there anywhere where I can download this without the virus?

First, that's not my mod, it's Synthetic Soul's mod. He has dropped updating his mod a while ago (though the latest update to my mod is also very old). Check this wiki page for the latest info on all mods.

2nd, I'm almost 100% sure that your firewall/antivirus is marking the file as False Positive (check the meaning from web if you don't know what it means). I've seen this with my mod as well. It seems that many lazy AV-vendors are marking ALL programs made with AutoIt language (see the FP infected name) as worm/trojan/whatever malware. This is most unfortunate and your AV-vendor and others should correct this. I've emailed many vendors already with this problem, hopefully they'll correct this problem.. but what I've seen so far, I wouldn't expect miracles.

REACT 2 Released

Reply #1518
Can you please tell me if you plan to release an updated version of your REACT2 mod soon? There are four CDs in my collection that are problematic, and I want to rip them using EAC 0.99 Prebeta5, but I just can't do that without REACT2 and your mod.
If not, then can you please do us all a favour and release an update that fixes the compatibility issue?

I posted this last Thursday: "the upcoming REACT mod with the updated metamp3! (it's coming, I already have fixed some bugs/issues (incl. EAC0.99pb5 issue))" My initial "launch date" was last weekend but, here comes the excuses , in the course of fixing couple of bugs/problems, I ran into new bugs/problems which slowed down the process (I had to test and learn why something was done in a way it was).. and then I got sick on Sunday (and I'm still sick), high fever and other influenza type of symptoms (stupid WHO and media which planted a fear of H1N1 swine flu into me). I've tried to code it further this week a bit (it's hard to concentrate when there's a constant "woo" in my head starting from the morning) and I'm positive that it comes out this weekend.. at the latest. So, it's coming soon. If you can't wait to test the new EAC, just install pb5 over pb4 (you can easily install pb4 back over pb5, I've tested) and rip your problematic CD's without REACT.. I doubt that the new version would be any better than pb4 (could be but the changelog doesn't look promising).

REACT 2 Released

Reply #1519
Code: [Select]
REACT "<path to cue sheet>"

This is functionality that I added in 2.0.ssb16g.

This works beautifully! Thanks Synthetic Soul.

...So, it's coming soon. If you can't wait to test the new EAC, just install pb5 over pb4 (you can easily install pb4 back over pb5, I've tested) and rip your problematic CD's without REACT.. I doubt that the new version would be any better than pb4 (could be but the changelog doesn't look promising).

Akkurat, hope you get better soon! I think that this new version of EAC is better than the old one. I have two more troublesome CDs (for the old v0.99pb4) to rip. I will post confirmed results in the EAC thread as soon as I finish doing this.

REACT 2 Released

Reply #1520
Finally, as promised (one hour before the day changes ), here it is!

CHANGELOG:

2.0.akku.b04 (7th June 2009)
--------------------------------
Changed files: REACT.exe, REACT.ini, REACT-image.cfg & REACT-track.cfg.
Added files - Tools: flac.exe, lame.exe, metaflac.exe & metamp3.exe.

- Fixed REACT to work with the changed EAC 0.99pb5 command line switches.
- Fixed a bug with image filenames saved sometimes incorrectly (again for the 3rd time!) in Windows Vista. The method was changed and the procedure is slightly slower now; filename will appear "one letter at a time" to the save dialog.
- Fixed cuesheet generation again; the indices and gaps detection windows were detected in wrong order. This made REACT error with CD's that had lots of track indices.
- Fixed left behind glean cuesheet file not deleted in track mode when creating normal cuesheet(s) with the INI setting.
- Fixed a tricky problem with EAC not using the changed "Use this directory" setting in image mode in certain situations. If you see REACT inserting drive+path+filename "one letter at a time" to the save dialog in image mode, don't fret, it's this fix at work.
- Fixed bad file naming scheme settings not detected by REACT in certain situations.
- Fixed a bug where long lasting and/or failing freedb query made REACT fail to "hook" to the EAC window.

- Added "check for EAClog" to track config.
- Changed the bat file delete command so that there is no quick flash of error message at the very end of both configs.
- Changed Mp3 tagging switches for the updated MetaMP3 in both configs.
- Added the fix for MetaMP3 "wildcard parse bug with filenames ending with any multiples of 2 consecutive period chars" to both configs.
- Changed disc related tagging so that both "discname" and "discnumber"/"totaldiscs" tags are written if supplied. Changed also the way the folder structure is created when both are supplied; the "discname" is in parenthesis after the "discnumber": <path>\<discnumber> (<discname>).

- REACT.ini
   - "Version" updated.
   - Changed default "UserTrackFormats" to "Flac" and "LameMP3".
   - "Opt_LameMP3" updated. Removed "--vbr-new" because it's default VBR routine with the updated LAME encoder.
   - "Ver_LameMP3" updated.
   - "Ver_Flac" updated.

- Updated FLAC to 1.2.1b (flac.exe & metaflac.exe).
- Updated LAME to 3.98.2 (lame.exe).
- Updated MetaMP3 to 0.92 beta 5 (metamp3.exe).
   - Fixes a bug with zero-padded track numbers when using only "tracknumber" in tagging.
   - Updating to this version automatically fixes the "discname" tagging bug in REACT configs.

- Changed REACT configuring (Ctrl-F2):
   - EAC "Use CD-Text information in CUE sheet generation" setting is set ON (needed with track encoding in image mode).
   - EAC "Create '.m3u' playlist on extraction" setting is set OFF.
   - EAC "Use various artist naming scheme" setting is always set ON.
   - EAC "On unknown CDs," and "automatically access online freedb database" settings are always set ON.
   - REACT now waits for the EAC process to close completely before configuring.
      - Added splash window while closing the process because it could take some time.
   - REACT will now always restart after configuring.

- Added EAC Compression Queue not supported text to the "Notes" section of the documentation.
- Added "Tools" section to documentation. Lists all updated tools used in this mod.


Download and read the manual: REACT:Mods

EDIT: Forgot to mention, CAT-QuickHeal and VBA32 antivirus programs detected the new REACT.exe as trojan (scanned in virustotal.com).. not true, false positives.. I've contacted both of these vendors and hopefully they'll fix the FPs.

REACT 2 Released

Reply #1521
I see the hard work on REACT and the mods are still ongoing.  Good to see

It has been a while for me.  My ripping machine suffered a boot drive failure and after a repair I have mostly abandoned MS for Linux.

I understand that EAC works under wine.  Any chance I might get REACT to do the same?  Or is there a similar tool/script?

REACT 2 Released

Reply #1522
I haven't heard anyone using REACT under Wine.. try it..? And tell us if it's working. Remember that there are many tools included in REACT, some of them could fail to work. Good luck.

REACT 2 Released

Reply #1523
Cheers.  It might help me learn about wine.

If some of the tools fall over maybe we can find alternatives.  This could be a challenge.

REACT 2 Released

Reply #1524
@Akkurat

Where to put code for creating playlist (MP3 files) in REACT-track.cfg?

So where to put this?
Quote
@tools@\Tag.exe --playlist --sort track --a-artist "@cdartist@" --a-title "@album@" --plname temp.m3u *.flac
REM ** Workaround for %-chars disappearing from the playlist filename when using tag.exe.
REN temp.m3u "$cdartist$ - $album$.m3u"