Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: REACT 2 Released (Read 1071190 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

REACT 2 Released

Reply #450
I see.  REACT calls albumart.exe from within the REACT script, not as part of the config.  OK.

It only has the main EAC GUI data (CD Artist, CD Album, year, etc.) at it's disposal at this time, so I think it will be safest (or perhaps the only option) to revert it to "<album>.jpg".

I will upload beta 13 ASAP.  Thanks for the heads up.
I'm on a horse.

REACT 2 Released

Reply #451
I see.  REACT calls albumart.exe from within the REACT script, not as part of the config.  OK.

It only has the main EAC GUI data (CD Artist, CD Album, year, etc.) at it's disposal at this time, so I think it will be safest (or perhaps the only option) to revert it to "<album>.jpg".

I will upload beta 13 ASAP.  Thanks for the heads up.

Hi Neil,

I kind of figured that I would not have any control over the file naming. Though, I think we did in the original REACT release (pre-REACT2).

Thanks again for your help, and for beta 13. You are the man! 


Dirk
Surf's Up!
"Columnated Ruins Domino"

REACT 2 Released

Reply #452
OK, 2.0.ssb13 is there.

I'm testing at the moment and it's going fine so far, but it needs more testing.

Thanks again for the feedback.  Out of interest, are you using the Additional Meta Data functionality, or are you solely after the few bugfixes/improvements I've made ("%" issue; "&" issue; new style log files)?

Changes from b12:
  • Reverted cover filename to "<album>.jpg" irrespective of EAC version.
I'm on a horse.

REACT 2 Released

Reply #453
Actually, I have need for all of the fixes and additional meta data functionality. Thank you for adding all of the extras.

I will try beta 13 as soon I arrive home from work. Boy, you are a quick one! 
Surf's Up!
"Columnated Ruins Domino"

REACT 2 Released

Reply #454
Actually, I have need for all of the fixes and additional meta data functionality. Thank you for adding all of the extras.

I will try beta 13 as soon I arrive home from work. Boy, you are a quick one! 
Ah, cool.  It's good to hear of someone making use of the added functionality.  That makes a total of three now I think!

I'm lucky enough to work for an "Internet" company, with people who just care if I get my work done, so I have the flexibility to trawl HA or make a quick fix and upload once in a while.
I'm on a horse.

REACT 2 Released

Reply #455
REACT 2.0.ssb13 is working perfectly with my FLAC images. Thank you, Neil.
Surf's Up!
"Columnated Ruins Domino"

REACT 2 Released

Reply #456
Good news.  Thanks for your help Dirk.
I'm on a horse.

REACT 2 Released

Reply #457
Thanks for REACT! Great tool for fast and secure ripping! I have just solved a problem with REACT: it was not working on my PC (Windows XP pro sp2 RUS) because it uses code page 1252 when running script, and Russian characters in folder name (My documents -> Мои документы) are shown wrong. I’ve only changed one string in REACT-image.cfg: CHCP 1252 -> CHCP 1251 and now it works as it should. Hope this will be useful for others who have Win XP with language different from English.

REACT 2 Released

Reply #458
Okay, I read the whole thread and now I am confused! I know that this has been already answered in this very thread, but puhleaaase answer my question:

If I set any of the following options to '1' (i.e., enable it), will this permanently (as in, permanently in a non-recoverable way), alter my FLAC images?:

ReplayGain
ApplyAlbumGain
AdjustAlbumGain_dB
AddCuesheetAG
UseWaveGainAG

I am fine with things being written out into tags, but I want to ensure that my FLAC images themselves are not modified irreversibly.

Please tell me which (if any) of the above options actually alter the audio, and not just write to FLAC/APEv2 tags.

REACT 2 Released

Reply #459
I can only quote Tycho:
OK, inputs  are noted. To tag both AG and TG but not apply them, you must set

ReplayGain=1
ApplyAlbumGain=0
UseWaveGainAG=0  ; when 1, it computes AG scale value to apply on lame while encoding. 

I will rethink how to organise the RG options in future releases.

Also, from the wiki:

ReplayGain
Enable/Disable ReplayGain calculation and tagging.
ApplyAlbumGain
Apply the album gain to the files, so they are played back with a consistent volume across the albums on every player.
AdjustAlbumGain_dB
If you want to adjust the album gain from 89.0 dB when applying to the audio, set adjustment in dB here.
AddCuesheetAG
Add Album gain/Album peak values to the cuesheet as REM lines. This implies that WaveGain is ran.
UseWaveGainAG
Instruct to use WaveGain to calculate AlbumGain values on the wav image file. The values will be transferred to the various compressed formats, rather than calculating them via other tools. If ApplyAlbumGain=1, LAME and OggEnc2 will use the --scale option to apply the album gain scale factor calculated by WaveGain.

I don't use RG, but I think the above all adds up.
I'm on a horse.

 

REACT 2 Released

Reply #460
All,

Long time EAC user and somehow missed this great tool!! Thanks to all who have made this possible. I have tested the REACT 2.0.ssb13 version and everything works fine with the exception of my CUE sheets not being moved over as they were before. But I can confirm that the log file is being moved over correctly.

One more question... I tried searching but could not come up with anything.

I copied over 1.1.4 FLAC binaries (flac.exe, libflac.dll and metaflac.exe) and changed the ini to 1.1.4 and compression will not work with these binaries. Is there any way to get 1.1.4 to work with REACT?

Thanks.


Bryan

REACT 2 Released

Reply #461
Are you ripping to tracks or image?  Can we see the config code that deals with the cuesheet please?

There should be no reason why FLAC 1.1.4 will not work.  Does the binary work OK from the command line?

Edit: Ah, I see.  REACT-track.cfg uses "@albumfile@.
  • .cue".  This will actually end up as "<artist> - <album>.
  • .cue", when REACT actually creates "<album>.
  • .cue".  Can you confirm that you are using @albumfile@?

    Edit 2:  After refreshing myself with the source I'm not sure what the resolve is.  The confusion is with the @albumfile@ token.  Currently it follows the log format, so for EAC < 0.99 it will be "<album>", and for 0.99 + it will have the same name as the image for image rips, and "<artist> - <album>" for track rips.
I'm on a horse.

REACT 2 Released

Reply #462
Are you ripping to tracks or image?  Can we see the config code that deals with the cuesheet please?

There should be no reason why FLAC 1.1.4 will not work.  Does the binary work OK from the command line?


I am ripping to an image (F10). The only config stuff I have messed with is the .ini file. Below is what I have:

Code: [Select]
[Settings]
Version=2.0
ImageExt=wav
ImageNaming=$artist$ - [$year$] $album$
ImageHotKey={F10}
TracksHotKey={F4}
TracksHotVal=+{F5}
VA=Various Artists
CreateAllCuesheets=1
RunCoverDownloader=1
CoverDownloader=C:\Program Files\REACT2\coverdownloader\albumart.exe
EAC=C:\Program Files\Exact Audio Copy\EAC.exe
Tools=C:\Program Files\REACT2\tools
MinimizeCompressionWindow=1
ProcessPriority=1
Sla_Bks_Col_Qst_Bar_Quo_Ast_Lt_Gt=-|-|-||!|'|#|[|]

[UserTrackFormats]
Flac=1
Wavpack=0
LameMP3=0
NeroAac=0
iTunesAac=0
OggEnc2=0

[UserOutputNames]
OutRoot=@mymusic@\EAC
ImageDir_Flac=@OutRoot@\FLAC-images\$cdartist$
ImageDir_Wavpack=@OutRoot@\WV-images\$cdartist$
ImageDir_MP3=@OutRoot@\MP3-images\$cdartist$
TrackDir_Flac=@OutRoot@\FLAC\$cdartist$\[$year$] $album$
TrackDir_Wavpack=@OutRoot@\WV\$cdartist$\[$year$] $album$
TrackDir_MP3=@OutRoot@\MP3\$cdartist$\[$year$] $album$
TrackDir_AAC=@OutRoot@\AAC\$cdartist$\[$year$] $album$
TrackDir_OGG=@OutRoot@\OGG\$cdartist$\[$year$] $album$
TrackName_SA=$track$ - $title$
TrackName_VA=$track$ - $title$ [$artist$]
TrackName_SA_acdir=$n - $~t
TrackName_VA_acdir=$n - $~t [$~a]

[UserSettings]
Debug=0
Comment=Created with EAC/REACT2, @curdate@
EmbedCover=1
ReplayGain=0
ApplyAlbumGain=0
AdjustAlbumGain_dB=+3.0
AddCuesheetAG=0
UseWaveGainAG=0
Opt_Flac=-6 -f
Opt_Wavpack=-hmy
Opt_LameMP3=-V5 --vbr-new --noreplaygain --nohist
Opt_NeroAac=-lc -q 0.21
Opt_iTunesAac=-d -s 2000
Opt_OggEnc2=-q 3.0
Ver_Flac=1.1.3
Ver_Wavpack=4.40
Ver_LameMP3=3.97
Ver_NeroAac=1.0.0.2
Ver_OggEnc2=2.83 Lancer aoTuV b5


and the meta.ini:
Code: [Select]
[Current]
discnumber=1
totaldiscs=1
discname=


In doing a diff on the source, the only stuff I see that deals differently with CUE's is:

Code: [Select]
; Add additional meta data to all track cuesheets
        fLoadMetaDataFromIni()
        fLoadAndResaveCuesheet($gui_albumfile & ".[s].cue")
        fLoadAndResaveCuesheet($gui_albumfile & ".[mg].cue")
        fLoadAndResaveCuesheet($gui_albumfile & ".[m].cue")
        fLoadAndResaveCuesheet($gui_albumfile & ".[mc].cue")
    EndIf


And yes, the 1.1.4 FLAC binary I used can encode form the command line.

Thanks for the help.


Bryan

EDIT:
Just reverted to original 2.0 binary and CUE's were copied correctly and log was not (expected behavior). This is also in EAC 0.99pb1.

REACT 2 Released

Reply #463
If using ACDIR, it will not work with the new libflac.dll. The only libflac file that seems to work is the one that is packaged with the ACDIR binary.
Surf's Up!
"Columnated Ruins Domino"

REACT 2 Released

Reply #464
If using ACDIR, it will not work with the new libflac.dll. The only libflac file that seems to work is the one that is packaged with the ACDIR binary.


Thanks for the info.

REACT 2 Released

Reply #465
OK, you are ripping to an image, but you are also creating the four cuesheets by specifying CreateAllCuesheets=1 in your INI.  Any reason for this?  You only really need to do this for track rips.

The token @cuesheet@ should still work.  As reported above (I was editing a second time when you posted so you may want to re-read) the @albumfile@ token is going to be working differently now.  I see this is used in the track sections of REACT-image.cfg. Is this where you are experiencing issues?  As you are ripping to an image @albumfile@ will (I suppose wrongly, considering its name) actually follow the image name, i.e.: "$artist$ - [$year$] $album$".  Therefore "@albumfile@.
  • .cue" will not work, as it refers to "$artist$ - [$year$] $album$.
  • .cue" rather than "$album$.
  • .cue".

    I get the impression that perhaps you are ripping to an image but to create track files (for album gain purposes)?

    In doing a diff on the source, the only stuff I see that deals differently with CUE's is:

    Code: [Select]
    ; Add additional meta data to all track cuesheets
            fLoadMetaDataFromIni()
            fLoadAndResaveCuesheet($gui_albumfile & ".[s].cue")
            fLoadAndResaveCuesheet($gui_albumfile & ".[mg].cue")
            fLoadAndResaveCuesheet($gui_albumfile & ".[m].cue")
            fLoadAndResaveCuesheet($gui_albumfile & ".[mc].cue")
        EndIf
    Yeah, I'm 99% sure that this change is not relevant in this issue.  I think @albumfile@ is the culprit.

    I had to make changes with regard to @albumfile@ due to the new log naming schemes.  However, I wonder whether I should use some other token and keep @albumfile@ as it was, so that it can be used in this instance.  I think it is the only place that it is really used.
I'm on a horse.

REACT 2 Released

Reply #466
OK, you are ripping to an image, but you are also creating the four cuesheets by specifying CreateAllCuesheets=1 in your INI.  Any reason for this?  You only really need to do this for track rips.

I get the impression that perhaps you are ripping to an image but to create track files (for album gain purposes)?


I guess I should spend some more time learning the program 

I was doing cuesheets b/c that's what I have always done and when ripping to an image and setting FLAC=1, I assumed I needed cuesheets if I wanted to make a copy of the disc at some future date. I guess I just need to set the image type to 'flac'.

I just tried ripping to tracks (F4) and FLAC 1.1.4 DOES work but I still see the same behavior with the cuesheets and when watching the temp directory I see the .log file, and when everything finishes it disappears and is NOT being moved to the final directory.

I need to tinker some more with the program. I'll do more testing and report back once I think I have a better grasp on how everything works.

Thanks.


Bryan

REACT 2 Released

Reply #467
If you are ripping to an image then the image cuesheet, accessed using @cuesheet@, is automatically createdYou do not need to tell REACT to create them by all specifying CreateAllCuesheets=1; this is normally used when ripping to tracks.

You do need a cuesheet.

I am going to release another version of my mod in the next few hours (possibly in the next half hour).  I will revert @albumfile@ to represent "<source directory>\<album>", as I think this makes most sense - given the token's name! I am now using @logfile@ for what was previously @albumfile@, where "@logfile@.log" == "@eaclog@".
I'm on a horse.

REACT 2 Released

Reply #468
If you are ripping to an image then the image cuesheet, accessed using @cuesheet@, is automatically createdYou do not need to tell REACT to create them by all specifying CreateAllCuesheets=1; this is normally used when ripping to tracks.

You do need a cuesheet.

I am going to release another version of my mod in the next few hours (possibly in the next half hour).  I will revert @albumfile@ to represent "<source directory>\<album>", as I think this makes most sense - given the token's name! I am now using @logfile@ for what was previously @albumfile@, where "@logfile@.log" == "@eaclog@".


Thanks for the clarification. I appreciate your help and prompt responses.


Bryan

REACT 2 Released

Reply #469
OK, I have reverted @albumfile@ to represent "<sourcedir>\<album>", irrespective of the EAC version.

What was (incorrectly, given the token name) @albumfile@ is now @logfile@, where "@logfile@.log" == "@eaclog@" (i.e.: it is the path to the log file without the file extension).  I can't see @logfile@ being any use, but it's available. 

I think this makes most sense: @albumfile@ does now again refer to a file using the album name.

2.0.ssb15

Changelog:
  • Reverted @albumfile@ to "<sourcedir>\<album>", irrespective of the EAC version.
  • Add Test=1 under the Settings section of the REACT ini to use Test and Copy with F4/F10.
NB: ssb14 was something I was working on at home, and has now been incorporated into ssb15.  The Test setting has been tested, but not exhaustively so.  I thought I may as well throw it into ssb15, from ssb14, though. All feedback welcome.  To clarify: Set Test=1 and then hitting F10 will run "Test & Copy Image & Create CUE Sheet" and F4 will run "Test & Copy Selected Tracks".
I'm on a horse.

REACT 2 Released

Reply #470
Hi Neil,

I set Test=1 and hit F10 and "Test & Copy Image & Create CUE Sheet" ran perfectly. Thanks for adding that!
Surf's Up!
"Columnated Ruins Domino"

REACT 2 Released

Reply #471
Have tested out 2.0.ssb15 and everything works as I had hoped. After spending some time reading over the source and CFG files everything is now becoming clearer as to how everything ties together.

Thanks for the help.


Bryan

REACT 2 Released

Reply #472
I set Test=1 and hit F10 and "Test & Copy Image & Create CUE Sheet" ran perfectly. Thanks for adding that!
 
Have tested out 2.0.ssb15 and everything works as I had hoped. After spending some time reading over the source and CFG files everything is now becoming clearer as to how everything ties together.

Thanks for the help.
I've just got up.  Nice to wake up to some good news and polite members!  You're both welcome.  Thanks for testing Dirk.
I'm on a horse.

REACT 2 Released

Reply #473
Started using eac 0.99pb1 and Synthetic Souls's ssb15 mod that creates wavpack and mp3's, works great but i have a query.
React moves my album art and log to the newly ripped wavpack dir which is fine, but i would also like it if the album art could also be copied to the newly created mp3 album, is this possible?

Also embedding album art doesn't seem to work for me, i'm hitting F10 and ripping to separate tracks for mp3 and wavpack. What i would really like is to embed album art into the separate files and also keep a copy in the album folder, is this possible?

REACT 2 Released

Reply #474
React moves my album art and log to the newly ripped wavpack dir which is fine, but i would also like it if the album art could also be copied to the newly created mp3 album, is this possible?
Yes.  However, looking at REACT-image.cfg it looks like it should be copied to both by default.  Confused.

Also embedding album art doesn't seem to work for me, i'm hitting F10 and ripping to separate tracks for mp3 and wavpack. What i would really like is to embed album art into the separate files and also keep a copy in the album folder, is this possible?
Do you have EmbedCover set to 1 in the UserSettings section of REACT.ini?  I believe I'm right in saying that, with that setting, you will have the album art embedded and copied.
I'm on a horse.

 
SimplePortal 1.0.0 RC1 © 2008-2021