Skip to main content

Topic: Current wisdom about LAME/VBR Track Duration Issue (Read 4943 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • maggior
  • [*][*][*]
Current wisdom about LAME/VBR Track Duration Issue
I am coming back to mp3 after having used ATRAC and Sony equipment for some time.  The new iPods with gapless support have brought me back.

I'm figuring out what I need to do and how to use the tools before I go hog-wild encoding all of my CDs.

One thing I haven't sorted out is what the best/suggested way to handle the issue related to the track duration issue with VBR files created by LAME. 

I wasn't surprised to see that iTunes displayed the durations incorrectly, but when foobar2000 did too, I was surprised.

I've done some reading and the usage of vbrfix.exe comes up again and again.  I also see where this utility trashes the LAME tags in the file.  It's not clear to me if this should be used.

So my questions are:
1) Should I use vbrfix.exe on all VBR mp3s I encode?  I listen to a lot of electronic, jazz, and prog music so most of the music I encode will be above the 10 min. mark.
2) Will vbrfix.exe clobber gapless info?
3) Why does this happen and why can't it be fixed in the LAME encoder itself?
4) If proper duration information is really important, should I just use CBR?

Thanks in advance for your help.

Current wisdom about LAME/VBR Track Duration Issue
Reply #1
I've never seen Foobar report times incorrectly with any LAME files in my years.  Have you tried the "Fix VBR MP3 Header" option under Utilities in the right click context menu?  It's new to me and I've never needed it but make a copy of the files and try it.
"Have you ever been with a woman? It's like death. You moan, you scream and then you start to beg for mercy, for salvation"

  • maggior
  • [*][*][*]
Current wisdom about LAME/VBR Track Duration Issue
Reply #2
Last night, I transcoded some files from FLAC to LAME mp3 using foobar2000.  Now that I know that I can encode files without them having to be all on the command line for gapless, this is an option.

The resulting mp3s showed proper duration in foobar, iTunes, and Sonic Stage.   

I guess that when encoding mp3s within foobar2000 it automatically does the "fix mp3 vbr header" operation.

So now I have something that works.

I'm curious though why this hasn't been addressed in lame.exe itself.  Anything else seems to be either a patch or a work-around.

Cheers!

  • evereux
  • [*][*][*][*][*]
Current wisdom about LAME/VBR Track Duration Issue
Reply #3
I suspect the process/tools you used to create the MP3s is at fault somehow, not the LAME encoder. Could you elaborate?
daefeatures.co.uk

  • maggior
  • [*][*][*]
Current wisdom about LAME/VBR Track Duration Issue
Reply #4
I suspect the process/tools you used to create the MP3s is at fault somehow, not the LAME encoder. Could you elaborate?


I was using ALL2LAME previously.  All it does is create a batch file which executes LAME from the command line.  When I used files encoded this way (with -V2), the duration of the file would be something strange, such as over an hour for a 20 min. song.  It would play OK though.

When I use foobar2000 set the same way - to generate files using the -V2 option, this problem does not occur.

I've read in past posts that this could be fixed either by using vbrfix or some option in foobar2000.  But, it seems that just by doing the encoding in foobar2000 avoids the problem.

I'm just trying to understand why.

Hope that makes it clearer.

Cheers.
  • Last Edit: 29 September, 2006, 03:47:52 PM by maggior

  • stephanV
  • [*][*][*][*]
Current wisdom about LAME/VBR Track Duration Issue
Reply #5
Using lame.exe from commandline creates files with correct times in foobar2000 for me. I don't see the problem.
"We cannot win against obsession. They care, we don't. They win."

  • evereux
  • [*][*][*][*][*]
Current wisdom about LAME/VBR Track Duration Issue
Reply #6
maggior, you don't say how you ripped the audio?

If you don't use EAC, try it and report back since the initial problem you state is encoding from CD? This should at least show you ALL2LAME is OK.
daefeatures.co.uk

  • maggior
  • [*][*][*]
Current wisdom about LAME/VBR Track Duration Issue
Reply #7
maggior, you don't say how you ripped the audio?

If you don't use EAC, try it and report back since the initial problem you state is encoding from CD? This should at least show you ALL2LAME is OK.


The audio was originally ripped using EAC.  I've archived them in flac.  When using ALL2LAME, I would convert the flac files to wave and then drag them into ALL2LAME.  When using foobar2000, I just brought the flac files into it and right clicked and chose to transcode to LAME.

This problem only occurs with VBR files and with files that are lengthy (10 min. or so longer).  This is based on my reading in other threads on this issue and on my personal experience.
  • Last Edit: 29 September, 2006, 09:02:14 PM by maggior

  • Never_Again
  • [*][*][*][*][*]
  • Members (Donating)
Current wisdom about LAME/VBR Track Duration Issue
Reply #8
Was the Gapless checkbox ticked.