Skip to main content

Topic: LAME 3.97 released (Read 45930 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Demetris
  • [*][*][*]
LAME 3.97 released
Reply #25
Thanks to the LAME developers, to all the testers and issue-reporters, and to those who compile for us!

  • ddrawley
  • [*][*][*][*]
  • Members (Donating)
LAME 3.97 released
Reply #26
Please ignore, my question was already answered.
  • Last Edit: 25 September, 2006, 10:53:39 AM by ddrawley

  • BinaryTB
  • [*]
LAME 3.97 released
Reply #27
I ask this every release, but how long until we stop needing the "lame.exe fixed for decoding through stdout" version?  I mean, I guess the fix has been around for a while, but I don't understand why there is a separate compile every time there is a new version instead of just fixing the regular release version.

  • k.eight.a
  • [*][*][*][*]
LAME 3.97 released
Reply #28
I ask this every release, but how long until we stop needing the "lame.exe fixed for decoding through stdout" version?  I mean, I guess the fix has been around for a while, but I don't understand why there is a separate compile every time there is a new version instead of just fixing the regular release version.
I wonder about the same issue too...
Sorry for my poor English, I'm trying to get better... ;)
"The greatest trick the Devil ever pulled, was convincing the world he didn't exist."

  • krmathis
  • [*][*][*][*][*]
LAME 3.97 released
Reply #29
LAME 3.97 for Mac OS X (Universal binary).
Feel free to host it on RareWares!

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.97 released
Reply #30
LAME 3.97 for Mac OS X (Universal binary).
Feel free to host it on RareWares!

Now at Rarewares, thanks a lot.
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • krmathis
  • [*][*][*][*][*]
LAME 3.97 released
Reply #31
Now at Rarewares, thanks a lot.

My pleasure!

  • Martin H
  • [*][*][*][*][*]
LAME 3.97 released
Reply #32
I ask this every release, but how long until we stop needing the "lame.exe fixed for decoding through stdout" version?  I mean, I guess the fix has been around for a while, but I don't understand why there is a separate compile every time there is a new version instead of just fixing the regular release version.
I wonder about the same issue too...

The fix for decoding MP3s gaplessly ie. modifying the decoder to also remove the trailing padding, and for decoding through stdout has been added to CVS and are included in the latest LAME v3.98 alpha ie. LAME v3.98a6.
  • Last Edit: 25 September, 2006, 06:58:51 PM by Martin H

LAME 3.97 released
Reply #33
Woo hoo, and I was going to reencode all my FLAC files so here's hoping dbpowerAMP gets sorted with 3.97 soon!!
You can replace lame_enc.dll in illustrate/dbpoweramp/compression/lame/ with the new version.  Or you can use the generic cli plugin and use lame.exe.

I'll be getting 3.97 final going with dbpoweramp myself later on.

Thanks to the devs!
Vorbis-q0-lowpass99
lame3.93.1-q5-V9-k-nspsytune

  • Mgz
  • [*][*][*]
LAME 3.97 released
Reply #34
those winamp 5.25 guy better make an update quick then

they just add lame 3.97beta something a week ago or so
still LAME 3.96.1 --preset extreme -q 0 -V 0 -m s at least until 2005.

  • spoon
  • [*][*][*][*][*]
  • Administrator
LAME 3.97 released
Reply #35
The R12 alpha will get 3.97 (non beta) early next week.

  • Maurits
  • [*][*][*][*]
LAME 3.97 released
Reply #36

LAME 3.97 for Mac OS X (Universal binary).
Feel free to host it on RareWares!

Now at Rarewares, thanks a lot.

Thanks krmathis and john33!

By the way, it deserves to be mentioned in the Wiki as well: http://wiki.hydrogenaudio.org/index.php?ti...and_source_code
There is a hidden message in the song at approximately 4:32. If played at half speed, Waters can be heard to say, "That was pretty avant-garde, wasn't it?"

  • probedb
  • [*][*][*][*][*]
LAME 3.97 released
Reply #37
Woo hoo, and I was going to reencode all my FLAC files so here's hoping dbpowerAMP gets sorted with 3.97 soon!!
You can replace lame_enc.dll in illustrate/dbpoweramp/compression/lame/ with the new version.  Or you can use the generic cli plugin and use lame.exe.

I'll be getting 3.97 final going with dbpoweramp myself later on.


Excellent, thanks for this I shall give it a go

  • krmathis
  • [*][*][*][*][*]
LAME 3.97 released
Reply #38
Thanks krmathis and john33!

You are most welcome!

Quote
By the way, it deserves to be mentioned in the Wiki as well: wiki.hydrogenaudio.org

Then edit the Wiki yourself, and add the information you want in there...

  • DrO
  • [*][*]
LAME 3.97 released
Reply #39
those winamp 5.25 guy better make an update quick then

they just add lame 3.97beta something a week ago or so

that's not quite true since the recent lame builds have been in the 5.25betas for most of the ~2month public beta run and the final version is already in internal builds so not something to worry about i think, heh

-daz

  • ZinCh
  • [*][*][*]
LAME 3.97 released
Reply #40
thanks for your work!

can you also add *NIX version to rarewares ? (plus freebsd , linux , other compliation ?)

  • Alex B
  • [*][*][*][*][*]
LAME 3.97 released
Reply #41
Is there any particular reason why lame.exe in the Rarewares 3.97 bundle is now 508 KB. In the 3.97b3 package it was only 263 KB.

I guess it is not compressed similarly, but what is the benefit of the change?


Edit: fixed the size 512 KB -> 508 KB
  • Last Edit: 30 September, 2006, 05:23:00 PM by Alex B

  • jmartis
  • [*][*][*][*]
LAME 3.97 released
Reply #42
probably a noob question too, but are there any improvements from 3.97b3 > 3.97 final or is 3.97 final basically the same as 3.97b3?

  • DrO
  • [*][*]
LAME 3.97 released
Reply #43
Alex B: i believe the upx compression was removed since despite using more space on disk, it's better on the system when loaded into memory when it's run (can't find the few posts where it was described off hand)

jmartis: it should be the same as 3.97b3 (think it was mentioned at the start of the thread)

-daz

  • Alex B
  • [*][*][*][*][*]
LAME 3.97 released
Reply #44
I think I found the answer. It wasn't far away.

Actually, this appears to have been a problem with compressing VC8/ICL9.1 compiles with UPX. It is easily reproducable simply by compressing and decompressing. The compressed version fails, and then decompressing it produces a version that works!!

Looks like I either abandon UPX, or test each time I compress - tedious.

Looks like he abandoned UPX. 

  • john33
  • [*][*][*][*][*]
  • Developer
LAME 3.97 released
Reply #45
I think I found the answer. It wasn't far away.

Looks like he abandoned UPX. 

Yep!!
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/

  • xmixahlx
  • [*][*][*][*][*]
LAME 3.97 released
Reply #46
fresh lame compiles have been added to RareWares/Debian:

lame, lame-3.97, lame-cvs


later

  • Bourne
  • [*][*][*][*][*]
  • Banned
LAME 3.97 released
Reply #47
I have just upgraded to foobar 0.9.4 and lame final 3.97. Converting FLAC files to mp3 now returns error code 1. Back to the good ole versions of foobar (0.9.1) and lame (3.97b2).
  • Last Edit: 04 October, 2006, 04:19:47 PM by Bourne

  • Sunhillow
  • [*][*][*][*]
  • Members (Donating)
LAME 3.97 released
Reply #48
Better change only 1 parameter at a time, so you can see which change produces the fault

  • Bourne
  • [*][*][*][*][*]
  • Banned
LAME 3.97 released
Reply #49
the parameters are the foobar2k ones default... and yes, I tried that in the command line...
i suppose it's just broken?

it's a funny thing though... it didn't happen initially... I got to convert about 3 albums from FLAC to MP3.
it's just that 2 days after I upgraded the lame.exe in foobar2k it just couldn't do it anymore...
  • Last Edit: 04 October, 2006, 04:43:52 PM by Bourne