Skip to main content

Topic: iTunes playback problem with FLAC to LAME VBR files (Read 6231 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • knoxcr
  • [*]
iTunes playback problem with FLAC to LAME VBR files
I know I'll be flamed for using iTunes, but I'm on a Mac and it's my player of choice.

I'm having some trouble playing back files that have been decoded from FLAC and encoded to LAME VBR.  If at any point I try to advance in the track while playing (for example by dragging the slider ahead through the track to 30 seconds from the end), the last few seconds of the track seem to get cut off.

Note: You need to have a track that contains audio to the absolute end of the track or you may not notice.  The track I am using is "Trip Like I Do" by The Crystal Method.

If I just leave it alone (don't fast forward at all), it will play through just fine.  Even more confusing if I go directly from CD to LAME VBR, I can fast forward through the track and have it play fine.  Something seems to be happening in the FLAC to LAME VBR process.  Playback seems OK in other players as well with fast forwarding.  I've tested foobar 2000 and winamp on Windows and the Finder on Mac OS X seems to playback just fine while fast forwarding.  It's just iTunes on both Windows and Macs with files that have been converted from FLAC to LAME.  Any ideas?

  • saratoga
  • [*][*][*][*][*]
iTunes playback problem with FLAC to LAME VBR files
Reply #1
Sounds like the issue in this thread:

http://www.hydrogenaudio.org/forums/index....opic=45684&st=0

Seeing as I can't seem to get this to happen with iTunes, and you can't get it to happen with some LAME files, I tend to think its some obscure iTunes bug that only occurs with certain combinations of iTunes versions and LAME builds.

  • ffooky
  • [*][*][*][*]
iTunes playback problem with FLAC to LAME VBR files
Reply #2
What method(s) are you using to go CD->LAME VBR and FLAC->LAME VBR ?

  • knoxcr
  • [*]
iTunes playback problem with FLAC to LAME VBR files
Reply #3
What method(s) are you using to go CD->LAME VBR and FLAC->LAME VBR ?


I'm using EAC to go from CD->LAME VBR.  And for FLAC->LAME VBR, I've used Frontah on Windows, decoded to a WAV file on the command line and given that to EAC, and Max on Mac OS X.  All with the same results.

  • knoxcr
  • [*]
iTunes playback problem with FLAC to LAME VBR files
Reply #4
I just wanted to let anyone know who cared that I was able to fix the problem I've been seeing with vbrfix on Windows.  There appears to be a Mac OS X version, but I have not tested it yet.

  • ffooky
  • [*][*][*][*]
iTunes playback problem with FLAC to LAME VBR files
Reply #5
I'm using EAC to go from CD->LAME VBR.  And for FLAC->LAME VBR, I've used Frontah on Windows, decoded to a WAV file on the command line and given that to EAC, and Max on Mac OS X.  All with the same results.


I've never encountered this problem, though I don't use MP3 much personally.

FWIW, I've always either gone FLAC->WAV with xACT or FLAC 1.1.2 on the command line and then to LAME MP3 with iTunes-LAME (3.97) or straight FLAC->LAME with:
Code: [Select]
for f in *.flac; do flac -c -d "$f" \
| lame -V 2 --vbr-new - "${f%%.*}.mp3"; done

  • sTisTi
  • [*][*][*][*]
iTunes playback problem with FLAC to LAME VBR files
Reply #6
I just wanted to let anyone know who cared that I was able to fix the problem I've been seeing with vbrfix on Windows.

That's what I find so strange about the whole problem - there seems to be nothing wrong with the Lame files, as  different versions were tested, all of which worked without problems with all other players. So what does vbrfix fix if nothing seems to be wrong with the encodings themselves??
Proverb for Paranoids: "If they can get you asking the wrong questions, they don't have to worry about answers."
-T. Pynchon (Gravity's Rainbow)