Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_run (Read 531491 times) previous topic - next topic
ptk and 1 Guest are viewing this topic.

Re: foo_run 0.3.8

Reply #700
How can I open selected files with Serato? I also have foo_run_group, but I can't find a solution.
Thanks in advance , if anyone can help.

Quote
"C:\Program Files '('x86')'\Audacity\audacity.exe" "%_path%"

Edit to real path
Quote
"C:\Program Files '('x86')'\Serato\Serato.exe" "%_path%"
Use the answer from previous reply but replacing audacity path with serato path. If Serato is able to load files with command line, that should work. Otherwise it's a limitation of Serato. Try it first on command line, what works there... works on foo_run (translating full file path to "%_path%")

Re: foo_run 0.3.8

Reply #701

Edit to real path
Quote
"C:\Program Files '('x86')'\Serato\Serato.exe" "%_path%"
Use the answer from previous reply but replacing audacity path with serato path. If Serato is able to load files with command line, that should work. Otherwise it's a limitation of Serato. Try it first on command line, what works there... works on foo_run (translating full file path to "%_path%")
[/quote]
@regor, I use Serato for x64 so it will be like this : "C:\Program Files\Serato\Serato DJ Pro\Serato DJ Pro.exe" "%_path%"
Serato opens indeed but without opening any file ( I tried with command line too but the result is the same), just starts and that's it. This is a solution that I was looking for a long time, but unfortunately without any result. It seems it might be a limitation of Serato....
What I wanted was to select let's say 10 . or 30 (or any number) files and open the files in Serato.
I was hoping that maybe it would be possible with foo_run_group (this component allows you to open a group of selected files)

Re: foo_run 0.3.8

Reply #702

Edit to real path
Quote
"C:\Program Files '('x86')'\Serato\Serato.exe" "%_path%"
Use the answer from previous reply but replacing audacity path with serato path. If Serato is able to load files with command line, that should work. Otherwise it's a limitation of Serato. Try it first on command line, what works there... works on foo_run (translating full file path to "%_path%")
@regor, I use Serato for x64 so it will be like this : "C:\Program Files\Serato\Serato DJ Pro\Serato DJ Pro.exe" "%_path%"
Serato opens indeed but without opening any file ( I tried with command line too but the result is the same), just starts and that's it. This is a solution that I was looking for a long time, but unfortunately without any result. It seems it might be a limitation of Serato....
What I wanted was to select let's say 10 . or 30 (or any number) files and open the files in Serato.
I was hoping that maybe it would be possible with foo_run_group (this component allows you to open a group of selected files)

If it doesn't work on command line, then you are out of luck. This plugin only uses command line under the hood. It's a problem by Serato (you may ask at support to implement command line file loading).

Re: foo_run 0.3.8

Reply #703
I'm way in over my head here trying to write a powershell equivalent to a Linux command I use (using wsl) for someone without wsl.

I've got the command working from Powershell:
Code: [Select]
(& 'C:\Program Files\_personalInstalls\_portable\encoders\flac\metaflac.exe' --show-tag CUESHEET --no-utf8-convert 'D:\MUSIC.conversion\FLAC\Coldplay - Music Of The Spheres.flac' | ? {$_.trim() -ne '' }).replace('cuesheet=', '').replace('CDImage.wav', 'Coldplay - Music Of The Spheres.flac') | Set-Content 'D:\MUSIC.conversion\FLAC\Coldplay - Music Of The Spheres.cue'

and by prefixing and quoting it I can get it working from a command prompt
Code: [Select]
powershell -command "above code here"
But I can't get it working from foo_run.

If I add -noexit I can see that it's opening a powershell session, but it doesn't seem to do anything.

 

Re: foo_run 0.3.8

Reply #704
Is there any way to open multiple URLs with something like this below or do I have to go the batch file route? You can do two commands in a batch file so I thought it may be possible to do this with foo_run. See the answer on SO here for running two commands.

PS: I've removed the escaping for clarity in the example below.

Code: [Select]
https://www.google.com/search?q=%artist% & https://duckduckgo.com/?q=%artist%

Re: foo_run 0.3.8

Reply #705
Is there any way to open multiple URLs with something like ...

Yup, there is. cmd window flashes but I guess there's a PowerShell way.

Code: [Select]
cmd /c echo|start "" https://www.google.com/search?q=rickroll & start "" https://duckduckgo.com/?q=rickroll

Fixed and no cmd window flashes with this bit of extraordinary code:
Code: [Select]
cmd /c start /min start "" https://www.google.com/search?q=sorted & cmd /c start /min start "" https://duckduckgo.com/?q=sorted

Re: foo_run 0.3.8

Reply #706
Sorry for spamming. Can't edit the last post.

This one works as it will close the cmd window afterwards.

Code: [Select]
cmd /c start /min start "" https://www.google.com/search?q=sorted ^& start "" https://duckduckgo.com/?q=sorted ^& exit

Re: foo_run 0.3.8

Reply #707
It's been a while, but I've just released foo_run 0.4.0 8)

It's a release to address the changes to be introduced with foobar2000 v2 and comes with these additions

  • NEW: added dark mode support under foobar2000 v2.0.
  • NEW: added 64-bit version for 64-bit foobar2000 v2.0.
  • CHG: updated to the latest foobar2000 SDK.

You can get it via the link from the first post.

Re: foo_run 0.4.0

Reply #708
@Florian Many Thanks.This is very useful.
Can I request a group function?

e.g.

-Search
--Google Artist
--Amazon Artist + ALBUM
--Last.fm Artist Info

-Tool
--Mp3tag Artist-ALBUM Open Folder
--AlbumArtDownloaderXUI Albumart Search + Save

Thanks.
SHURE SRH1840, SENNHEISER HD660S, Beyerdynamic DT 1990 PRO, HIFIMAN HE5se, Ultrasone Performance 880, AKG K712 PRO, Bowers & Wilkins P7, SONY MDR-1AM2, Bose QuietComfort 45, SONY WH-1000XM3 (made a Upgrade/Balanced Cable by myself) Shall I write more?

Re: foo_run 0.4.0

Reply #709
It's been a while, but I've just released foo_run 0.4.0 8)

It's a release to address the changes to be introduced with foobar2000 v2 and comes with these additions

  • NEW: added dark mode support under foobar2000 v2.0.
  • NEW: added 64-bit version for 64-bit foobar2000 v2.0.
  • CHG: updated to the latest foobar2000 SDK.

You can get it via the link from the first post.

Brilliant, thank you.  Just imported my config from Foobar 1.6 so that I can set up all my keyboard shortcuts, etc.  Crucial for 2.0!

Re: foo_run 0.4.0

Reply #710
Another update! I've just released foo_run 0.4.1, which adds support for currently playing item info.

You can get it via the link from the first post.

Re: foo_run 0.4.1

Reply #711
stopped working for radio streams %URL%


Re: foo_run 0.4.1

Reply #713
Doesn't work in foobar2000 v1.6.12


Re: foo_run 0.4.1

Reply #715
Seems like I'm getting the hang of it! I've just released foo_run 0.4.2, which fixes some metadata fields missing under foobar2000 v1.6.12.

Thanks for reporting @kutuzof and for confirming @marc2k3 !!

You can get it via the link from the first post.


Re: foo_run

Reply #716
I lose all menu entries of Run services when switch from 32-bit to 64-bit. I still keep old config thankfully. Although import and export is one way to migrate the config, is it possibe to keep them when switch from 32-bit to 64-bit? thanks :)


Re: foo_run

Reply #718
Hi :) @Florian

After installing "Run services 0.4.3":
All "foobar2000 v2.0 beta 32bit 64bit" settings have been deleted.

There is no problem for those who want to take over the settings of "foobar2000 v1.6.12 (foo_run.dll.cfg)".

Automatic updates are dangerous.
Run Services
https://www.foobar2000.org/components/view/foo_run
SHURE SRH1840, SENNHEISER HD660S, Beyerdynamic DT 1990 PRO, HIFIMAN HE5se, Ultrasone Performance 880, AKG K712 PRO, Bowers & Wilkins P7, SONY MDR-1AM2, Bose QuietComfort 45, SONY WH-1000XM3 (made a Upgrade/Balanced Cable by myself) Shall I write more?

Re: foo_run

Reply #719
Hello,
I noticed something that doesn't work for me, probably a matter of encoding characters or accents from a foreign language.
The function "Export..." to an .xml file does not work if there is a character with an accent like é è â à in the name of the folder. There is no error message, it does nothing.
And if I put an accent in the name of the .xml file, it rewrites it in a weird way, for example :
é  ->  é
è  ->  è
à  ->  à
Tested with foo_run 0.4.3 and foobar 2.0 beta 8 x86. If I remember correctly it has been there for a long time, it is not due to the latest versions.

Re: foo_run

Reply #720
After installing "Run services 0.4.3":
All "foobar2000 v2.0 beta 32bit 64bit" settings have been deleted.
Thanks for reporting and sorry for the issue! (just to be clear, you're most likely referring to the foo_run configuration and not all of fb2k).

I've now added a workaround for that with foo_run 0.4.4 and I'm hoping and crossing fingers that you have a backup of the previous configuration to confirm the fix.

Re: foo_run

Reply #721
The function "Export..." to an .xml file does not work if there is a character with an accent like é è â à in the name of the folder. There is no error message, it does nothing.
Thanks for pointing! There is probably an error message on the foobar2000 console. I'll look into it once I'm out of the mode of furiously trying to hotfix an issue I've introduced earlier today.

Re: foo_run

Reply #722
There is probably an error message on the foobar2000 console.
Sorry, I didn't look at the console.
When there is an accent in the path, in the name of the folder, for example  D:\Téléchargements\test.xml  the console says :
Run: export done successfully
But the .xml file is not created.

When I put an accent in the name of the .xml file, the console says:
Run: Cannot save XML stream to D:\test é è à â ç ù.xml.
Run: export done successfully

The .xml file is created and in this example it is called test é è à â ç ù.xml . Inside the file, everything is fine. It's just the name of the file.

Re: foo_run

Reply #723
Thanks for the details! I've fixed the import/export when using filenames with non-ascii characters with foo_run 0.4.5.

Re: foo_run

Reply #724
Thank you! It works fine now in both cases.