Skip to main content

Topic: foo_browser (Read 351166 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • odyssey
  • [*][*][*][*][*]
foo_browser
Reply #700
Is it possible to exclude items entirely from a panel? I don't want to display all items which has %skip% tag. I tried the following without luck: $ifequal(%skip%,1,,$if2(%artist%,<MISSING>))

I modified the string to the following:
$ifequal(%skip%,1,<SKIPPED>,$if2(%artist%,<MISSING>))
which logically should group allfiles maked with %skip% tag in it's own category, but still nothing happens. It seems to ignore anything except the artist, and i DID refresh the contents
Can't wait for a HD-AAC encoder :P

  • odyssey
  • [*][*][*][*][*]
foo_browser
Reply #701
I can't manage to do ANYTHING which have been mentioned to work with foo_browser.

Now, I created %involved% which includes all involved artist in a multi-field tag. If this tag are not found, it should just return %artist% instead. I use the following code in "Format":

$if2(%<involved>%,$if2(%artist%,<MISSING>))

BUT IT DON'T CARE ABOUT %involved%! Anything i try (including the previous example) just returns %artist%. I tested my code in a Column to make sure i did not screw something up, but it returns the expected values even with this:

$ifequal(%skip%,1,<SKIP>,$if2(%involved%,$if2(%artist%,<MISSING>)))
Can't wait for a HD-AAC encoder :P

  • morphguy12
  • [*][*]
foo_browser
Reply #702
can someone help me,  whenever I switch between tabs the browser resets to the top.

Im using CepiPerez's layout for the most part, with dark1, dark2, and dark 3 as my layouts. On the top there are three buttons, and whenever I switch between them, the "Show Playlist" page resets. On that page I have a browser panel on top with it looking in my library using *Browser* as my playlist, and then I have a Singe Column Playlist using Browser, which works with my browser which is up on top

I tried unchecking things like automatically activate, and replace previous, in the Browser settings, but to my luck, it still resets for some reason

  • kopf
  • [*][*][*]
foo_browser
Reply #703
Is there a feature in this plugin that filters the library like the search box in the top right hand corner of iTunes?

If so, I'd definitely use it. I can't find such a feature though.
http://ventolin.org - sredzkistra├če

  • morphguy12
  • [*][*]
foo_browser
Reply #704
K, so I did some testing, and I took out my browser, and there is no problem at all, so it has to be my browser and that it is reseting.

Please, if someone could help me out, or if someone has gotten this to work.

Thanks

  • damir
  • [*]
foo_browser
Reply #705
is it possible to make the Artist field sort by the BAND id3 tag and also fall back to the ARTIST id3 tag if the BAND tag is not present?

y'see i use the BAND tag for various artist albums. basically i want to know if it's possible for this to act like WMP does when dealing with BAND id3 tags. i.e. it sorts by the ARTIST tag unless there is a BAND tag in the file, in which case it defaults to that.
  • Last Edit: 14 February, 2007, 01:45:54 PM by damir

  • tberman333
  • [*][*][*]
foo_browser
Reply #706
Is there a way to have multiple value tags list separately in a browser panel?

For example, I have a tag called style and for one song I have:

Style = Rock; Funk; Jazz; Mellow

I have a panel setup with this format:

$if2(%<style>%,<MISSING>)

But that returns all the values on one line separated by commas.  I would want each value to be listed individually and when any of the values are selected the track would show up in the Browser playlist.

It works this way in Album List, but I can't seem to get it to work in the Browser.

Thanks!
GO WHALE!!!

My Website

  • eliazu
  • [*][*][*]
foo_browser
Reply #707
same question as @tberman333 here....
i used to be ok, it doesn't anymore (maybe it has something to do with to move to Vista?)

  • odyssey
  • [*][*][*][*][*]
foo_browser
Reply #708
same question as @tberman333 here....
i used to be ok, it doesn't anymore (maybe it has something to do with to move to Vista?)

No, i have the same issue.

Edit: Whatever, switched to 1.2.2c it works.
  • Last Edit: 18 February, 2007, 04:49:25 PM by odyssey
Can't wait for a HD-AAC encoder :P

  • tberman333
  • [*][*][*]
foo_browser
Reply #709

same question as @tberman333 here....
i used to be ok, it doesn't anymore (maybe it has something to do with to move to Vista?)

No, i have the same issue.


I don't use Vista either. Win XP here.
GO WHALE!!!

My Website

  • Krank
  • [*]
foo_browser
Reply #710
Hm. New here, and don't really have time to work my way through 29 pages...

So, a few questions:

1) is this plugin still delevoped? Is stuff happening?

2) Would it be at all possible to make the "population of lists" take place in the background or something? It's kind of annyoying having to wait several seconds for them to populate when I start the program, and I'd very much like to be able to do stuff right away...

  • morphguy12
  • [*][*]
foo_browser
Reply #711
no way of getting it to remember where it left off, or to not refresh when going through tabs???

foo_browser
Reply #712
No, i have the same issue.

Edit: Whatever, switched to 1.2.2c it works.

Any idea where I can get a hold of this version?
thanks

  • flxfxp
  • [*][*]
foo_browser
Reply #713
Is there any way for foo_browser to play nicely with foo_ui_panels?
It seems to have update problems with the panel if the interface gets updated (e.x restore from systray, resize foobar)





Thanks!

Dennis
  • Last Edit: 21 March, 2007, 02:17:52 PM by flxfxp

  • cwbowron
  • [*][*][*][*][*]
foo_browser
Reply #714
Quote
= Release 1.2.3b =
* hopefully fixed a bug with interacting with panels ui
There used to be a link to my website here.

  • flxfxp
  • [*][*]
foo_browser
Reply #715
Thanks for answering my plea, cwbowron. It works much better now

Regards,

Dennis

  • sylla
  • [*][*][*]
foo_browser
Reply #716
Is it possible to make the browser just browse the active playlist and not the whole library?

  • eliazu
  • [*][*][*]
foo_browser
Reply #717

same question as @tberman333 here....
i used to be ok, it doesn't anymore (maybe it has something to do with to move to Vista?)

No, i have the same issue.

Edit: Whatever, switched to 1.2.2c it works.


got this version [july 6 2006] .. it's still doesnt work!
  • Last Edit: 24 March, 2007, 05:55:25 PM by eliazu

  • cwbowron
  • [*][*][*][*][*]
foo_browser
Reply #718
Temporary server due to bandwidth issues:

http://msu.edu/~bowronch/foobar/foo_browser.zip
There used to be a link to my website here.

  • Matyas
  • [*][*][*]
foo_browser
Reply #719
Is it possible to make the browser just browse the active playlist and not the whole library?

Yes, just right click on the playlist in the playlist panel and select "Browse"

  • sylla
  • [*][*][*]
foo_browser
Reply #720

Is it possible to make the browser just browse the active playlist and not the whole library?

Yes, just right click on the playlist in the playlist panel and select "Browse"


Yeah I knew that, but I'm lazy and would like it to be the standard, so that every time I change playlist, the browser will browse the new playlist, like in iTunes... But hey, it's not a very big problem, just would like it better that way.

  • tgoose
  • [*][*][*][*]
foo_browser
Reply #721


Is it possible to make the browser just browse the active playlist and not the whole library?

Yes, just right click on the playlist in the playlist panel and select "Browse"


Yeah I knew that, but I'm lazy and would like it to be the standard, so that every time I change playlist, the browser will browse the new playlist, like in iTunes... But hey, it's not a very big problem, just would like it better that way.

I believe it is possible with another plugin to change the default action upon clicking... but I don't have fb2k here to test.

  • eliazu
  • [*][*][*]
foo_browser
Reply #722
Is there a way to have multiple value tags list separately in a browser panel?

For example, I have a tag called style and for one song I have:

Style = Rock; Funk; Jazz; Mellow

I have a panel setup with this format:

$if2(%<style>%,<MISSING>)

But that returns all the values on one line separated by commas.  I would want each value to be listed individually and when any of the values are selected the track would show up in the Browser playlist.

It works this way in Album List, but I can't seem to get it to work in the Browser.

Thanks!


does anybody has an answer to that?
it's really bothering me

foo_browser
Reply #723
Is there a way to have multiple value tags list separately in a browser panel?

For example, I have a tag called style and for one song I have:

Style = Rock; Funk; Jazz; Mellow

I have a panel setup with this format:

$if2(%<style>%,<MISSING>)

But that returns all the values on one line separated by commas.  I would want each value to be listed individually and when any of the values are selected the track would show up in the Browser playlist.

It works this way in Album List, but I can't seem to get it to work in the Browser.

Thanks!

I use that same bit of code and it returns my multivalue tags as separate tags. Maybe the problem is that your style tag was not formatted as a multivalue tag? If that is the case, go to preferences > advanced > the properties dialog node. Within that node there is a Multivalue Fields setting where you can add tags you wish to be formatted as multivalue. Add your style tag to that.

You can tell if a tag is not being formatted as a multivalue tag when you're editing a tracks tag value. In the Edit Value window it says Use ; character to separate multiple values on the bottom of the window. If that phrase is grayed it means your tag will not be formatted as a multivalue tag.

  • tberman333
  • [*][*][*]
foo_browser
Reply #724
I use that same bit of code and it returns my multivalue tags as separate tags. Maybe the problem is that your style tag was not formatted as a multivalue tag? If that is the case, go to preferences > advanced > the properties dialog node. Within that node there is a Multivalue Fields setting where you can add tags you wish to be formatted as multivalue. Add your style tag to that.

You can tell if a tag is not being formatted as a multivalue tag when you're editing a tracks tag value. In the Edit Value window it says Use ; character to separate multiple values on the bottom of the window. If that phrase is grayed it means your tag will not be formatted as a multivalue tag.


Thank you very much... that worked for me.  I had thought I had set my tag as a multivalue tag, but for some reason it did not stay.  It is strange because it showed as seperate lines in Album List, but not in Browser (or Playlist Tree).  I went back and changed the tag to multivalue, saved it, and then retagged the some files and it is working perfectly.

Hope this works for others that were having the same problem as well!
GO WHALE!!!

My Website