Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: [CRASHWARE] updated foo_uie_albumart (Read 607084 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[CRASHWARE] updated foo_uie_albumart

Reply #825
AlbumArtSmall etc. are more than hidden. They are marked as system or something alike. Google if you want to delete them - and stop using DaEvilSoftware

[CRASHWARE] updated foo_uie_albumart

Reply #826
Hi gfngfgf, I have a request: is it possible to pause the cycling when foobar is minimized?
I noticed that even if minimized, heavy images can produce noticeable spikes in memory (less for cpu) usage.

[CRASHWARE] updated foo_uie_albumart

Reply #827
Hi gfngfgf, I have a request: is it possible to pause the cycling when foobar is minimized?
I noticed that even if minimized, heavy images can produce noticeable spikes in memory (less for cpu) usage.

Yes, that sounds reasonable.  I'll look into it.

[CRASHWARE] updated foo_uie_albumart

Reply #828
Is it possible to cycle trough various images in the same folder and how do I do this with the sources??

thanks in advance

[CRASHWARE] updated foo_uie_albumart

Reply #829
Is it possible to cycle trough various images in the same folder and how do I do this with the sources??

thanks in advance


In behaviour tab check 'Cycle all wildcard matches' and just add all the possible sources to your list (e.g. *.jpg)

[CRASHWARE] updated foo_uie_albumart

Reply #830
Hi !

great plugin but it would be great to be able to switch off debug console output... In new version Im seeing many messages like this:

Error (foo_uie_albumart): Image  not found!

I know an workaround but I think it should be an option in preferences...

[CRASHWARE] updated foo_uie_albumart

Reply #831
Hi !

great plugin but it would be great to be able to switch off debug console output... In new version Im seeing many messages like this:

Error (foo_uie_albumart): Image  not found!

I know an workaround but I think it should be an option in preferences...

This is a bug.  I'll have it fixed in the next version.  Thank you for reporting it.

[CRASHWARE] updated foo_uie_albumart

Reply #832

1. No, there's no support for pictures embedded as tags and there's none planned.

...

I understand and respect you don't want to support album art integrated in every file of an album. But I just saw the new FLAC change log and it natively supports adding picture files now.
I already have alot of FLAC album images with integrated cuesheet and now the cover included too. I do like this because you now don't have the overhead of having the album art in every file of the album. I hope more lossless encoders will take over this standard!
What are your thoughts about this and is there a possibility of adding support for albumart in album images to foo_uie_albumart?


This should be possible, but it is up to FLAC source filter. This works for example with Matroska container, check the Matroska support thread for more details.

[CRASHWARE] updated foo_uie_albumart

Reply #833
Hello, i have a question: I changed my source list to

[foo_uie_albumart]
$replace(%path%,%filename_ext%,)folder.*
$replace(%path%,%filename_ext%,)*front*.*
$replace(%path%,%filename_ext%,)*cover*.*
$replace(%path%,%filename_ext%,)*back*.*
$replace(%path%,%filename_ext%,)*in*.*
$replace(%path%,%filename_ext%,)*cd*.*
$replace(%path%,%filename_ext%,)*.*
--components\default.*
[End]

but using that, i noticed that i doesn't show the defaut image in the component directory anymore, do you know why?

Other question real quick: in one of my folder i have around 200mp3s but no artwork and it shows an artwork that i think is embedded in a song, is there a way to disable that?

thanks in advance for your help and that great plugin

[CRASHWARE] updated foo_uie_albumart

Reply #834
Quote
Other question real quick: in one of my folder i have around 200mp3s but no artwork and it shows an artwork that i think is embedded in a song, is there a way to disable that?

Well, add an extension to your patterns instead of .*

[CRASHWARE] updated foo_uie_albumart

Reply #835
Other question real quick: in one of my folder i have around 200mp3s but no artwork and it shows an artwork that i think is embedded in a song, is there a way to disable that?


You probably have a hidden image in that directory, there is no support for embedded images. You can check by going Folder Options -> View -> Show Hidden Files and Folders and rechecking your directory for image files.

[CRASHWARE] updated foo_uie_albumart

Reply #836
anyone know the exclude string? My Zune added a whole bunch of 'albumartsmall', 'folder', and 'small' images

[CRASHWARE] updated foo_uie_albumart

Reply #837
anyone know the exclude string? My Zune added a whole bunch of 'albumartsmall', 'folder', and 'small' images

There is none. Just don't spam your folders with crap or name the images you want shown.

[CRASHWARE] updated foo_uie_albumart

Reply #838
feature request:
in the preferences window, on display tab, in the colors section ... can the background color picker have a checkbox to choose a color or if its unchecked make the panel be the default color (grey for most windows users).
also in the panel options section can we possibly get a minimum panel width increment box.  my panels keep resetting to a skinnier width than my art.  i drag it to the width i want it and then click on my playlist and it shrinks back (i even tried locking the panel).

finally (not the most important but it may be cool)
have the option to use the .ico format for our arwork.

thanx for keeping this plugin going ...

[CRASHWARE] updated foo_uie_albumart

Reply #839
feature request:
in the preferences window, on display tab, in the colors section ... can the background color picker have a checkbox to choose a color or if its unchecked make the panel be the default color (grey for most windows users).

This has been requested before.  I'm still working on it.

also in the panel options section can we possibly get a minimum panel width increment box.  my panels keep resetting to a skinnier width than my art.  i drag it to the width i want it and then click on my playlist and it shrinks back (i even tried locking the panel).

Sure.  I can do that.

edit: I just thought of something....do you have "Auto-hide" enabled on the Columns UI Layout tab?  After it shrinks back, what happens if you just hold your mouse over the edge (instead of resizing it again)?

finally (not the most important but it may be cool)
have the option to use the .ico format for our arwork.

I think this should be possible, too.  I'll check it out.

[CRASHWARE] updated foo_uie_albumart

Reply #840
no auto-hide isn't checked ... and it doesn't resize when i mouse over.  also the lock option seems to only lock position relative to window size (i'm not sure if that what was it was meant to be).  i was thinking lock would shift the panel if you resize the main foobar window, like when you lock the playback button and seekbar panel at the top (it will resize relative to the window) ... i'm not sure if this is a bug persay or a feature
anyways keep it rockin' ... this is a great plugin!

[CRASHWARE] updated foo_uie_albumart

Reply #841
Hi,

I'm a little rusty on how to configure the sources list, and by rusty I mean I have no idea at all. I'm just using the default sources list that came with the plugin, and for all intents and purposes, it seems to do the trick, generally- it loads an image it finds in the same directory as my music and for most cases this does just fine.

However, for albums (which I keep in individual directories) which have both front and back art to them, it just stays on one image, and even if I enable the "cycle images" option, it stays on that one image. moving that one image elsewhere or outright deleting it will finally get it to cycle to the other, but it refuses to cycle on its own.

Can anyone offer up some help? I'm not really sure what I need to configure the sources list to be so that I can cycle through all the images in the same folder.

-N

[CRASHWARE] updated foo_uie_albumart

Reply #842
Enable "cycle all wildcard matches" and change the first source to:

Code: [Select]
$replace(%path%,%filename_ext%,)*

 

[CRASHWARE] updated foo_uie_albumart

Reply #843
-----
Version 0.2.6 (January 14, 2007)
Plugin homepage

Download
Change log
Source
Wiki page (Help)
-----

As always, check the changelog for a full list of changes.  A few highlights:

If an image is larger than the albumart window, you can now drag the mouse to move the image around.  Overall, the dragging feature works well, but there might be a few bugs.  For instance, if you drag the mouse really far off the edge of the window, you might not be able to immediately move the image again.  If that happens, just keep trying to drag, and it will eventually move.

There's a new "History" section on the Preferences page.  Every time albumart searches for images using a particular source, it saves the matching filenames in memory.  Later, albumart can use the results in memory rather than searching again.  For instance, if I'm playing Album A, then play Album B, then switch back to Album A, albumart would only have to search twice.  The second time you play Album A, the saved results would be used.  If you're one of the people who has noticed that albumart's searches slow down your system, you might find this helpful.  You can force albumart to ignore the history and search again by clicking "Refresh" from the context menu.

Finally, I made two improvements to the "Edit Source" window.  First, the text box is bigger to make it easier to enter long sources.  Second, there's now a title formatting preview that should work a lot like the preview on the "Title Formatting" section of foobar2000's main preferences.

edit: restored the download link (see the post below)

[CRASHWARE] updated foo_uie_albumart

Reply #844
A bug was just found in version 0.2.6 (see this post).  Apparently, when a new Album Art Panel is added to the Columns UI Layout, foobar2000 crashes with no failure.txt.  I'm still tracking down the cause, but until then, I'm removing the 0.2.6 download.  Hopefully this won't take too long to figure out.

EDIT: okay, the bug's been fixed now.  It's amazing what one line of code can do 

If you downloaded 0.2.6 before, please download again from the link above and check under "Preferences -> Components" to make sure you're using the Jan 15, 2007 version (double-click on the entry for "Album Art Panel").

[CRASHWARE] updated foo_uie_albumart

Reply #845
Thanks for the update. Works flawlessly for me.

Tich

[CRASHWARE] updated foo_uie_albumart

Reply #846
Many thanks gfngfgf, for keeping your work and second my suggestion:
Quote
- Automatic cycling is paused while foobar2000 is minimized

[CRASHWARE] updated foo_uie_albumart

Reply #847
gfngfgf
in the last version of playlist tree
cwbowron as Added notification callback, so other plugins can be notified of tree selections.

do you think it is possible to use this in album art panel ?
thanks
Music is my first love.

[CRASHWARE] updated foo_uie_albumart

Reply #848
gfngfgf
in the last version of playlist tree
cwbowron as Added notification callback, so other plugins can be notified of tree selections.

do you think it is possible to use this in album art panel ?
thanks

I'll look into it.

[CRASHWARE] updated foo_uie_albumart

Reply #849
This is probably a really trivial easy one but I have my Artist Images setup so that they are in this format

%artist%\[CD%discnumber%\]%album%

and the artist pic is always called Artist.*

I can get it to work in when its just %artist%\%album%
but when its %artist%\CD%discnumber%\%album%

This works: $replace(%path%,%directory%'\'%filename_ext%,Artist.*)
This doesnt: -$replace(%path%,(%path%,1)'\'$directory%filename_ext%,Artist.*)
Also Fails: -$replace(%path%,$directory%'\'(%path%,1)filename_ext%,Artist.*)

Any ideas please...

OK got this one workinh
$replace(%path%,$if($strcmp($lower($left(%directoryname%,2)),cd),$directory(%path%,2)$char(92),)
%directoryname%$char(92)%filename_ext%,Artist.*)