Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: [CRASHWARE] updated foo_uie_albumart (Read 607080 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[CRASHWARE] updated foo_uie_albumart

Reply #750
Try
Code: [Select]
-$replace(%path%,%directory%'\'%filename_ext%,)cover.jpg


Edit: you got it.

[CRASHWARE] updated foo_uie_albumart

Reply #751
I cant get this plugin to work. I downloaded and use columsUi...i use the newest version of foobar. I downloaded the mod, extracted it to /foobar/components    but my foobar doesnt reconize it. I dont see anywhere were i can edit the plugin in my "prefrences" option in foobar. Can anyone help me out? I also use windows xp pro

[CRASHWARE] updated foo_uie_albumart

Reply #752
I cant get this plugin to work. I downloaded and use columsUi...i use the newest version of foobar. I downloaded the mod, extracted it to /foobar/components    but my foobar doesnt reconize it. I dont see anywhere were i can edit the plugin in my "prefrences" option in foobar. Can anyone help me out? I also use windows xp pro

Christ, this has to be the most common question since the change. Why doesn't anyone even attempt to look up a few posts...

That screenshot is from an older version. Albumart now supports multiple instances and the settings are no longer managed from the main foobar preferences tree. Instead, add the panel to your layout (File> Preferences> Display> Columns UI> "Layout" Tab) then right click on the panel and select "Preferences" from the popup. There you will find the albumart settings.

[CRASHWARE] updated foo_uie_albumart

Reply #753
Christ, this has to be the most common question since the change. Why doesn't anyone even attempt to look up a few posts...

It's not their fault as long as my plugin page doesn't have installation instructions and the wiki page has an outdated screenshot.  I'm in the process of updating the wiki page now.

[CRASHWARE] updated foo_uie_albumart

Reply #754
Well. i have 2 questions.



question1:
The music files are located in
<some path>\album_dir
If i have 3 or 4 pictures in this folder, let them be x1.jpg , x2.jpg and x3.jpg

by deafault, x1.jpg will be displayed
If i want that when i click "Next Source", x2.jpg will be displayed, and click one more time, x3.jpg will be displayed?

the name of these pictures varies from album to album, i.e.these picture are not of fixed names, so the following wont work
$replace(%_path%,%_filename_ext%,)x1.jpg
$replace(%_path%,%_filename_ext%,)x2.jpg
$replace(%_path%,%_filename_ext%,)x3.jpg

what should i do?




question2:
The music files are located in
<some path>\album_dir

but the pictures are located in a folder inside it, say
<some path>\album_dir\xxx
this folder name varies from from album to album, i.e. it is not of fixed name

what should i do?

[CRASHWARE] updated foo_uie_albumart

Reply #755
questions



Regarding question 1:
Just put
$replace(%_path%,%_filename_ext%,)*
That should cover it all.

Regarding question 2:
I am not sure about this solution but it's worth a try to see if it works. Try this:
$replace(%_path%,%_filename_ext%,)*\*
Please let us/me know if the solution for this one worked

[CRASHWARE] updated foo_uie_albumart

Reply #756

questions



Regarding question 1:
Just put
$replace(%_path%,%_filename_ext%,)*
That should cover it all.

Regarding question 2:
I am not sure about this solution but it's worth a try to see if it works. Try this:
$replace(%_path%,%_filename_ext%,)*\*
Please let us/me know if the solution for this one worked



Thanks for the quick reply
questions 1 works after i enable wildcard
questions 2 works too

Thank you very much!!

[CRASHWARE] updated foo_uie_albumart

Reply #757
You should clean up your music collection

 

[CRASHWARE] updated foo_uie_albumart

Reply #758
-----
Version 0.2.5 (October 7, 2006)
Plugin homepage

Download
Change log
Source
Wiki page (Help)
-----

See the change log for a complete list of changes.

The panel will now display art on empty playlists.  Be careful with this, because Album Art Panel still tries to evaluate the source string, and any track-specific variables like %path% and %title% will evaluate to '?'.  For example, $replace(%path%,%filename_ext%,)*.jpg evaluates to "*.jpg" because %path% and %filename_ext% both evaluate to '?'.  The string "*.jpg" causes the panel to display any image in the foobar2000 program directory.  If this isn't what you want, use the string $replace(%path%,%filename_ext%,*.jpg) instead.

edit: the reason why it tries to evaluate the source string is because in the future, I'd like to allow access to variables like %playlist_name% and %lock_name% so that the user can customize what image is displayed on an empty playlist.  This is somewhat of a low priority, though.

As requested, the image search is suppressed if it shouldn't be necessary.  If the source string, after titleformatting, is the same as the previous formatted source, the image search is skipped and the previous results are used.  For example, suppose my source is $replace(%path%,%filename_ext%,)*.jpg and I'm playing a track from the album "Audioslave", located in the folder "E:\Music\Audioslave\Audioslave\".  The source will evaluate to "E:\Music\Audioslave\Audioslave\*.jpg".  If I then switch to the next track in the album, the source will evaluate to the same string, and so the image search will not occur.

Finally, Album Art Panel can now read images within archives.  In general, you should be able to use the string $replace(%path%,%filename_ext%,)folder.jpg to read a file called "folder.jpg" from the same archive that the current track is in.  Wildcards are not supported.  This string assumes that there's no directory structure inside the archive.  You can still build a source that reads images if there is a directory structure; just remember that foobar2000 uses the forward-slash '/' as the directory separator inside archives.

[CRASHWARE] updated foo_uie_albumart

Reply #759
Thank you for the update gfngfgf, especially for adding the feature to read in archived files. Its been along time coming and its seriously appreciated, keep up the great work.
You're talking to my guy all wrong... It's the wrong tone. Say it again, and i'll stab you in the face with a soldering iron!

[CRASHWARE] updated foo_uie_albumart

Reply #760
Very important request here.

It would be really really wonderful IF the option was there to be able to drag the image.  A lot of us have images stored when we scan cd books as really large resolutions and having it displayed large in the album art window is useless if you can't drag it around with a little hand.  A lot of time this resolution is nessesary to read all the fine writing.  Currently you have to open in externel viewer like infranview in order to do this... it would be great to not have to open every time you look.

Thanks!

Jonathan

[CRASHWARE] updated foo_uie_albumart

Reply #761
I use Directory Opus as a replacement for Windows Explorer and up until now, foo_uie_albumart always opened Opus when I used the Open directory option.  But the latest version (0.2.5) has started opening Explorer instead of Opus. 

Has the routine to Open directory been altered?

[CRASHWARE] updated foo_uie_albumart

Reply #762
Has the routine to Open directory been altered?

Yes, as I noted in the changelog.  I made some changes at version 0.2.4, but lots of people were having serious problems (crashes).  Rather than going back to the way it used to be (which didn't crash and opened your replacement file browser), I did something different.  In 0.2.5, foo_uie_albumart's "Open Directory" feature should run the same command that is run when you right-click a track in your playlist and select "Open Directory".  (To get technical, I'm using the standard_commands::context_file_open_directory function).  I'm guessing that if you right-click a track in the playlist and select "Open Directory", it will also open Explorer and not Opus.  I don't see this being a big enough issue to change the way it is now.

[CRASHWARE] updated foo_uie_albumart

Reply #763
Yes, as I noted in the changelog.  I made some changes at version 0.2.4, but lots of people were having serious problems (crashes).  Rather than going back to the way it used to be (which didn't crash and opened your replacement file browser), I did something different.  In 0.2.5, foo_uie_albumart's "Open Directory" feature should run the same command that is run when you right-click a track in your playlist and select "Open Directory".  (To get technical, I'm using the standard_commands::context_file_open_directory function).  I'm guessing that if you right-click a track in the playlist and select "Open Directory", it will also open Explorer and not Opus.  I don't see this being a big enough issue to change the way it is now.
True, not a big issue, but, in my case, annoying.

I suppose since you're using the RMB Open Directory command, then the 'fault' lies with foobar, really.

[CRASHWARE] updated foo_uie_albumart

Reply #764
I'm using directory opus, too. But both commands work correctly here. There must be something wrong with your Directory Opus installation.

Concerning the "image cache": I'd propose not only to cache the last image (which is completely useless if you cycle throught images), but rather use a associative array and cache the last 20-50 results.

[CRASHWARE] updated foo_uie_albumart

Reply #765
I'm using directory opus, too. But both commands work correctly here. There must be something wrong with your Directory Opus installation.
Weird.  Since I read your comment, I've been through Dopus' settings a few times trying the different Explorer Replacement options, and I can't get Foobar to open a directory using it.  I'll have to try a re-install.

[CRASHWARE] updated foo_uie_albumart

Reply #766
Big Thanks for pics' show when playlist is empty! I wanted it  for a long time.

[CRASHWARE] updated foo_uie_albumart

Reply #767
Thanks a lot for fixing the resizing bug 

[CRASHWARE] updated foo_uie_albumart

Reply #768
I have a feature request here which i would die for.  The option in the preferences to have it only load the images when a track is PLAYED and not just added to the play list.  the reason i ask is because a lot of us play music off a network hard drive because of massive collections and when doing so you have to wait forever for the image to load, which is quite alright if you have the ability to still start the music but the cursor locks up until its loaded.  so if the option were there you could play a track and then wait on the image which is fine by me.

is this possible??? or a way to free up the cursor/program in order to still start stop music while its loading?????

thanks so much

Jonathan

EDIT:  Also i was wondering if you could tell me why in technical terms it takes so long to load anyways.  I checked the transmission and i can load a 30 meg picture in a snap, does the plugin que them all up or something??

[CRASHWARE] updated foo_uie_albumart

Reply #769
I have a feature request here which i would die for.  The option in the preferences to have it only load the images when a track is PLAYED and not just added to the play list.  the reason i ask is because a lot of us play music off a network hard drive because of massive collections and when doing so you have to wait forever for the image to load, which is quite alright if you have the ability to still start the music but the cursor locks up until its loaded.  so if the option were there you could play a track and then wait on the image which is fine by me.

is this possible??? or a way to free up the cursor/program in order to still start stop music while its loading?????

thanks so much

Jonathan

EDIT:  Also i was wondering if you could tell me why in technical terms it takes so long to load anyways.  I checked the transmission and i can load a 30 meg picture in a snap, does the plugin que them all up or something??



correction.  why does it take so long for the wildcard search?? could anyone point me to the implementation in the source??  to search a directory with 5 pngs in it and return the one that starts with a shouldn't take a minute and half on a 100 megabit lan.  I would like to help test/write can someone point me on my way?

[CRASHWARE] updated foo_uie_albumart

Reply #770
correction.  why does it take so long for the wildcard search?? could anyone point me to the implementation in the source??  to search a directory with 5 pngs in it and return the one that starts with a shouldn't take a minute and half on a 100 megabit lan.  I would like to help test/write can someone point me on my way?

take a look at albumart_helpers.cpp.  I don't have a LAN to test on, so I have no idea if there are specific problems with the method used.  I can imagine that it would take a while, though, because for each image found, the entire image is loaded to check whether it really is a valid image (rather than, say, a text file with a ".jpg" extension).  If each of your images is 30 megabytes, it can indeed take a long time to load them all.

[CRASHWARE] updated foo_uie_albumart

Reply #771
oh ok sorry for the reply i just sent you then. this makes sense.  This is a feature that i do not need... is there anyway you could add the option for this checking as a toggle? i am quite certain each of these images i put there is valid... would it not be faster anyways to avoid this and have it display error if they couldn't load and then let people turn the option on if they want the long check?  other than that it seems quite fast enough... kudos there =)

*whisper* any chance of a quick compile without the option for a grateful user =D

[CRASHWARE] updated foo_uie_albumart

Reply #772
I upgraded to 0.9.4.1 today... and my album art doesnt change smoothly anymore... Just jumps from one image to the next with tranisiton set to 300ms... With transistion set to 10000 ms it appears that there is a jump to a certain part in the fade then it fades from there.

My System has more than enough usable power to handle it and it didnt happen until i updated to 0.9.4.1

[CRASHWARE] updated foo_uie_albumart

Reply #773
i am quite certain each of these images i put there is valid... would it not be faster anyways to avoid this and have it display error if they couldn't load and then let people turn the option on if they want the long check?

Yes, I've been thinking about the same thing, too.  Probably next version, it won't load every image that it tests just to make sure it is a valid image.  That does seem kind of silly now that I think about it 

vader897: I just upgraded to 0.9.4.1 right now, and I haven't noticed any issues with the fading.

[CRASHWARE] updated foo_uie_albumart

Reply #774
@gfngfgf

can you add option to run external program ( for exemple coverdownload) when double or middle click ?

thank for your work
Music is my first love.