Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: [CRASHWARE] updated foo_uie_albumart (Read 614235 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

[CRASHWARE] updated foo_uie_albumart

Reply #700
Will there be a 3D mode (it was seen in unofficial release by David L at Jul 23 2006) here, in official plugin?

[CRASHWARE] updated foo_uie_albumart

Reply #701
And there is realy no possibility to "climb up" in the folder-structure ...?? 
You should be able to climb up be using the $directory function.

Something like
$replace(%path%,$directory(%path%,1)\%_filename_ext%,folder.jpg)
accesses the file "folder.jpg" in the parent folder.
Always defragment your MP3s to avoid subtle lack in harmonics.

[CRASHWARE] updated foo_uie_albumart

Reply #702
Quote
gfngfgf' date='Sep 14 2006I I'm a little confused.  Were you able to fix your problem?




Yes, but until I saw solutions posted here, it was only able to display if filename matched %artist% tag, i.e. no wildcard . Only problem now, left click in album art panel will not change source.

Great plug-in...thanks for the help.


[CRASHWARE] updated foo_uie_albumart

Reply #703
Something like
$replace(%path%,$directory(%path%,1)\%_filename_ext%,folder.jpg)
accesses the file "folder.jpg" in the parent folder.


Good hint Tri 

[CRASHWARE] updated foo_uie_albumart

Reply #704
E:\Artists Photos\%artist%.jpg
-E:\Artists Photos\%artist%.png

You can save the .jpg/.png here and do .* - if I'm guessing right and your "Artist Photos" folder only contains image files
The * problem is created by foo_uie_albumart trying to display the mp3s as images (which will fail, of course ^^), since something like $replace(%path%,%filename_ext%,)* matches every file in that folder (most of them beeing mp3s). but E:\Artists Photos\%artist%.* should only match one or maybe two files - so no problem here.

[CRASHWARE] updated foo_uie_albumart

Reply #705
good point there is no need to specify file extensions in this folder
My Name is Sean and I'm here to leech off your genius.

[CRASHWARE] updated foo_uie_albumart

Reply #706

And there is realy no possibility to "climb up" in the folder-structure ...?? 
You should be able to climb up be using the $directory function.

Something like
$replace(%path%,$directory(%path%,1)\%_filename_ext%,folder.jpg)
accesses the file "folder.jpg" in the parent folder.


*Great* hint!  That'll serve me well until the ".." shortcut is fixed again.

[CRASHWARE] updated foo_uie_albumart

Reply #707
Something like
$replace(%path%,$directory(%path%,1)\%_filename_ext%,folder.jpg)
accesses the file "folder.jpg" in the parent folder.


Good hint Tri 


How could I use this code to go back 3 directories?

example

My Music
-Artist Directory
--Live Directory
---Album
----Disc 1
----Disc 2

With my artistimage.jpg in the 'artist directory' and the files in the disc 1 and 2 folders. Is there a way?

[CRASHWARE] updated foo_uie_albumart

Reply #708
Tri had the right idea with it, but a more customizable/applicable method is to use
$replace(%path%,$directory(%path%,1)\%filename_ext%,)folder.*
Where folder.* can be whatever you'd like. I feel it's improved, since it allows for using wildcards still.

How could I use this code to go back 3 directories?

With my artistimage.jpg in the 'artist directory' and the files in the disc 1 and 2 folders. Is there a way?

This is slightly more trickly.
If Foobar had a function which split lines, you could tell it to only use the first X directories using a seperator of \, but it doesn't.
Therefore, you have to use
$replace(%path%,$directory(%path%,3)\$directory(%path%,2)\$directory(%path%,1)\%filename_ext%,)artistimage.jpg

You can continue going up or down the path by adding an additional $directory(%path%,#)\

[CRASHWARE] updated foo_uie_albumart

Reply #709
Tri had the right idea with it, but a more customizable/applicable method is to use
$replace(%path%,$directory(%path%,1)\%filename_ext%,)folder.*
Where folder.* can be whatever you'd like. I feel it's improved, since it allows for using wildcards still.


How could I use this code to go back 3 directories?

With my artistimage.jpg in the 'artist directory' and the files in the disc 1 and 2 folders. Is there a way?

This is slightly more trickly.
If Foobar had a function which split lines, you could tell it to only use the first X directories using a seperator of \, but it doesn't.
Therefore, you have to use
$replace(%path%,$directory(%path%,3)\$directory(%path%,2)\$directory(%path%,1)\%filename_ext%,)artistimage.jpg

You can continue going up or down the path by adding an additional $directory(%path%,#)\


Ah, thank you! Looks like I was doing the right thing - only backwards. 

[CRASHWARE] updated foo_uie_albumart

Reply #710
im not sure why, but the only version of this that works for me is 0.164a. im running the latest stable build of foobar, and have tried the past 4 stable versions of this plugin, and after i install it, it is nowhere to be found in my prefrences, but when i replace it with the 0.164a version, it magically appears back under the display branch. anyone know why this is?

[CRASHWARE] updated foo_uie_albumart

Reply #711
im not sure why, but the only version of this that works for me is 0.164a. im running the latest stable build of foobar, and have tried the past 4 stable versions of this plugin, and after i install it, it is nowhere to be found in my prefrences, but when i replace it with the 0.164a version, it magically appears back under the display branch. anyone know why this is?


It's no longer located in the display branch. Go to the Columns UI Layout tab and insert the panel wherever you're going to want it. Then click on it and choose configure, and you'll be at the preferences screen for it.

[CRASHWARE] updated foo_uie_albumart

Reply #712
ahh, thanks alot

 

[CRASHWARE] updated foo_uie_albumart

Reply #713
-----
Version 0.2.4.1 (September 18, 2006)
Plugin homepage

Download
Change log
Source
-----

This release addresses a few of the bugs that people have reported over the past week.  I also added an option to disable cycling through all wildcard matches.  The option is disabled by default, so if you do want to cycle through all wildcard matches, make sure to check the box on the "Behaviour" tab.

You can also cycle through wildcard matches in random order now.  To be precise, it's really a "shuffle".  When the panel first hits a wildcard source, it builds a list of all the matches for that source.  If "Random" is enabled, the list is shuffled, and then images are loaded from the list until the panel moves on to the next source.  If you keep hitting "Next Source", you will see all the wildcard matches for a particular source.

I did some more fiddling with the "Open Directory" function, so anyone who was experiencing crashes with the original 0.2.4 release, I'd be interested to know if you're still getting crashes with 0.2.4.1.

Also, the built-in image search now restricts the results to only image files, based on the file extension.  If the file does not have an extension of .jpg, .jpeg, .gif, .png, or .bmp, the program won't try to open the file.  This should lessen the problems with sources being too general, but it should still be faster to be specific with your source strings.  There is no way to work around this filtering.  If the image extension you use if not in the list, let me know and I'll add it.

Finally, regarding "..\" not working: I haven't been able to figure it out.  I have a feeling the filesystem service in the foobar2000 SDK doesn't support "..", but this is just a guess.  I could work around it, but I feel it's not worth my time since Tri and D3WEY both posted valid solutions above (here and here).

[CRASHWARE] updated foo_uie_albumart

Reply #714
I use next sources list
Code: [Select]
$replace(%path%,%filename_ext%,)*front*.jpg
-$replace(%path%,%filename_ext%,)*inside*.jpg
-$replace(%path%,%filename_ext%,)*cd*.jpg
-$replace(%path%,%filename_ext%,)*back*.jpg
--c:\audio\no_cover*.jpg


Whis this list I see in console only
Code: [Select]
10:43:24] searching album art, preprocessed pattern: "C:\Audio\The Doors\1970 - Absolutely Live\*front*.jpg"


When I use
Code: [Select]
$replace(%path%,%filename_ext%,)*front*.jpg
$replace(%path%,%filename_ext%,)*inside*.jpg
$replace(%path%,%filename_ext%,)*cd*.jpg
$replace(%path%,%filename_ext%,)*back*.jpg
--c:\audio\no_cover*.jpg



In console I see
Code: [Select]
10:44:08] searching album art, preprocessed pattern: "C:\Audio\The Doors\1970 - Absolutely Live\*front*.jpg"
[10:44:10] searching album art, preprocessed pattern: "C:\Audio\The Doors\1970 - Absolutely Live\*inside*.jpg"
[10:44:14] searching album art, preprocessed pattern: "C:\Audio\The Doors\1970 - Absolutely Live\*cd*.jpg"
[10:44:15] searching album art, preprocessed pattern: "C:\Audio\The Doors\1970 - Absolutely Live\*back*.jpg"


Why it is?

I don' t see no_cover image in first and second cases when use "Next Source" command.
I can see no_cover image only if I don't use wildcard matches in souces list.
It is good?

[CRASHWARE] updated foo_uie_albumart

Reply #715
Why it is?

pepoluan gave a good explanation in this post and I added some explanation a few posts below his.  Basically, the dash groups sources together.  In your first list, since the panel found a match for "*front*.jpg", it doesn't bother to try any of the others.  Another way to say it is that "Next Source" skips to the next source in the list which does not start with a dash.

I don' t see no_cover image in first and second cases when use "Next Source" command.
I can see no_cover image only if I don't use wildcard matches in souces list.
It is good?

The no-cover image should only be seen if the panel can't find any of the images you specified.  If you have at least one image that contains one of the words "front", "inside", "cd", or "back", then yes, it is correct that the no-cover image is not shown for the first and second cases.

[CRASHWARE] updated foo_uie_albumart

Reply #716
removed

[CRASHWARE] updated foo_uie_albumart

Reply #717
I don't know if it helps, but albumart seems to have crashed my foobar:

http://pastebin.com/790010

I use the latest version from yesterday.

[CRASHWARE] updated foo_uie_albumart

Reply #718
i cant get this plugin to work, im using the new one from yesterday. all you have to do is put it in your components directory and restart foobar right?

[CRASHWARE] updated foo_uie_albumart

Reply #719
I don't know if it helps, but albumart seems to have crashed my foobar:

http://pastebin.com/790010

I use the latest version from yesterday.

What exactly is that link you posted?

edit: never mind, I see that it is the crashlog.  Were you doing anything in particular at the time it crashed, or did it just crash out of the blue?

i cant get this plugin to work, im using the new one from yesterday. all you have to do is put it in your components directory and restart foobar right?

You also have to be using the latest version of Columns UI as your user interface.  Then, on the "Layout" tab of the "Columns UI" page in Preferences, right-click on a Splitter and select "Insert panel->Panels->Album Art".

[CRASHWARE] updated foo_uie_albumart

Reply #720
Okay, walla, and others, I've updated the plugin.  Please redownload from here.  See if that stops the crashes.

edit: FYI, I think the crash happened because I forgot to check if the source string evaluated to nothing (a blank string).  This could happen if you have a source like "$if(%isplaying%,something,)" where the string evaluates to nothing if foobar2000 isn't playing.  Anyway, those types of strings should be okay if you download the updated version I just posted.

[CRASHWARE] updated foo_uie_albumart

Reply #721
I've lost my source list when I updated, can someone teach me how I put my "Radio Stream" image back?!

The lnew version crashed here too, I'll try the updated one now
-foobar2000 + Burrrn + EAC
-HD 80Gb using High QualityVBR MP3s


[CRASHWARE] updated foo_uie_albumart

Reply #723
Thanks
-foobar2000 + Burrrn + EAC
-HD 80Gb using High QualityVBR MP3s

[CRASHWARE] updated foo_uie_albumart

Reply #724
hi guys, i have a problem with the new albumart version 0.2.4.1

i can't see 800x600 pixels images or big size images, only mini images like 150x150

anyone with the same problem?

my config


$replace(%path%,%filename_ext%,)*
-$replace(%path%,%filename_ext%,)..\*
$substr(%_path%,1,$strrchr(%_path%,'\'))*.jpg
-match:$replace(%_path%,%_filename_ext%,)*
--components\default.*