Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: [CRASHWARE] updated foo_uie_albumart (Read 616690 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[CRASHWARE] updated foo_uie_albumart

Reply #400
.NET is not necessary. Try gdiplus.dll, otherwise download Dependancy Walker and see what it says.

[CRASHWARE] updated foo_uie_albumart

Reply #401
.NET is not necessary. Try gdiplus.dll, otherwise download Dependancy Walker and see what it says.


That's the ticket. I had a feeling it was gdi+ after perusing your source code. Sadly I was searching for a libgdi+. Thanks a bunch.

[CRASHWARE] updated foo_uie_albumart

Reply #402
Hi, first of all, thanks for continue updating this great plugin.
I have found a small issue:
When "follow cursor" is not activated, and I play an album without covers, the "default cover" doesn't change anymore, even if I play albums with covers. I have to manually correct this with "right button - first source"

I have found a temporal fix, activating "follow cursor".

[CRASHWARE] updated foo_uie_albumart

Reply #403
Could anyone make it so it's possible to use 2 album art panels? I want to use one because of how it is now and then add one to just make me able to add a new pic to the interface so it looks better.

The second album art could be used for this:

Then add a normal album art panel there.

[CRASHWARE] updated foo_uie_albumart

Reply #404
Hi, first of all, thanks for continue updating this great plugin.
I have found a small issue:
When "follow cursor" is not activated, and I play an album without covers, the "default cover" doesn't change anymore, even if I play albums with covers. I have to manually correct this with "right button - first source"

I have found a temporal fix, activating "follow cursor".

I found this bug a few days ago and have fixed it (I think...I'll go back and double-check  ).  Thanks for reporting.

Could anyone make it so it's possible to use 2 album art panels? I want to use one because of how it is now and then add one to just make me able to add a new pic to the interface so it looks better.

Multiple instances is on my "to-do" list, but it's at a lower priority than everything else.  I do plan on getting to it at some point, though.

[CRASHWARE] updated foo_uie_albumart

Reply #405
The second album art could be used for this:

Then add a normal album art panel there.


Thats one sexy layout can you share the code for the status bar & the playlist?

Also what font are you using?

 

[CRASHWARE] updated foo_uie_albumart

Reply #406
-----
Version 0.175 (May 26, 2006)
Plugin homepage

Download
Change log
Source

Known bugs and planned features:
  • BUG: display is blank on startup if image path is relative (i.e., "components\default.*")
       
  • BUG: when switching to a playlist with no items, display is blank
  • CTRL+drag to copy image
       
  • allow multiple instances (very low on the priority list)
-----

Please be aware that your "transition time" setting will be reset to 300ms when you upgrade to this version.

I added automatic cycling of sources during playback in this version.  If you don't like the automatic cycling, it's easy enough to disable on the "Behaviour" tab.  Another feature I added was that Album Art Panel now responds to items being added to the playlist.  The main benefit is that now, if you have "Auto send to playlist" enabled in Album List Panel, the album art will be updated as you browse the Album List.  It's not exactly the same as the old "external control" option from 0.8.3, but I think it's a pretty good approximation.

I've been making a lot of tweaks to how the album art changes when you change tracks or use "Next Source" and "Previous Source", so any kind of unexpected behaviour you see, please let me know and I'll take a look at it.  I'm probably going to make the location of the "No Cover" art separate from the regular sources list in the next version, and that should take care of a few of the lingering bugs that I'm seeing.

[CRASHWARE] updated foo_uie_albumart

Reply #407
Not sure what exactly you're thinking as far as splitting the source list up, but you should consider (if you aren't already) that some people have set-ups that allow for separate 'no cover' images. (e.g., i have a different 'no cover' image for audio CDs and HTTP streams than for regular cover-less albums.)
~

[CRASHWARE] updated foo_uie_albumart

Reply #408
Good job!, it seems to work pretty good!
I found two little bugs

1) The "cicle source" feature only works if "follow cursor" is deactivated.
2) Imagine this situation: I'm playing an album with more than one image (front.jpg and back.jpg) and I click on the panel to see the second source (back.jpg)... When I change to another album with more than one image, I see the second source (back.jpg) for that new album, not the first one.

[CRASHWARE] updated foo_uie_albumart

Reply #409
A bug: Using "Copy sources list to clipboard" does not include the last character of the sources list.
Always defragment your MP3s to avoid subtle lack in harmonics.

[CRASHWARE] updated foo_uie_albumart

Reply #410
My sugession to new version:

Curent cover arts list  replace with two list of cover art sourses -

1. Cover art  Images

2. No cover arts images


If cover arts exist  - its cycles only from firs list, and if not exist - its cycles only frm second list.

I don't wont cycle covert art with 'no cover' images.

[CRASHWARE] updated foo_uie_albumart

Reply #411
This has probably been addressed already somewhere (either here or in the other thread), but will there be support for finding the album art in the audio file in addition to external files?

[CRASHWARE] updated foo_uie_albumart

Reply #412
My sugession to new version:

Curent cover arts list  replace with two list of cover art sourses -

1. Cover art  Images

2. No cover arts images


If cover arts exist  - its cycles only from firs list, and if not exist - its cycles only frm second list.

I don't wont cycle covert art with 'no cover' images.



agreed, especially if the author said something about a timer to change the art. i probably wouldnt use a timer anyway, but having a no cover art image would definatly ruin it.

[CRASHWARE] updated foo_uie_albumart

Reply #413
Just took the plunge and changed to 0.9.2 b3. Biggest reason for holding out was amount of plugins in general and album art specifically. Well, I installed 0.750 with column_ui 1.3 beta 1v5. Dll is in the correct component  directory and I can access configuration in 'preferences'. However, albumart won't display in the side panel. Windows installation has NET Framework 1.1 as well as 2.0.

Any tips?


Cheers

[CRASHWARE] updated foo_uie_albumart

Reply #414
Not sure what exactly you're thinking as far as splitting the source list up, but you should consider (if you aren't already) that some people have set-ups that allow for separate 'no cover' images. (e.g., i have a different 'no cover' image for audio CDs and HTTP streams than for regular cover-less albums.)

What I was thinking was that I would have a single text box where you could enter one "No Cover" image, and if none of the sources in the source list matched, the "No Cover" image would be displayed.  Having multiple 'no cover' images would still be possible using a '-' in the source list.  It's only a suggestion, and I'm not even sure if anyone else is bothered by the way it is now.

(after reading the other comments regarding 'no cover' images, I probably won't do it like above.  But I definitely think there should be a way to distinguish a 'no cover' image from an alternate source)

1) The "cicle source" feature only works if "follow cursor" is deactivated.

Confirmed and intended (kind of).  It doesn't make sense to me to cycle covers of tracks that aren't currently playing.  I also haven't figured out yet how to check whether the currently selected track is the same as the currently playing track.

2) Imagine this situation: I'm playing an album with more than one image (front.jpg and back.jpg) and I click on the panel to see the second source (back.jpg)... When I change to another album with more than one image, I see the second source (back.jpg) for that new album, not the first one.

Is "revert to first source when current source would result in a different display" on the "behaviour" tab enabled?  (Note: right now there's no way to have it always revert to the first source)

A bug: Using "Copy sources list to clipboard" does not include the last character of the sources list.

  I thought I had checked for that.  Thanks for pointing it out.

Curent cover arts list  replace with two list of cover art sourses -

<snip>

If cover arts exist  - its cycles only from firs list, and if not exist - its cycles only frm second list.

I don't wont cycle covert art with 'no cover' images.

Interesting suggestion.  I'll see what I can do with this.  I don't think I'll make a second list, because, IMO, that will just clutter up an already cluttered Preferences page, but I'll definitely look into skipping 'no cover' images while automatically cycling.

This has probably been addressed already somewhere (either here or in the other thread), but will there be support for finding the album art in the audio file in addition to external files?

It's not on my to-do list at all.  Check the top of page 16; I think I responded to this question in more detail. (edit: it was this post)

Just took the plunge and changed to 0.9.2 b3. Biggest reason for holding out was amount of plugins in general and album art specifically. Well, I installed 0.750 with column_ui 1.3 beta 1v5. Dll is in the correct component  directory and I can access configuration in 'preferences'. However, albumart won't display in the side panel. Windows installation has NET Framework 1.1 as well as 2.0.

.NET should not be required at all.  If you're using Windows2000, do you have gdiplus.dll?  There's a link on my plugin homepage.

Also, the new version of Columns UI has no "Sidebar" like in 0.8.3.  It's been replaced by the Layout system, so you need to go to Preferences -> Display -> Columns UI -> Layout and right-click on a splitter to add the Album Art Panel.

[CRASHWARE] updated foo_uie_albumart

Reply #415
I want to get it to use the first the first 6 letters of the album and then look for in my cover directory for the cover with a filename that has the first 6 letters of the album at the start of the file name.

eg. Album - GTA San Andreas KJah

looks for GTA San*.jpg

D:\My Mp3s\Album Cover\$substr(%album%,1,6)*.jpg

Hoping it would pick up
GTA San Andreas.jpg


Also how come this component has no "About" dialog box i.e. to get the version number?.

EDIT: ITS WORKING NOW I WAS USING AN OLD VERISON OF ALBUM ART. Probably because when I tried Foobar 0.9 on my test machine. The newer dll wasn't loading up.

Thanks for your time gfngfgf

great plug-in

[CRASHWARE] updated foo_uie_albumart

Reply #416
2) Imagine this situation: I'm playing an album with more than one image (front.jpg and back.jpg) and I click on the panel to see the second source (back.jpg)... When I change to another album with more than one image, I see the second source (back.jpg) for that new album, not the first one.


Yes I have this problem now if a song that has no cover is played the default.png cover is shown. Then when a song has a cover is played the default.png is still shown. This basically goes against the objective of this component.

Why cant it go to the first source when a new song is played, and work its way down the source list. I thought that was the primary goal in an ordered source-list?

Can someone post last working version when this bug/feature didn't exist.

[CRASHWARE] updated foo_uie_albumart

Reply #417
Is "revert to first source when current source would result in a different display" on the "behaviour" tab enabled?  (Note: right now there's no way to have it always revert to the first source)

You are right, it was my fault, "revert to first source..." was deactivated
Yes I have this problem now if a song that has no cover is played the default.png cover is shown. Then when a song has a cover is played the default.png is still shown. This basically goes against the objective of this component.

As gfngfgf said... do you have "revert to first source..." activated? Activate it
Also how come this component has no "About" dialog box i.e. to get the version number?.

You can chek ALL version numbers in Preferences - Components

Keep the good work!

[CRASHWARE] updated foo_uie_albumart

Reply #418
As gfngfgf said... do you have "revert to first source..." activated? Activate it

Yeah I do in the console it just has:

searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "components\default.png"

i.e. its not going to the top of the source list.
It seems to be a bug then.

[CRASHWARE] updated foo_uie_albumart

Reply #419
i.e. its not going to the top of the source list.
It seems to be a bug then.

Make sure you're using my latest version, since this is one bug I've been trying to address.  If the problem still occurs, could you copy and paste your source list, please?  (If you have version 0.175, you can use the "copy sources to clipboard" feature, except it will cut off the last character of the last source)

edit: added link to my plugin page

[CRASHWARE] updated foo_uie_albumart

Reply #420
-----
Version 0.176 (May 27, 2006)
Plugin homepage

Download
Change log
Source

Known bugs and planned features:
  • BUG: display is blank on startup if image path is relative (i.e., "components\default.*")
  • BUG: when switching to a playlist with no items, display is blank
  • when cycling sources, "no cover" art should be skipped
  • CTRL+drag to copy image
  • allow multiple instances (very low on the priority list)
-----

Minor update to fix some issues.  The "Copy sources to clipboard" button no longer cuts off the last character.  Cycling sources should work if you have "Follow cursor" enabled and you select the currently playing track.  Finally, I added a help button to the "Sources" tab which takes you to the wiki page on Album Art Panel.

edit: added "cycling sources should skip 'no cover' art" to planned features list

[CRASHWARE] updated foo_uie_albumart

Reply #421
Make sure you're using my latest version, since this is one bug I've been trying to address.  If the problem still occurs, could you copy and paste your source list, please?  (If you have version 0.175, you can use the "copy sources to clipboard" feature, except it will cut off the last character of the last source)

edit: added link to my plugin page


Ok I tried 0.176 and the problem happened again:

Here is my source list:
D:\Top Mp3s\Album Cover\%album%.jpg
D:\Top Mp3s\Album Cover\Artist\%artist%.jpg
D:\Top Mp3s\Album Cover\$substr(%album%,1,10)*.jpg
D:\Top Mp3s\Album Cover\Artist\$substr(%artist%,1,6)*.jpg
D:\Top Mp3s\Album Cover\Artist\$substr(%artist%,1,3)*.jpg
components\default.png

Here is the console
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "D:\Top Mp3s\Album Cover\?.jpg"
searching album art, preprocessed pattern: "D:\Top Mp3s\Album Cover\Artist\Dido.jpg"
searching album art, preprocessed pattern: "D:\Top Mp3s\Album Cover\?*.jpg"

The last three were when I chose preferences. i.e. it some triggers the right code.

Also when a track has no album why does it search for ?.jpg.

Thanks

[CRASHWARE] updated foo_uie_albumart

Reply #422
parive3: Try making that last source "-components\default.png" (note the hyphen at the beginning).

edit: come to think of it, the solution I gave may or may not work.  Basically, right now there's no way to distinguish a "no cover" art from a regular source.  I'm going to try and address that in 0.180.

The reason album art panel searches for "?.jpg" is that in foobar2000's titleformatting system, if a tag can't be found, "?" is returned.  You can use this instead:

Code: [Select]
D:\Top Mp3s\Album Cover\[%album%].jpg

which will search for ".jpg" if there's no album.

[CRASHWARE] updated foo_uie_albumart

Reply #423
parive3: Try making that last source "-components\default.png" (note the hyphen at the beginning).

edit: come to think of it, the solution I gave may or may not work.  Basically, right now there's no way to distinguish a "no cover" art from a regular source.  I'm going to try and address that in 0.180.

With the dash the problem exist but it now goes to the above source rather than the first source.

searching album art, preprocessed pattern: "D:\Top Mp3s\Album Cover\Artist\Blo*.jpg"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "D:\Top Mp3s\Album Cover\Artist\Den*.jpg"
searching album art, preprocessed pattern: "components\default.png"
searching album art, preprocessed pattern: "D:\Top Mp3s\Album Cover\Artist\Way*.jpg"
searching album art, preprocessed pattern: "components\default.png"

So when I change my source list to all dashed it works fine.
D:\Top Mp3s\Album Cover\[%album%].jpg
-D:\Top Mp3s\Album Cover\Artist\[%artist%].jpg
-D:\Top Mp3s\Album Cover\$substr([%album%],1,10)*.jpg
-D:\Top Mp3s\Album Cover\Artist\$substr([%artist%],1,6)*.jpg
-D:\Top Mp3s\Album Cover\Artist\$substr([%artist%],1,3)*.jpg
-components\default.png

So I am not sure maybe that was what you intended.


Thanks for your help.

[CRASHWARE] updated foo_uie_albumart

Reply #424
I just uploaded version 0.176a, same download address (here, clear your browser cache if necessary).  There was a small bug with the "Help" button, and I think I was able to stop Album Art from flooding the console whenever you enter preferences.

parive3: if you haven't already, you should read the wiki article to understand what the hyphen does.  When the track changes, Album Art Panel will always start by searching from the first source in the current group, then if the image has changed, the panel searches from the first source (assuming that option is enabled).  In that regard, Album Art is working as intended, because (I'm guessing) "Blo*.jpg" doesn't exist, the "no cover" art is being shown anyway when you switch tracks.  I do consider it a bug, though, and I think the changes I make in the next version will fix this undesired behavior.

edit: I'll also add an option to always revert to the first source, since I can see when that might be useful.