Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: [CRASHWARE] updated foo_uie_albumart (Read 614228 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[CRASHWARE] updated foo_uie_albumart

Reply #350
Thanks to foosion for updating this component!

Ive noticed an odd behaviour, and I cant remember if it has been present for all 0.9-compatible releases of album art. It definitely isnt present on my 0.83 version, which I still have installed (for some reason)

1. Select 'Now playing' mode
2. Start playing a song
3. Click on a song from a different album
4. Doubleclick to change to 'follow cursor mode'

For 0.83, the panel switches immediately to the selected song's art, and another double click restores it. In 0.9 - the art in the panel doesnt change. Can anyone else replicate this?

Im using Foobar 0.9 (does this issue exist in later betas?), columns_ui 0.13b1v5, Album art 0.164a, Xp.

Thanks for any replies!

[CRASHWARE] updated foo_uie_albumart

Reply #351
These are the lines that I am using for the source:
match:C:\Documents and Settings\Administrator\My Documents\My Music\Album Covers\%album%.*
-C:\Documents and Settings\Administrator\My Documents\My Music\Album Covers\No cover.png

That's an interesting problem to have...  And these are the only two lines in your sources list?

carmik: That problem has been present in every version of albumart for foobar2000 0.9, as far as I can tell.  It bothers me, too.

edit: I've been mucking around with the code, and I think I've fixed the problem carmik described.  I'm going to see if I can get to any of the other bugs that people have pointed out before I release anything, and *possibly* some new features, but my priority is the bug fixes.

[CRASHWARE] updated foo_uie_albumart

Reply #352

These are the lines that I am using for the source:
match:C:\Documents and Settings\Administrator\My Documents\My Music\Album Covers\%album%.*
-C:\Documents and Settings\Administrator\My Documents\My Music\Album Covers\No cover.png

That's an interesting problem to have...  And these are the only two lines in your sources list?

Correct, just these two lines.  Kind of tired at the moment, but if I remember correctly, I was having this problem with the later v0.8.3 too.  But, never questioned it since at the time I could edit the streams info to add something to the %album% field.

[CRASHWARE] updated foo_uie_albumart

Reply #353
In Foobar if there is no album tag, %album% will just display a question mark, so the input to album art is

Code: [Select]
match:C:\Documents and Settings\Administrator\My Documents\My Music\Album Covers\?.*


For file matching ? is any single character, so the Album Art plug-in is asked to find a file where the second character is a period.

Try
Code: [Select]
match:C:\Documents and Settings\Administrator\My Documents\My Music\Album Covers\$if2(%album,No cover).*


Anders

[CRASHWARE] updated foo_uie_albumart

Reply #354
Fond a bug in Album Art Panel 0.164a.

If all sources are removed i throws a "Unhandled exception : Bug check".

Anders

[CRASHWARE] updated foo_uie_albumart

Reply #355
For file matching ? is any single character, so the Album Art plug-in is asked to find a file where the second character is a period.

Good call.  Another option is to use "album.???", but that assumes all your images have three characters in the extension (for instance, wouldn't work if you have "album.jpeg").

I'll take a look at that "unhandled exception".

[CRASHWARE] updated foo_uie_albumart

Reply #356
Sadly, Anders' code does seem to have an effect on the results.  I tried messing around with the precedence but didn't have any luck.  And, gfngfgf, haven't tried your suggestion yet.  How would the "album.???" work?

[CRASHWARE] updated foo_uie_albumart

Reply #357
Thanks to foosion for updating this component!

Ive noticed an odd behaviour, and I cant remember if it has been present for all 0.9-compatible releases of album art. It definitely isnt present on my 0.83 version, which I still have installed (for some reason)

1. Select 'Now playing' mode
2. Start playing a song
3. Click on a song from a different album
4. Doubleclick to change to 'follow cursor mode'

For 0.83, the panel switches immediately to the selected song's art, and another double click restores it. In 0.9 - the art in the panel doesnt change. Can anyone else replicate this?

Im using Foobar 0.9 (does this issue exist in later betas?), columns_ui 0.13b1v5, Album art 0.164a, Xp.

Thanks for any replies!


yup, im having the exact same problem man. the problem is that the image doesnt refresh when toggle cursor is enabled or disabled. i think it can easily be fixed tho if the image was refreshed right after toggle cursor is enabled. you can verify this by assigning refresh to double click, and toggle cursor to left click. assuming you would want double click to toggle follow coursor, this would result in correct behavior. however the menu option to toggle follow cursor still wont work though, and you cant really assign the buttons however you want them. i want to use double click to 'focus playing' and middle click to toggle follow cursor its not that big of a deal, im sure it will be fixed soon.

another thought i had about toggle cursor was that it would be cool if the track info panel and album art could share the same follow cursor option. eg, toggling folow cursor on either the track info and album art would toggle both of them.

[CRASHWARE] updated foo_uie_albumart

Reply #358
Sadly, Anders' code does seem to have an effect on the results.  I tried messing around with the precedence but didn't have any luck.  And, gfngfgf, haven't tried your suggestion yet.  How would the "album.???" work?

"?" is a wildcard which stands for a single character, whereas "*" matches 1 or more characters.  For instance, if your source was "a?bum", you'd match "album", "abbum", "a3bum", etc., but not match "alllabum" or "a long phrase before bum".  If your source is "a*bum", you would match all of the above examples.

edit:

Just saw this slight error in Anders' string.  Note the missing '%':

Code: [Select]
match:C:\Documents and Settings\Administrator\My Documents\My Music\Album Covers\$if2(%album%,No cover).*

[CRASHWARE] updated foo_uie_albumart

Reply #359

Sadly, Anders' code does seem to have an effect on the results.  I tried messing around with the precedence but didn't have any luck.  And, gfngfgf, haven't tried your suggestion yet.  How would the "album.???" work?

"?" is a wildcard which stands for a single character, whereas "*" matches 1 or more characters.  For instance, if your source was "a?bum", you'd match "album", "abbum", "a3bum", etc., but not match "alllabum" or "a long phrase before bum".  If your source is "a*bum", you would match all of the above examples.

edit:

Just saw this slight error in Anders' string.  Note the missing '%':

Code: [Select]
match:C:\Documents and Settings\Administrator\My Documents\My Music\Album Covers\$if2(%album%,No cover).*


Saw that too, 'tis why I was messing with the precedence a bit.  With the line orders that I tried it was all the ROD image or it didn't have an effect.  Also, how would you use "album.???" in the source?

[CRASHWARE] updated foo_uie_albumart

Reply #360
Saw that too, 'tis why I was messing with the precedence a bit.  With the line orders that I tried it was all the ROD image or it didn't have an effect.  Also, how would you use "album.???" in the source?

You would just use this as a source:

Code: [Select]
C:\Documents and Settings\Administrator\My Documents\My Music\Album Covers\%album%.???

(note, the "match:" prefix has been optional since version 0.160)

[CRASHWARE] updated foo_uie_albumart

Reply #361
hi,
there is 2 bugs with the 2 following options :
(behaviour tab)
- album cover art follows cursor even when playing
check it, then save, it's automatically unchecked ! but it works. but now you want to desactivate this option, you can't, because the checkbox is always unchecked...
- maybe linked to the first problem (it worked until I change the option above), the second check box to be able to change cover when clicking in Album list panel, even when checked it doesn't work...

and before it had worked perfectly, but I touched the first option, I shouldn't have...

edit: version 0.164, foobar 0.9.1, colUI 0.1.3b1v4

[CRASHWARE] updated foo_uie_albumart

Reply #362
First thing I'd do, update your components:
version 0.164 to 0.164a
version colUI 0.1.3b1v4 to 0.1.3b1v5

[CRASHWARE] updated foo_uie_albumart

Reply #363
First thing I'd do, update your components:
version 0.164 to 0.164a
version colUI 0.1.3b1v4 to 0.1.3b1v5


sure that's what I did, I ignored that there was a new version on album_art. Then the bug of the checkboxes is no more here. But when I click on different items in the album list panel, I still have to select a song in the playlist to view the cover. All that with of course the checkbox 'allow external control of cover art' checked...
any ideas ?

column ui updated too to b1v5

[CRASHWARE] updated foo_uie_albumart

Reply #364
Quote
I still have to select a song in the playlist to view the cover. All that with of course the checkbox 'allow external control of cover art' checked...
any ideas ?

Isn't that the default behaviour?
I don't use that feature mate nor the playlist one, I'm not able to confirm.

[CRASHWARE] updated foo_uie_albumart

Reply #365
I think even in 0.8.3, you needed a modified version of album list for that "external control of cover art" option to work correctly.  Unless someone can absolutely confirm that they've had it working for them in 0.9, I'm just going to remove that option.  I don't think it's reasonable to expect other plugins to be updated to support one feature in album art.

[CRASHWARE] updated foo_uie_albumart

Reply #366
Thanks a bunch for all the work the developer(s) is/are doing.
Mainly two things have been already requested a while back but still ( hopefully work in progress ) not available.
1.Retrieving album art from tags
2.Horizontal and vertical padding.
I'm not well acquainted with coding though 
I guess a lot of people here would like to see those features included in the next version if you don't mind Sir 
Thanks again.

[CRASHWARE] updated foo_uie_albumart

Reply #367
Is there any user guide for the plugin. I've got it in the components together with Columns UI but I cannot figure out how to use it. I right-clicked on the player but have nothing like panels menu entry. Also is it possible to make album cover displayed somewhere on the screen with every new song played when foobar is minimised to tray. I am sorry for stupid questions but I cannot find the answers...

[CRASHWARE] updated foo_uie_albumart

Reply #368
I think even in 0.8.3, you needed a modified version of album list for that "external control of cover art" option to work correctly.


yes
Music is my first love.

[CRASHWARE] updated foo_uie_albumart

Reply #369
... but I cannot figure out how to use it. I right-clicked on the player but have nothing like panels menu entry...

foobar -> Preferences -> Columns UI -> Layout -> Insert a splitter -> Right-Click that very splitter and choose insert panel -> Album Art.

[CRASHWARE] updated foo_uie_albumart

Reply #370

... but I cannot figure out how to use it. I right-clicked on the player but have nothing like panels menu entry...

foobar -> Preferences -> Columns UI -> Layout -> Insert a splitter -> Right-Click that very splitter and choose insert panel -> Album Art.

oh, thanks a lot! btw is it possible to have a pop-up display with album cover at the beginning of each song. I saw it on a screenshot, but not sure if it is done by this or some separate plugin...


[CRASHWARE] updated foo_uie_albumart

Reply #372
I think even in 0.8.3, you needed a modified version of album list for that "external control of cover art" option to work correctly.  Unless someone can absolutely confirm that they've had it working for them in 0.9, I'm just going to remove that option.  I don't think it's reasonable to expect other plugins to be updated to support one feature in album art.

Oh, how I miss this feature. You see, browsing the Album list feels more like browsing a physical CD collection if the album art is displayed for each CD. It feels more real. Could it have something to do with memorisation? Perhaps there is hope for an Album list update by musicmusic? Maybe if we ask him politely?

[CRASHWARE] updated foo_uie_albumart

Reply #373
Perhaps there is hope for an Album list update by musicmusic? Maybe if we ask him politely?

Even so, the 0.8.3 modified Album List Panel wasn't very stable.  I remember lots of crashes related to people having that .dll installed.

Something I might look into is whether the album art can change if you have "auto send to playlist" enabled in Album List Panel.  I think that would have the "browsing a real CD collection" feel to it.

 

[CRASHWARE] updated foo_uie_albumart

Reply #374
As if this plugin hasn't been passed around to enough developers, I've made some changes of my own, and I'd like to release the new version for people to take a look at

-----
Version 0.170 (May 20, 2006)
Plugin homepage

Download
Change log
Source

Known bugs and planned features:
  • BUG: display is blank on startup if image path is relative (i.e., "components\default.*")
       
  • allow user to choose color of pixel border
       
  • automatically cycle through sources via adjustable timer
       
  • allow multiple instances (very low on the priority list)
-----

Read the change log for all the changes I made.  I'd really love to get some feedback and bug reports on "Next Source" and "Previous Source".  I practically rewrote those two functions, which fixed several odd behaviors, but it's still not perfect.