Skip to main content

Topic: [CRASHWARE] updated foo_uie_albumart (Read 559787 times) previous topic - next topic

0 Members and 2 Guests are viewing this topic.
  • Melomane
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #850

gfngfgf
in the last version of playlist tree
cwbowron as Added notification callback, so other plugins can be notified of tree selections.

do you think it is possible to use this in album art panel ?
thanks

I'll look into it.


i love you !
Music is my first love.

  • RandomEngy
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #851
I know you say you don't have support for embedded art planned, but it be a killer feature for me; as of now it's unusable.  I have several folders full of miscellaneous Mp3s which would be a complete hassle to segregate into their own folders, so currently it just picks the album art from some random track for all of them.

To me it makes sense if the art is associated with the file and not with the directory it's in.  Is there some reason why support for this is not planned?
  • Last Edit: 02 February, 2007, 01:58:48 AM by RandomEngy

  • gfngfgf
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #852
I'm actually now considering adding support for embedded tags (in ID3V2 and probably FLAC as well), but I should stress that I don't have any timetable set.  I'm busy with school right now, so it's tough to make time to work on this plugin.

  • RandomEngy
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #853
Hey, no sweat.  Thanks for keeping it in mind.

  • butmunch
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #854
Whenever I add this to my columns UI foobar crashes saying
"Unhandled Exception: dynamic assert failure"



Code: [Select]
Core (2006-11-25 13:21:34)
    foobar2000 core 0.9.4.2
foo_albumlist.dll (2006-11-25 17:49:06)
    Album List 3.2.0
foo_cdda.dll (2006-11-25 13:19:46)
    CD Audio Decoder 2.1.1
foo_converter.dll (2006-11-25 13:20:00)
    Converter 1.0.1
foo_dsp_atsurround.dll (2006-10-29 16:05:04)
    ATSurround Processor 0.1.6a
foo_dsp_std.dll (2006-11-25 13:20:12)
    Standard DSP array 1.0
foo_input_std.dll (2006-11-25 13:19:14)
    FLAC Decoder 1.1.0
    Standard Input Array 1.0
    WMA Decoder 1.1
foo_rgscan.dll (2006-11-25 13:18:18)
    ReplayGain Scanner 2.0.2
foo_ui_columns.dll (2006-11-22 12:05:24)
    Columns UI 0.1.3 beta 1v7
foo_ui_std.dll (2006-11-25 13:18:12)
    Default User Interface 0.9acc
foo_uie_albumart.dll (2007-01-14 23:09:26)
    Album Art Panel 0.2.6
foo_uie_quicksearch.dll (2007-01-03 14:18:46)
    Quick Search Toolbar 2.8k
foo_vis_flame.dll (2006-08-13 18:11:22)
    Flame visualisation 0.93


which sucks, have I been a complete noob and missed something? I haven't used foobar for the best part of a year.

  • gfngfgf
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #855
which sucks, have I been a complete noob and missed something? I haven't used foobar for the best part of a year.

Re-download Album Art 0.2.6 and make sure it is dated 01-15-2007.  That bug was in the initial release and fixed, but I didn't change the version number.

  • jako
  • [*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #856
oh my god
something must be wrong

i just download it for 1 hour and the date of the file seems to change to 01-15-2007 instead of 01-14-2007
  • Last Edit: 10 February, 2007, 03:39:29 AM by jako

  • Laemtao
  • [*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #857
I have this strange problem where when my playlist is empty, the album art panel will show the cover art from the first R.E.M. album (in alphabetical order) I have in my album art directory.

So, when my playlist is empty, it will show "R.E.M. - Automatic For The People.jpg", and if I delete that, it will show the next file that starts with R.E.M.

When I delete all of the R.E.M. album covers from the dir, it displayes the no artwork pic like it should.
It does not display any other album cover when it shouldn't, only one's starting with R.E.M.

What in nine hells is happening here?

Here is my sources config:
Code: [Select]
f:\album art\%artist% - %album%.*
-f:\album art\%artist%.*
-f:\album art\%album%.*
-f:\album art\nocover.png


EDIT: I found that putting brackets around the %artist% and %album% variables fixes the problem, but still, why R.E.M.?
  • Last Edit: 14 February, 2007, 08:57:03 PM by Laemtao

  • gfngfgf
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #858
EDIT: I found that putting brackets around the %artist% and %album% variables fixes the problem, but still, why R.E.M.?

Because if there is no track (i.e., the playlist is empty), "%artist%" and "%album%" both return '?', thus, album art panel will search for an image that matches "f:\album art\?.*".  Any image that starts with "R.E.M." matches that pattern.

  • Hakubo
  • [*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #859
Hi gfngfgf. I think I have found a bug.



Note the reduced image quality, when it's centered.

  • barry123
  • [*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #860
I use this code now

[foo_uie_albumart]
$replace(%path%,%filename_ext%,)folder.jpg
-$replace(%path%,%filename_ext%,)folder.png
-$replace(%path%,%filename_ext%,)folder.gif
--components\default.*
[End]

but is there any way to change the code like this

%filename%.jpg


my covers have different names and I dont wanna change 5000 jpg's to folder.jpg
and for my new albums it's a lot of work to.
I just want to use the name they already have.

Is this possible, so something like this:

[foo_uie_albumart]
$replace(%path%,%filename_ext%,)%filename%.jpg
-$replace(%path%,%filename_ext%,)folder.png
-$replace(%path%,%filename_ext%,)folder.gif
--components\default.*
[End]

  • gfngfgf
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #861
my covers have different names and I dont wanna change 5000 jpg's to folder.jpg
and for my new albums it's a lot of work to.
I just want to use the name they already have.

Just use the '*' wildcard, which can stand for anything:

Code: [Select]
$replace(%path%,%filename_ext%,)*.jpg

This will pick up the first (jpeg) image in the same folder as the currently playing track.

  • Hakubo
  • [*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #862
Strangely enough, reverting to 0.164a did not help.

Anybody else experiencing this behavior?

Hi gfngfgf. I think I have found a bug.



Note the reduced image quality, when it's centered.

  • gfngfgf
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #863
Strangely enough, reverting to 0.164a did not help.

Anybody else experiencing this behavior?

Yes, actually. Sorry for not responding earlier.  I think I was able to fix this issue.  Thanks for the report.

  • Hakubo
  • [*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #864
Thanks. After I noticed the problem, it became sort of annoying.
Hope you release the fixed version soon.

  • Hall
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #865
[FEATURE REQUEST]

Hello guys, I have a feature request!!!

Can you make foo_uie_albumart retrieve cover images within archives?

I normally RAR-up my perfectly tagged albums, including the jpegs for the cover art. I rely on foo_unpack to extract & play the tracks inside.

It would be great if foo_uie_albumart could extract the cover art.

  • gfngfgf
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #866
It would be great if foo_uie_albumart could extract the cover art.

It already can (since 0.2.5), but no wildcard support.

  • Hall
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #867

It would be great if foo_uie_albumart could extract the cover art.

It already can (since 0.2.5), but no wildcard support.



Hey great! But I use wildcards to scan through sources though :-(.
I'll drop in a few manual filenames for now.
Hope the wildcard support will be implemented in the future.

[CRASHWARE] updated foo_uie_albumart
Reply #868

It would be great if foo_uie_albumart could extract the cover art.

It already can (since 0.2.5), but no wildcard support.

Good to know...
Unfortunately I don't have WinRar (or equiv.), Does this work for zip?
No luck yet

Thanks!
Peace

  • dr.zick
  • [*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #869
[stupid feature request]
could we get a foobar spawned window for the "external viewer" option ... my windows always opens an image in "micro$oft image and fax viewer" no matter how many times i hack the registry to tell it to not do that, and the "ms image viewer" always opens full screen no matter how much i try to get it to not do that.

my idea, a little window (say like the console) pop up and display the image.  kinda like itunes does.  maybe we can have a customization option panel in the plugin preferences, that will determine title string displayed, window width and height size, and maybe an image source if we want to have a "big" image displayed in this window as opposed to a smaller image displayed in the album art panel.

just an idea ... thanks for feedback.

  • Empyrean
  • [*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #870
I'm actually now considering adding support for embedded tags (in ID3V2 and probably FLAC as well), but I should stress that I don't have any timetable set.  I'm busy with school right now, so it's tough to make time to work on this plugin.


I know you are busy, but I'd just want you to know there is an audience out there for this.  For me personally, FLAC is more important than ID3.

Looking forward to future updates and still enjoying now.

  • Fredrik
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #871
Im using the latest version of foobar and using PanelsUI and album art aint working... why?
I dont even have a control page on preferences, aint there one ?

Thanks for reading!




EDIT: NVM it works now!
  • Last Edit: 05 March, 2007, 12:30:25 PM by Fredrik

  • dr.zick
  • [*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #872
Im using the latest version of foobar and using PanelsUI and album art aint working... why?
I dont even have a control page on preferences, aint there one ?

Thanks for reading!




EDIT: NVM it works now!



mine works ... is it not working or not displaying?

  • Kosmas
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #873
I think I found a bug. I use the following lines for source:
Quote
[foo_uie_albumart]
$replace(%path%,%filename_ext%,)*
-$replace(%path%,%filename_ext%,)..\*
--components\default.*
[End]

This searches not only in the current dir, but also in the next upper directory. So when I have a multiple CD-Album I need only one picture, e.g "The_Wall" has two CDs in subdirs "CD1" and "CD2". This worked well with foo_uie_albumart 0.2.1, but not in 0.2.6. Now I see only pictures of my single-CD albums.

AlbumArt 0.2.1 displays the following lines in the debug-window (console):
Quote
searching album art, preprocessed pattern: "C:\mp3\Pink Floyd\1979-The Wall\CD1\*"
searching album art, preprocessed pattern: "c:\mp3\Pink Floyd\1979-The Wall\CD1\..\*"

AlbumArt 0.2.6 displays the following lines in the debug-window:
Quote
searching album art, preprocessed pattern: "C:\mp3\Pink Floyd\1979-The Wall\CD1\*"
  0 match(es) found
searching album art, preprocessed pattern: "C:\mp3\Pink Floyd\1979-The Wall\CD1\..\*"
  0 match(es) found

So the same directories are searched, but with 0.2.6 there will no files be found. Is this a bug or what is wrong? Is the ".." for one directory up not valid any more?

Thanks for reading.

  • Kosmas
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #874
Ok, after short investigation I found a workaround. I replaced the second line as follows:

Quote
-$replace($replace(%path%,%filename_ext%,),%directory%\,)*

Now this works like the older string in the previous version. Instead of using '..' it directly deletes the last dir inside the string. Or is there a better way?

Thanks for reading.