Skip to main content

Topic: [CRASHWARE] updated foo_uie_albumart (Read 559782 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Punio.4
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #25
Quote
Quote
Just a question... been having this problem with the old version too...
There is an option to control it also via the album list panel, however the albumart doesn't change until I select a track in the playlist (if follow cursor is enabled).
[{POST_SNAPBACK}][/a]


It's never worked for me either. I believe it requires a modified version of the album list panel. The original foo_uie_albumart zip file (which can be found [a href="http://pelit.koillismaa.fi/plugins/redir.php?id=561]here[/url]) includes this. It's older than the foo_uie_albumlist I was using, but it does work properly with this feature. I prefer my album art to display the currently playing track anyway...
[a href="index.php?act=findpost&pid=351786"][{POST_SNAPBACK}][/a]


thanx, it really works now ^^

[CRASHWARE] updated foo_uie_albumart
Reply #26
Wow!  I never thought a little thing like fading would make such a big difference.  Excellent work and thanks!
- FLAC/200GB external
- AAC 128 vbr/local
- iPod Nano 2G 8GB

  • stripe
  • [*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #27
Any chance you could have a go at trying to fix this bug?

stripe/ben
  • Last Edit: 24 December, 2005, 02:52:07 PM by stripe

  • gfngfgf
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #28
Quote
Any chance you could have a go at trying to fix this bug?

stripe/ben
[{POST_SNAPBACK}][/a]

[a href="http://www.hydrogenaudio.org/forums/index.php?showtopic=29383&view=findpost&p=320363]fixed url[/url]

Can you paste your sources list here?

  • Storm
  • [*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #29
Looks great, watch out for the new SDK when it comes out, this would be really hot for 0.9...

  • acedriver
  • [*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #30
love the transition..

  • stripe
  • [*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #31
Quote
Quote
Any chance you could have a go at trying to fix this bug?

stripe/ben
[{POST_SNAPBACK}][/a]

[a href="http://www.hydrogenaudio.org/forums/index.php?showtopic=29383&view=findpost&p=320363]fixed url[/url]

Can you paste your sources list here?
[a href="index.php?act=findpost&pid=352140"][{POST_SNAPBACK}][/a]


(whoops, should have previewed)  I'm currently using the default sources, but with earlier versions of albumart I have attempted plenty of different configs, none of which worked.  I'm getting the exact same behavior with this version, so I don't think the source list is the problem.

-ben/stripe

[CRASHWARE] updated foo_uie_albumart
Reply #32
Great work on the update, and would there be any chance of adding support for reading in archived files ?
You're talking to my guy all wrong... It's the wrong tone. Say it again, and i'll stab you in the face with a soldering iron!

[CRASHWARE] updated foo_uie_albumart
Reply #33
Very awesome idea, I love the transition.

500 miliseconds is perfect. :D

  • david_dl
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #34
Quote
Great work on the update, and would there be any chance of adding support for reading in archived files ?
[a href="index.php?act=findpost&pid=352221"][{POST_SNAPBACK}][/a]


I'll investigate this some time after christmas, if I can do it through the foobar archive plugin (I forget what its called, its midnight on christmas day here  ) it shouldn't be too hard.

500ms, that's the default I set right? I did a lot of research before settling on 500 

  • tksh
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #35
Has anyone else notice this with transitions?

Turn off "follow cursor" mode.  Play the second song and then select the first song.  Albumart should show second song's cover, and it does.  Now advance to the next track, instead of fading from the second song's to the third song's cover, it immdiately shows the first song's cover (the selected track) and then fades to the third song's cover.

Using foobar 8.3 with columns_ui here.

  • gfngfgf
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #36
Quote
(whoops, should have previewed)  I'm currently using the default sources, but with earlier versions of albumart I have attempted plenty of different configs, none of which worked.  I'm getting the exact same behavior with this version, so I don't think the source list is the problem.

-ben/stripe
[a href="index.php?act=findpost&pid=352209"][{POST_SNAPBACK}][/a]

Hmm, are you still using Windows 98SE?  Is there anybody who is using the albumart plugin and Windows 98 without errors?

  • david_dl
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #37
Quote
Has anyone else notice this with transitions?

Turn off "follow cursor" mode.  Play the second song and then select the first song.  Albumart should show second song's cover, and it does.  Now advance to the next track, instead of fading from the second song's to the third song's cover, it immdiately shows the first song's cover (the selected track) and then fades to the third song's cover.

Using foobar 8.3 with columns_ui here.
[a href="index.php?act=findpost&pid=352302"][{POST_SNAPBACK}][/a]


Fixed  , Get the update from my first post.

  • tksh
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #38
Quote
Fixed  , Get the update from my first post.
[a href="index.php?act=findpost&pid=352353"][{POST_SNAPBACK}][/a]


Yep, it's working as expected now.  Thanks for the quick fix.

  • Slourte
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #39
I'm having a hard time refreshing a cover that has been changed... anyone else noticed that? Great work nonetheless!

  • bigdave
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #40
Thanks for this great plugin the fading between album art images looks just great. 



Nice job.

  • gfngfgf
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #41
One little thing: I normally have foobar2000 minimized to the system tray.  When I open it and the album art has changed, it fades from the old album art to the current one.  This is kind of awkward, though, because I might have minimized foobar2000 4 hours ago, and the old album art is, well, old.  Is it possible to have the album just change when foobar2000 is restored, rather than fade?

  • corganzero0
  • [*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #42
I have a simply question:
how can I get this plugin to display whatever image I have in the folder where the playing file is located, regardless of file name?

  • gfngfgf
  • [*][*][*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #43
Quote
I have a simply question:
how can I get this plugin to display whatever image I have in the folder where the playing file is located, regardless of file name?
[a href="index.php?act=findpost&pid=354050"][{POST_SNAPBACK}][/a]

Code: [Select]
match:$replace(%_path%,%_filename_ext%,)*


That should do the trick.

[CRASHWARE] updated foo_uie_albumart
Reply #44
Quote
To the people who are talking about the album art panel interacting with the album list panel: yes, you need the modified foo_uie_albumlist.dll that is/was included with foo_uie_albumart.  I remember, though, that there were many bug reports related to this modified album list panel, so be warned.[a href="index.php?act=findpost&pid=351813"][{POST_SNAPBACK}][/a]

is there anybody who can fix that albumlist panel modification?, because that along with this updated albumart would be so beautiful.

  • VLSI
  • [*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #45
Quote
Black is the default background colour. If you want a different colour use the options on the preferences page (Use background colour).
Hope that helps.
[a href="index.php?act=findpost&pid=351737"][{POST_SNAPBACK}][/a]

I think originally the default colour was the window background colour, usually light gray, but dependent on your Windows settings/theme.  It would be great if you could revert to the old behavior.  Also, please post your latest source for the fading version.  Thanks in advance.

  • rexy
  • [*][*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #46
Great to see further development of my code. Good luck, david.

  • WigBaM
  • [*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #47
Quote
One little thing: I normally have foobar2000 minimized to the system tray.  When I open it and the album art has changed, it fades from the old album art to the current one.  This is kind of awkward, though, because I might have minimized foobar2000 4 hours ago, and the old album art is, well, old.  Is it possible to have the album just change when foobar2000 is restored, rather than fade?
[a href="index.php?act=findpost&pid=353757"][{POST_SNAPBACK}][/a]

Put my hand up for this one as well! 
B KaCKe.

  • WigBaM
  • [*][*]
[CRASHWARE] updated foo_uie_albumart
Reply #48
Also this needs to be dealt with as well please. The problem is when you have multiple sources and one of them is not there album_art shows the last good source in the list instead of continuing skipping until the next good one is found. Hope you'll get it sorted! 
Anyway, great job!

Added: Another one, bind 'first  source' as a double-click action. Now when I double click the first source shows up only for a brief moment before it switches to second source.

[span style='font-size:13pt;line-height:100%']FIXED SOURCE[/span]
David, I had a look into the source myself and managed to fix all of the above issues (not the system tray one though):

in uie_albumart.cpp:
Code: [Select]
bool uie_albumart::set_image(..
....
 if(!file.is_empty()){
     Bitmap bmp(string_wide_from_utf8(file.get_ptr()));
     if(bmp.GetHeight()){
   img=file;
   crnsource = n; -ADDED THIS TO FIX ALBUM COVER STAYING ON;
   break;
     }
 }


I've implemented a little walk-around on the issue with double-clicking returning the second source. In the same uie_albumart.cpp:
Code: [Select]
LRESULT WINAPI uie_albumart::on_message(HWND wnd1,UINT msg,WPARAM wp,LPARAM lp){
    static bool b_dblclick = false; -ADDED THIS VARIABLE TO INDICATE DOUBLE-CLICK
    switch(msg)
    {
    case WM_CREATE:
....
....
 break;
    case WM_LBUTTONDBLCLK:
 click_func(cfg_dblclickfunc);
 b_dblclick = true; -ADDED
 break;
    case WM_LBUTTONUP:
 if(!b_dblclick){  -ADDED
     click_func(cfg_lftclickfunc);
 }
 b_dblclick = false;
 break;
    case WM_MBUTTONUP:


Hope it helps!
  • Last Edit: 17 January, 2006, 10:12:50 PM by WigBaM
B KaCKe.

  • ak47mega
  • [*]
[CRASHWARE] updated foo_uie_albumart
Reply #49
Anybody who know foo_ui_albumart 2 and more used ?
ex) trackinfo.dll trackinfo2.dll trackinfo3.dll

thanks for your help..
  • Last Edit: 18 January, 2006, 07:20:24 AM by ak47mega