Skip to main content
Topic: foo_encspot (Read 6486 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_encspot

foo_encspot.dll 0.1 - 67k

This plugin adds a context menu item (Get Encoder...) that uses EncSpot to detect the encoder used to encode an mp3, then sets ENCODEDBY to that encoder.

This is my first shot. I just grabbed the encspot console source and hacked it to work as a foobar plugin, and I'm extremely rusty with C++, so no guarantees about quality whatsoever. Also, I'm somewhat busy, so updates may be sparse.

Known bugs:
- Crashes on non-mp3s
- No progress bar

foo_encspot

Reply #1
Do you have a plan for the settings page? e.g. for customizing the tag name (being 'ENCODEDBY' by default), to disable tag updates (just show the info), anything else...

foo_encspot

Reply #2
Kickass, thanks for this! I think it will be very useful.

foo_encspot

Reply #3
Great idea!  Thanks for the plug-in.  Any chance of this expanding to different codecs (aac, mp4) or detecting the means by which it was encoded (--alt-preset, etc).  I don't even know if this is possible, but just an idea.  Thanks again.

<<--Downloads

foo_encspot

Reply #4
mp4's and LAME use their own tags, so no guessing required

foo_encspot

Reply #5
Grrreat plugin 
You noticed it stopped working after 508 files?
When you process n mp3 files, you'll get this warning: "Detected 508 files successfully with <n-508> errors". Then you need to restart foobar to be able to continue.

foo_encspot

Reply #6
Quote
Grrreat plugin 
You noticed it stopped working after 508 files?
When you process n mp3 files, you'll get this warning: "Detected 508 files successfully with <n-508> errors". Then you need to restart foobar to be able to continue.
[a href="index.php?act=findpost&pid=302991"][{POST_SNAPBACK}][/a]

Trial version?

foo_encspot

Reply #7
THANK YOU so much for this, the only problems I have with it are in fact it does only seem to apply to 508 files at a time, and also sometimes the wrong encoder was detected if the file did not contain an id3v2 tag, I had to convert some tags to id3v2 for the plugin to be able to read the Lame version. But ultimately this is one of the most useful plugins around, thank you.

foo_encspot

Reply #8
Thank you for this plugin. Will it be released for foobar 0.9.x ?
WavPack 4.31 -hm

foo_encspot

Reply #9
Quote
Failed to load DLL: foo_encspot.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.


With foobar 0.92 under win xp x64.Do i need to install additional libraries?
Favourite artist:CD-R
Favourite album:700MB

foo_encspot

Reply #10
Quote
Failed to load DLL: foo_encspot.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.


With foobar 0.92 under win xp x64.Do i need to install additional libraries?

I'd guess you need to install fb 0.8.3
Is over the of = % over 100

foo_encspot

Reply #11

Quote
Failed to load DLL: foo_encspot.dll
Reason: This component is missing a required dependency, or was made for different version of foobar2000.


With foobar 0.92 under win xp x64.Do i need to install additional libraries?

I'd guess you need to install fb 0.8.3


Thanx,my mistake
Favourite artist:CD-R
Favourite album:700MB

 
SimplePortal 1.0.0 RC1 © 2008-2019