Skip to main content

Topic: iPod mini 2G stutters when playing LAME aps (Read 124962 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Busemann
  • [*][*][*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #50
Quote
Their reaction was a shoulder shug as he suggestion to use the built-in mp3 encoder.


So it doesn't happen with the iTunes encoder?

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #51
Quote
So it doesn't happen with the iTunes encoder?
[a href="index.php?act=findpost&pid=299559"][{POST_SNAPBACK}][/a]

I have tested the iTunes mp3 encoder at the following settings:
- MP3 128kbps VBR Highest Quality
- MP3 192kbps VBR Highest Quality
- MP3 256kbps VBR Highest Quality

Only with LAME is it possible to create the problem.

  • earphiler
  • [*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #52
i just bought an iriver h320 for 210  used shipped.

i had one before but i had to sell it cos i needed money  this is purrrrfect

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #53
Quote
just loaded up Nine Inch Nails - Right Where It Belongs (towards end is the major skip-test) on my dad's 2G 4GB mini, and it skipped

if no fix comes out in the next 2 months, i'm going to buy a non-apple DAP. this is unacceptable and i'm getting impatient (although my 3G 15GB is suffice)
[{POST_SNAPBACK}][/a]

The stuttering / skipping on that song is terrible! 

I have added the lossless sample and updated my initial post:
[a href="http://www.hydrogenaudio.org/forums/index.php?showtopic=33486&view=findpost&p=300284]Nine Inch Nails - Right Where it Belongs[/url]

  • Faelix
  • [*][*]
iPod mini 2G stutters when playing LAME aps
Reply #54
Just a hint:

Searching about general AAC compatibility on iPod, I've found this topic about Nero AAC skipping, and, although the discussion wasn't thoroughly conclusive, there were indications about iTunes tagging system. By any chance, could VBR stuttering be aliviated if iTunes had the opportunity of analysing the music files before upoloading to iPod?

P.S.: Sorry if this is B.S., I don't have an iPod, but I'd like one very much, and I'm very sensitive about such bug reports.

iPod mini 2G stutters when playing LAME aps
Reply #55
Having just acquired a 2nd gen mini, I loaded on some of the test samples from sehested's original post. Thought my results would be of interest.

Results so far:

Five_Years_20s.mp3 - slight stutter just prior to file's end (possibly due to the mp3 slice?)

Five_Years_LAME.mp3 - plays perfectly

AWS_HOPE_XM_cut.mp3 - one tiny gap in playback around the 14 second mark

EQ was off for all of these tests.

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #56
Quote
Having just acquired a 2nd gen mini, I loaded on some of the test samples from sehested's original post. Thought my results would be of interest.

Results so far:

Five_Years_20s.mp3 - slight stutter just prior to file's end (possibly due to the mp3 slice?)

Five_Years_LAME.mp3 - plays perfectly

AWS_HOPE_XM_cut.mp3 - one tiny gap in playback around the 14 second mark

EQ was off for all of these tests.
[a href="index.php?act=findpost&pid=307368"][{POST_SNAPBACK}][/a]

What about NIN? The stuttering is quite obvious at the end on that song.

Are you sure that the clock speed was not 80 all along?

If your iPod was connected to the computer it would stay at 80. Also sometimes the clock speed gets stuck on 80 and speed optimisation isn't used. To rule out this from happening you can reset your iPod by pressing and holding MENU and select for a couple of seconds.

I have personally checked two 2G minis that both have the problem.

Eventually Apple will release new iPod mini software that should fix the problem. My 2G mini came with version 1.3. What version are you running?

iPod mini 2G stutters when playing LAME aps
Reply #57
Quote
What about NIN? The stuttering is quite obvious at the end on that song.

Are you sure that the clock speed was not 80 all along?

If your iPod was connected to the computer it would stay at 80. Also sometimes the clock speed gets stuck on 80 and speed optimisation isn't used. To rule out this from happening you can reset your iPod by pressing and holding MENU and select for a couple of seconds.

I have personally checked two 2G minis that both have the problem.

Eventually Apple will release new iPod mini software that should fix the problem. My 2G mini came with version 1.3. What version are you running?
[a href="index.php?act=findpost&pid=307383"][{POST_SNAPBACK}][/a]


Hi sehested,

Thanks for the info. You're right... I just encoded the NIN file and loaded it on the ipod. I get an obvious breakup at 10s, again at 19s, and a bit right at the end of the file. By far this is the worst of the batch.

My firmware is also 1.3, fresh out of the box, running on battery, no EQ. I did a reset to double-check and all results are the same.

  • borndevil
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #58
hi... I sent my iPod in service (for this and a wheel problem)
I had it replaced yesterday. this morning I tried new and was orrible discover that same problem was there!! I thought about use of goPod, something wrong in these bytes that changes (w/no chance to take it back)...
now I discover this thread and wooo that's enough for me as I was thinking about a ipod window-falling..

yes, that's a bad thing, iTunes encoder even with best setting doesn't sound as lame 3.90, so I think it's better place the EQ in some likely setting and we'll see.

sehested: thank you, you saved my new pod from burning in deep flames...

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #59
Quote
sehested: thank you, you saved my new pod from burning in deep flames...
[a href="index.php?act=findpost&pid=308783"][{POST_SNAPBACK}][/a]
You're welcome

  • borndevil
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #60
some reported EVERY sample I sent (mine too... and yours) are PERFECT on iPOD Mini 2G... you know what means...

...is changed something... chip... some component... some internal algorithm...
ours are really "different"... I think about some cost-reduction or other contracts with suppliers and different chips.

italian forum is alerted now.
whe must stay united because something is changed inside.
if it's an update problem well... it will be fast... if not...

  • hyper84
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #61
Here is one more confirmation of the stated problem with the NIN sample.  Played fine in the dock (lame 3.96.1 --preset standard).  When disconnected, however, the mini 2g stuttered badly.

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #62
Apple just released iPod Updater 2005-06-26 with iPod mini software 1.4.

The stuttering issue remains... 

They have known the issue and have yet failed to address it.

Makes you wonder if they are rather content with the fact that LAME has compatibility issues with iPod mini. 

I'm going to let them know once more at the Apple Discussion forum

iPod mini 2G stutters when playing LAME aps
Reply #63
I finally am able to confirm this issue (I tried out those audio files the other night).

Did not try the new iPod update, but it sounds like it did not fix the problem
iTunes 10 - Mac OS X 10.6
256kbps AAC VBR
iPhone 4 32GB

  • borndevil
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #64
yes
update didn't fix..............
....
...
..
.

  • hyper84
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #65
Hey i have great news!  More bad samples!  Green Day - Brain Stew and Jimi Hendrix - Wild Thing (off the Voodoo Child collection).  Brain Stew stutters at the beginning and Wild Thing stutters at 4:44 into the song.  I guess it's well confirmed by now though, but you may have wanted to know...  Has anyone had problems with vbr aac similar to the ones with lame?  I am going to run these samples with nero's vbr aac transparency setting to see if they still stutter.  I'll report back soon.

  • Jojo
  • [*][*][*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #66
the problem doesn't occur if the EQ is on, right?!
--alt-presets are there for a reason! These other switches DO NOT work better than it, trust me on this.
LAME + Joint Stereo doesn't destroy 'Stereo'

iPod mini 2G stutters when playing LAME aps
Reply #67
Quote
Apple just released iPod Updater 2005-06-26 with iPod mini software 1.4.

The stuttering issue remains... 

They have known the issue and have yet failed to address it.

Makes you wonder if they are rather content with the fact that LAME has compatibility issues with iPod mini. 

I'm going to let them know once more at the Apple Discussion forum
[a href="index.php?act=findpost&pid=309537"][{POST_SNAPBACK}][/a]


Arrrg.... was really hoping this problem would be "cured" today but this is not surprising. Well, I guess that will give us more time to file bug reports before the next update. 

sehested,
Do you know what causes the clock speed to sometimes get stuck on 80? I noticed my battery level declining faster than it should the past few days, and when the problematic LAME aps files played perfectly I realized that clock speed optimization was off. Not sure how this happened.

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #68
Quote
the problem doesn't occur if the EQ is on, right?!
[a href="index.php?act=findpost&pid=309621"][{POST_SNAPBACK}][/a]

Right. 

But, I personally prefer the flat EQ and to choose another EQ setting will fail to reproduce the sound as I want to hear it.

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #69
Quote
sehested,
Do you know what causes the clock speed to sometimes get stuck on 80? I noticed my battery level declining faster than it should the past few days, and when the problematic LAME aps files played perfectly I realized that clock speed optimization was off. Not sure how this happened.
Happens for me too occassionally, but I still haven't figured out what causes it.

  • hyper84
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #70
nero vbr aac seems to be fine with the problematic songs.

  • grug
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #71
I installed iPod Linux on my 4G iPod and it handles every --aps I threw at it without any pops or clicks or stutters at all. I can't wait until it matures a little more.

And as of tonight iPod Linux works on 2nd gen Minis.

  • hyper84
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #72
Quote
I installed iPod Linux on my 4G iPod and it handles every --aps I threw at it without any pops or clicks or stutters at all. I can't wait until it matures a little more.

And as of tonight iPod Linux works on 2nd gen Minis.
[a href="index.php?act=findpost&pid=309770"][{POST_SNAPBACK}][/a]

I don't know, but I'm sure that when running ipod Linux the clock speed on the ipod runs higher, so no you wouldn't have this problem.  But it does play flac

  • earphiler
  • [*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #73
I wonder if the "new" 20gb 'color' ipods have the skipping problem, and how about your ipod photo 1g 60gb you have? did u try updating that and see if the problem was still there ? thx

  • Fuchal
  • [*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #74
I have a 40GB 4th gen iPod and I have yet to run into any problem files.