Skip to main content

Topic: iPod mini 2G stutters when playing LAME aps (Read 124839 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
iPod nano/mini 2G use clock speed optimisation to increase battery time.
VBR songs with a sudden increase in bitrate may cause the iPod nano/mini 2G to stutter as the clock speed is not increased fast enough to deal with the increased bitrate.

This has so far been observed for songs encoded with LAME --preset standard and is only true when not using the equaliser.

Examples of songs that stutters can be found here:
David Bowie - Five Years
Nine Inch Nails - Right Where it Belongs

For Five Years the clock speed hovers around 24 jumping to 30 when the stuttering begins. Using the equaliser the clock speed hovers around 36 throughout the song and no stuttering occurs.

Further observations:
- this problem is related to the iPod nano/mini 2G but one sample has been found that makes the 4G Color iPod stutter
- problem with iPod mini software 1.3, 1.4, and 1.4.1
- problem with iPod nano software 1.0, and 1.1
- iPod mini 2G do not use optimisation when connected to a computer
- iPod mini 2G do use optimisation, both when using its battery and when connected to a powered dock that is not connected to a computer
- problem go away when using an EQ setting different from flat/off
- only safe EQ setting to use is Bass Reducer / Treble Reducer in order to avoid distortion of songs with a high recording level
- problem do not occur when using iTunes MP3 encoder
- problem do not occur when LAME VBR song do not contain 320 kbps: options --preset standard -B 256
- problem do not always occur at the same spot in the subtle songs listed below
- iPod mini 1G clock speed for Five Years hoovers aroung 31 rising to 33 where it was 24 / 30 for the 2G
- iPod mini optimisation may be turned off (I don't now how to provoke this) and require a reset of the iPod to turn it back on.
- for the 4G color iPod only the sample with NIN - Right Where it Belongs stutters, even with the EQ set to Bass Reducer. Acoustic EQ setting makes the problem go away.

Songs having the problem (obvious):
- Johnny Cash - A Satisfied Mind
- David Bowie - Five Years
- Nine Inch Nails - Right Where it Belongs
- Cake - Nugget @ 26s

Songs having the problem (subtle):
- Eminem - Drug Ballad
- Eminem - Kill You
- U2 - Miracle Drug
- Musica XM - AWS Hope Xm cut

Album songs not having the problem:
- Pink Floyd - Dark Side of the Moon
- Styx - Pieces of Eight
- Guns N' Roses - Illusions I
- Shirley Bassey - Greatest Hits/This is my Life

[span style='font-size:8pt;line-height:100%']Edited: Updated list of songs and albums.
Edited: iPod mini 1G do use speed optimisation. My iPod mini 1G was stuck at a clock speed of 80 and required a reset forcing it to use speed optimisation.
Edited: One user with iPod mini 2G was unable to reproduce problem.
Edited: Work around described
Edited: Added NIN
Edited: Added Cake
Edited: Updated for iPod mini software 1.4
Edited: Added Johnny Cash and updated observations
Edited: Added information about 4G color iPod stuttering
Edited: iPod nano stutters as bad as iPod mini 2G
Edited: Updated for iPod mini software 1.4.1 / iPod nano software 1.1
[/span]
  • Last Edit: 24 February, 2006, 01:40:12 AM by sehested

iPod mini 2G stutters when playing LAME aps
Reply #1
Wow... that's kind of a big bug.

Should be reasonably easy for Apple to fix with a firmware update though.

I've got a 1G iPod mini, and no problems at all for me...

  • Busemann
  • [*][*][*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #2
All new iPods use variable clock speed, but there were some speculation that the mini uses the brand new ARM chip that haven't officially gone into mass production yet. But yeah, it should be easy to fix if they are aware of it.

  • earphiler
  • [*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #3
all my VBR tracks play fine on my (technically 2G) 30GB ipod photo... except some on Nine Inch Nails - With Teeth. the 192k worked flawlessly, but the VBR rip stutters every once in a while. I thought maybe it was an Xfering problem, but I re-upped it several times and the problem still persisted. . . interesting . and it was encoded with lame 3.90.3



that , and the original mp3s are flawless -- no skips on 'puter playback
  • Last Edit: 23 April, 2005, 10:10:47 AM by earphiler

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #4
Quote
All new iPods use variable clock speed, but there were some speculation that the mini uses the brand new ARM chip that haven't officially gone into mass production yet. But yeah, it should be easy to fix if they are aware of it.
[a href="index.php?act=findpost&pid=292873"][{POST_SNAPBACK}][/a]

I have provided feedback to Apple and posted it on iPodLounge, so eventually I hope Apple will become aware of the problem and fix it.

How much of a problem it is is not yet clear as so far only LAME aps have been tested.

It might be that I have just scratched the surface and the problem turns bigger when investigated.

Anyway it is clearly a trade-off between battery time and minimising the risk for stuttering. In the current marketing war it might be that Apple will prioritise outstanding battery performance over occasional stuttering of a few songs, as long as the songs are not in AAC.

  • Busemann
  • [*][*][*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #5
Have you checked if you can reproduce with VBR files encoded with iTunes?

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #6
Quote
Have you checked if you can reproduce with VBR files encoded with iTunes?
[a href="index.php?act=findpost&pid=292904"][{POST_SNAPBACK}][/a]

No. Anyway lame aps is the dominant format also used by several download services.

If I where to use an iTunes specific format I would chose AAC.

However I have checked ALAC, which is also a VBR format, and there was no stuttering.

My priority now will be to listen to music in lame aps to identify the magnitude of the problem.

  • Busemann
  • [*][*][*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #7
Quote
No. Anyway lame aps is the dominant format also used by several download services.


Yea, but if it happens with their own encoder as well, it would probably get a higher priority.

  • Jojo
  • [*][*][*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #8
Quote
Further observations:
- iPod mini 1G do not use optimisation and clock speed is always 80 when playing
[a href="index.php?act=findpost&pid=292861"][{POST_SNAPBACK}][/a]

that's wrong. I own an 1G iPod mini and the clock speed jumps up and down as well while playing. If you start to listen or skip a song it will jump to 80 for a few seconds.

Anyway, couldn't you just prepare a sample...let's say digital silence followed by some part that will make LAME to use 320kbps? Maybe --preset extreme could help to create such a scenario...
--alt-presets are there for a reason! These other switches DO NOT work better than it, trust me on this.
LAME + Joint Stereo doesn't destroy 'Stereo'

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #9
Quote
I own an 1G iPod mini and the clock speed jumps up and down as well while playing. If you start to listen or skip a song it will jump to 80 for a few seconds.
That's interesting. I would have expected the same, but the iPod mini 1G I tested did not change from 80 on the sample provided. Software version was 1.3.
Quote
Anyway, couldn't you just prepare a sample...let's say digital silence followed by some part that will make LAME to use 320kbps? Maybe --preset extreme could help to create such a scenario...
[a href="index.php?act=findpost&pid=292948"][{POST_SNAPBACK}][/a]
What would the point be? I already provided a sample that demonstrates the problem.

  • jrkagan
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #10
I have a 4G 20GB iPod and I'm pretty sure its processors change speed dynamically during playback (see this article), but I've never once encountered a stutter in the 5 months I've owned it.  Almost all of my 1,500+ song library is encoded in LAME -preset-extreme via EAC.
  • Last Edit: 23 April, 2005, 07:11:03 PM by jrkagan
Josh Kagan @ The Southwestern University School of Law
Los Angeles, CA

www.JoshKagan.com

  • Jojo
  • [*][*][*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #11
Quote
Quote
I own an 1G iPod mini and the clock speed jumps up and down as well while playing. If you start to listen or skip a song it will jump to 80 for a few seconds.
That's interesting. I would have expected the same, but the iPod mini 1G I tested did not change from 80 on the sample provided. Software version was 1.3.
[a href="index.php?act=findpost&pid=292958"][{POST_SNAPBACK}][/a]

try to reset your iPod using the ipod_updater software...or you could also (un)-cap your iPod...this makes the iPod loading the defaults, which should fix the problem. I sometimes have that problem too - and I'm using the latest firmware as well. I usally notice it when my battery is already drained after 4 hours...
--alt-presets are there for a reason! These other switches DO NOT work better than it, trust me on this.
LAME + Joint Stereo doesn't destroy 'Stereo'

  • Jojo
  • [*][*][*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #12
Quote
I have a 4G 20GB iPod and I'm pretty sure its processors change speed dynamically during playback (see this article), but I've never once encountered a stutter in the 5 months I've owned it.  Almost all of my 1,500+ song library is encoded in LAME -preset-extreme via EAC.
[a href="index.php?act=findpost&pid=292965"][{POST_SNAPBACK}][/a]

nope your iPod should do fine as well as the 1G iPod mini (even though they both shift clock speeds). There seems to be a problem with the new chips Apple uses for their recent models that need less CPU power and therefore result a longer playback time...as far as I know only 2G iPod mini and 2G iPod Photo use these new chips...
--alt-presets are there for a reason! These other switches DO NOT work better than it, trust me on this.
LAME + Joint Stereo doesn't destroy 'Stereo'

  • MoSXS
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #13
My 2G 4GB mini is filled with --aps MP3s (ripped using EAC's secure mode) and I haven't had any problems with stuttering. I listen to all kinds of different music too. I have everything from Alicia Keys to Fear Factory on my iPod, so theres a variety of complexity and types of music. Not a single song has skipped or stuttered.

I downloaded the sample posted in the other thread. So far I've listened to it about 6 times and it's played flawlessly every time. I sent it over to my friend with a 6GB 2G mini and hes had no problems with it either.

I hate to say this, but I think it's just a problem with the original poster's iPod. So far I've seen 2 iPods play it correctly that, according to the original poster, should have stuttered at least once.

  • Lucas
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #14
my 2G ipod mini skips with 192k cbr songs too.. very randomly also.. so I don't think it's just the bitrate.. some frames might be harder to decode than others even if they're the same size, right? if not, I don't get it.

Where do you check the clock speed?

edited: typo
  • Last Edit: 23 April, 2005, 07:52:33 PM by Lucas

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #15
Quote
My 2G 4GB mini is filled with --aps MP3s (ripped using EAC's secure mode) and I haven't had any problems with stuttering. I listen to all kinds of different music too. I have everything from Alicia Keys to Fear Factory on my iPod, so theres a variety of complexity and types of music. Not a single song has skipped or stuttered.
Most songs seems not to be affected by this problem. I'm updating the original post as I found new examples.

Quote
I downloaded the sample posted in the other thread. So far I've listened to it about 6 times and it's played flawlessly every time. I sent it over to my friend with a 6GB 2G mini and hes had no problems with it either.

I hate to say this, but I think it's just a problem with the original poster's iPod. So far I've seen 2 iPods play it correctly that, according to the original poster, should have stuttered at least once.
[{POST_SNAPBACK}][/a]

It's not just one iPod mini 2G that has the problem: [a href="http://forums.ipodlounge.com/showthread.php?s=&threadid=93057]HelloWhat[/url]

Are you sure clock speed optimisation was in use when you played back the sample?

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #16
Quote
my 2G ipod mini skips with 192k cbr songs too.. very randomly also.. so I don't think it's just the bitrate.. some frames might be harder to decode than others even if they're the same size, right? if not, I don't get it.
Quote
Could you please provide a sample of a CBR song that skips?
Where do you check the clock speed?
[{POST_SNAPBACK}][/a]
To view the clock speed of an iPod (Windows version) do the following:
Connect iPod to your computer
Launch Windows Explorer
Change folder settings to show hidden files and folders. Also don't hide file type of known files
Create an empty file named "_show_speed" in iPods iPod_Control\Device folder
[a href="http://www.hydrogenaudio.org/forums/index.php?showtopic=33486&view=findpost&p=293010]Picture of Windows Explorer displaying show speed configuration[/url]
Disconnect the iPod
Set Date & Time setting "Time in title" to On


[span style='font-size:8pt;line-height:100%']Side Note: Is there a simple way to place pictures in posts, when you don't have your own web server?[/span]
  • Last Edit: 24 April, 2005, 04:43:15 AM by sehested

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #17
Quote
try to reset your iPod using the ipod_updater software...or you could also (un)-cap your iPod...this makes the iPod loading the defaults, which should fix the problem. I sometimes have that problem too - and I'm using the latest firmware as well. I usally notice it when my battery is already drained after 4 hours...
[a href="index.php?act=findpost&pid=292967"][{POST_SNAPBACK}][/a]

Thanks for the advice. 

After launching iPod Updater and reseting the iPod speed optimisation came into effect. 

I have updated my original post to reflect this new information.

  • Lucas
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #18
I spoke too fast.. I transfered one of the (many) songs that skip on my iPod, checked it with winamp, and it was a VBR file.. it was encoded my me, so it could only be -aps. I thought these tracks were from another much older 'batch' I encoded at 192k cbr.. seems I was wrong

The point is I just checked again and it skips. Thanks for that _show_speed thing, very useful  when playing these files the cpu varies from 27 to 30.

  • Lucas
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #19
I've found a part of a song that causes my iPod to skip. Always does it, it isn't random. I've uploaded it here:

http://www.hydrogenaudio.org/forums/index....71&#entry293071

  • MoSXS
  • [*]
iPod mini 2G stutters when playing LAME aps
Reply #20
Quote
Quote
My 2G 4GB mini is filled with --aps MP3s (ripped using EAC's secure mode) and I haven't had any problems with stuttering. I listen to all kinds of different music too. I have everything from Alicia Keys to Fear Factory on my iPod, so theres a variety of complexity and types of music. Not a single song has skipped or stuttered.
Most songs seems not to be affected by this problem. I'm updating the original post as I found new examples.

Quote
I downloaded the sample posted in the other thread. So far I've listened to it about 6 times and it's played flawlessly every time. I sent it over to my friend with a 6GB 2G mini and hes had no problems with it either.

I hate to say this, but I think it's just a problem with the original poster's iPod. So far I've seen 2 iPods play it correctly that, according to the original poster, should have stuttered at least once.
[{POST_SNAPBACK}][/a]

It's not just one iPod mini 2G that has the problem: [a href="http://forums.ipodlounge.com/showthread.php?s=&threadid=93057]HelloWhat[/url]

Are you sure clock speed optimisation was in use when you played back the sample?
[a href="index.php?act=findpost&pid=293007"][{POST_SNAPBACK}][/a]


Clock speed optimisation was on. Infact, I even reset it just to make sure. I've been listening to both songs posted in the other thread for about the last 10 minutes or so. Constant repeat. No stuttering whatsoever.

The clockspeed generally hung around 22-28MHz for both songs. Strangely enough, I tried a 128kbps AAC song, and the clockspeed is higher at around 28-30MHz. hmm.

Anyway, no stuttering for me.

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #21
Quote
Clock speed optimisation was on. Infact, I even reset it just to make sure. I've been listening to both songs posted in the other thread for about the last 10 minutes or so. Constant repeat. No stuttering whatsoever.
So not all 2G mini's will stutter. I will update my original post to this new information.
Quote
The clockspeed generally hung around 22-28MHz for both songs. Strangely enough, I tried a 128kbps AAC song, and the clockspeed is higher at around 28-30MHz. hmm.
It is commonly known that AAC use more juice than MP3 to decode:
MP3 or AAC for iPod Battery Life

  • earphiler
  • [*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #22
i was listening to ipod photo last nite, and it skipped on a weezer song. i replayed it , and it skipped exactly where i thought it did before. and it was a flawless rip -- again, no skips on 'puter playback. this must be fiXed!

  • sehested
  • [*][*][*][*]
  • Members (Donating)
iPod mini 2G stutters when playing LAME aps
Reply #23
Quote
i was listening to ipod photo last nite, and it skipped on a weezer song. i replayed it , and it skipped exactly where i thought it did before. and it was a flawless rip -- again, no skips on 'puter playback. this must be fiXed!
[{POST_SNAPBACK}][/a]

Please provide direct [a href="http://www.apple.com/feedback/ipod.html]feedback[/url] to Apple. The more complaints, the higher priority they will give the issue.

  • MugFunky
  • [*][*][*][*]
iPod mini 2G stutters when playing LAME aps
Reply #24
this sounds to me like a simple buffering problem - like what you'd get with winamp running on a pentium 100 while something else was running (hehhe... oldskoo).  if you increase the buffering, the file played back smoothly.

i wonder if that's controllable on the pod?  i don't own one and probably never will (they're too fashionable for a geek like me to have in good conscience ) unless apple implement gapless playback and perhaps PCM recording to give a use to those big hard disks they have.