Skip to main content

Topic: Fb2k pegs cpu after playing streams (Read 1615 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • macroexp
  • [*]
Fb2k pegs cpu after playing streams
Just in the last couple of days, foobar has started going crazy. I listen to SomaFM Groove Salad (I guess I listen to it a lot).

But after a few hours of playing, and this has happened twice now, it stops playing and the cpu goes to 100%. And it's a *hard* 100%, like it took about 10 minutes for the task manager to load up so I could even see it was fb2k causing the trouble.

This is on a 3.2ghz P4 (HT disabled, though I just enabled it now for giggles) running WinXP pro. I've been using fb2k for a long time now and I really don't want to go back to Winamp! But when it freezes up like that it takes a good chunk of time to recover the machine (without just hard-powering it down anyways) and that's something I just can't take!

Anybody else seen this kind of behavior? It put up the errors box and said something about mp3 stream corrupted, skipping to next playlist entry, then the same thing again for the next feed. I suppose it could be the fault of the stream, but I tell ya fb2k shouldn't freak out and kill the machine like that in any case!

Thanks all

Mike

  • macroexp
  • [*]
Fb2k pegs cpu after playing streams
Reply #1
Ok I found this other thread, seems like it is a known bug.

http://www.hydrogenaudio.org/forums/index....1048&hl=cpu+100



Quote
Just in the last couple of days, foobar has started going crazy. I listen to SomaFM Groove Salad (I guess I listen to it a lot).

But after a few hours of playing, and this has happened twice now, it stops playing and the cpu goes to 100%. And it's a *hard* 100%, like it took about 10 minutes for the task manager to load up so I could even see it was fb2k causing the trouble.

This is on a 3.2ghz P4 (HT disabled, though I just enabled it now for giggles) running WinXP pro. I've been using fb2k for a long time now and I really don't want to go back to Winamp! But when it freezes up like that it takes a good chunk of time to recover the machine (without just hard-powering it down anyways) and that's something I just can't take!

Anybody else seen this kind of behavior? It put up the errors box and said something about mp3 stream corrupted, skipping to next playlist entry, then the same thing again for the next feed. I suppose it could be the fault of the stream, but I tell ya fb2k shouldn't freak out and kill the machine like that in any case!

Thanks all

Mike
[a href="index.php?act=findpost&pid=282785"][{POST_SNAPBACK}][/a]