Skip to main content

Topic: foo_rmx beta (Read 64567 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • darkain
  • [*][*]
foo_rmx beta
Reply #100
Quote
But, I do have a request to make, the Play button, can you do it to a Play/Pause, so when you press play when a track is playing it will pause, so you dont need one play button and one pause button. I hope you understand what I mean.
[a href="index.php?act=findpost&pid=362601"][{POST_SNAPBACK}][/a]

Check the list of selectable functions, there should be "Play", "Play/Pause", and "Pause" in the list.  Just assign your remote button to "Play/Pause" and it should work.
-=- Darkain Dragoon -=-

  • optimuz
  • [*][*]
foo_rmx beta
Reply #101
Quote
Quote
But, I do have a request to make, the Play button, can you do it to a Play/Pause, so when you press play when a track is playing it will pause, so you dont need one play button and one pause button. I hope you understand what I mean.
[a href="index.php?act=findpost&pid=362601"][{POST_SNAPBACK}][/a]

Check the list of selectable functions, there should be "Play", "Play/Pause", and "Pause" in the list.  Just assign your remote button to "Play/Pause" and it should work.
[a href="index.php?act=findpost&pid=362647"][{POST_SNAPBACK}][/a]


For me, there is none, I've downloaded the latest RC3 from your webpage... I've only choosed to install Intelliremote, unmarked all other options, is it because of that? 

  • darkain
  • [*][*]
foo_rmx beta
Reply #102
Quote
For me, there is none, I've downloaded the latest RC3 from your webpage... I've only choosed to install Intelliremote, unmarked all other options, is it because of that? 
[a href="index.php?act=findpost&pid=362667"][{POST_SNAPBACK}][/a]

hmm, check again, it should be there.  also, verify that you are running the currect version of RM-X while it is running.  (it will say at the bottom of the configuration window)
-=- Darkain Dragoon -=-

  • darkain
  • [*][*]
foo_rmx beta
Reply #103
Quote
Quote
[a href="index.php?act=findpost&pid=361961"][{POST_SNAPBACK}][/a]

well, i fixed up a different bug in some code the console depends on, and ever since then, i havnt been able to reproduce the console task bar bug.  lets hope its gone for good!!

still need to add the param stuff to volume tho, but this is gonna take a day or three, as i dont want to half-ass it.  i want it to be standardized across all versions of RM-X.  so, while you might be used to -db for volume, it will still be represented as 0-100% in RM-X.
[a href="index.php?act=findpost&pid=362394"][{POST_SNAPBACK}][/a]



ok, while messing around w/ some other stuff tonight, the console bug came back.  oh noes!  well, this time, it was consistant when it would or wouldnt appear.  so, i spent a good hour or so trying to track down "why" it was occuring.  the thing only happens with foobar, and nothing else.  i almost gve up, then decided to browse around the MSDN a bit, and i gave something a try, and it seems to have worked now.
-=- Darkain Dragoon -=-

  • optimuz
  • [*][*]
foo_rmx beta
Reply #104
I seem to have 1.0 20050101 

But as I said, I've downloaded the latest installer from your website and installed it. So it is kinda strange that it says 1.0!


*edit*

Stupid me saw that I had downloaded 1.0 from your site and not 1.2 RC3   
But now I have downloaded it and everything works just fine now, thank you again for an AWESOME plugin! 
  • Last Edit: 07 February, 2006, 10:22:16 PM by optimuz

  • darkain
  • [*][*]
foo_rmx beta
Reply #105
RM-X Wiki now has the final build of RM-X v1.2.  Much newnes and loving to be had!
-=- Darkain Dragoon -=-

  • optimuz
  • [*][*]
foo_rmx beta
Reply #106
TY YOU ARE TEH SHIT darkain!!!

I've switched to 0.9 now, hope you will make rm-x work with 0.9 soon?
  • Last Edit: 23 February, 2006, 07:41:44 PM by optimuz

  • darkain
  • [*][*]
foo_rmx beta
Reply #107
Quote
TY YOU ARE TEH SHIT darkain!!!

I've switched to 0.9 now, hope you will make rm-x work with 0.9 soon?
[a href="index.php?act=findpost&pid=365705"][{POST_SNAPBACK}][/a]


as soon as i get teh SDK, its more or less done. 
-=- Darkain Dragoon -=-

  • optimuz
  • [*][*]
foo_rmx beta
Reply #108
Yeah I know that you don't have access to the SDK  But I mean, as soon as you get it I hope you can fix a version for 0.9 too!

  • leafo
  • [*]
foo_rmx beta
Reply #109
SDK is out!
http://www.foobar2000.org/SDK.zip

Please port this over to 0.9 as soon as you can, this is probably one of my most favorite plugins!

I love using my gamepad as a remote, and even my nintendo ds.

  • 4nt1
  • [*][*][*][*]
foo_rmx beta
Reply #110
Quote
SDK is out!
http://www.foobar2000.org/SDK.zip

Please port this over to 0.9 as soon as you can, this is probably one of my most favorite plugins!

I love using my gamepad as a remote, and even my nintendo ds.
[a href="index.php?act=findpost&pid=372788"][{POST_SNAPBACK}][/a]



I second that...

Can't wait to get my audigy 2 remote working

W00t W00t media centre here we come

  • darkain
  • [*][*]
foo_rmx beta
Reply #111
yes, i know the SDK is out.  the SDK also REQUIRES Visual Studio 2005... which means either no port, or i am forced to migrate my entire codebase over to Visual Studio 2005.  so basically, in other words, dont expect anything from me anytime soon.
-=- Darkain Dragoon -=-

  • Duble0Syx
  • [*][*][*][*]
foo_rmx beta
Reply #112
Quote
yes, i know the SDK is out.  the SDK also REQUIRES Visual Studio 2005... which means either no port, or i am forced to migrate my entire codebase over to Visual Studio 2005.  so basically, in other words, dont expect anything from me anytime soon.
[a href="index.php?act=findpost&pid=372816"][{POST_SNAPBACK}][/a]

Thats a real shame.  Although after using foobar v0.9 I don't see much that makes continuing to use v0.8.3 painful in any way.  0.9 does seem a bit faster and has a few nice feature.  Hope that sooner or later this gets ported.  I won't switch until RMX, albumart & the trackinfo panel are working.

  • Seldaek
  • [*][*][*]
foo_rmx beta
Reply #113
You can manage to control foobar without this plugin by using a combination of Girder & shortcuts in foobar (they don't have to be global if you target foobar's window in Girder).

  • Duble0Syx
  • [*][*][*][*]
foo_rmx beta
Reply #114
Quote
You can manage to control foobar without this plugin by using a combination of Girder & shortcuts in foobar (they don't have to be global if you target foobar's window in Girder).
[a href="index.php?act=findpost&pid=375308"][{POST_SNAPBACK}][/a]

The advantage of RMX was that foobar could be minimized and the screensaver could be active.  Changing tracks wouldn't effect any of this.  If that option would work the same way then it would be feasible.
  • Last Edit: 26 March, 2006, 02:06:14 AM by Duble0Syx

  • Seldaek
  • [*][*][*]
foo_rmx beta
Reply #115
Well I just tried that with Girder. You have two options:
- Set the key to global in foobar and then it works even in the tray, it will then wake up the computer but you can restore the screensaver at the same time, not perfect.
- Send a command to foobar window with WParam & LParam set (you can capture them through Girder), then it doesn't wake up the computer but doesn't work if foobar is in the tray, so it's not perfect either. Although I may not be aware of all the possibilities of Girder which is quite complex so that may still be possible.

  • darkain
  • [*][*]
foo_rmx beta
Reply #116
it seems to be a very common arguement for people to just use another app for their "remotes", and therefor "rm-x isnt needed".  but if we kept up w/ this mentatlity, we would all still be using MIDI files played on our sound-blaster 16's, right?  RM-X does a hell of a lot more then just give a few remotes access to a media player.  it is an entirely dynamic programming API + scripting envoirnment with features only limited by ones imagination.

ok, enough about that rant, back to whats important.  "RM-X Media Edition" is a very special and specific build of the RM-X Core.  Media Edition relies on a single code base with multiple entry points to support multiple media players with a single binary (this is why there is only 1 installer for all of Media Edition for all players). 

with foobar2000 now requiring components to be built in Visual Studio 8 and forcing them to be Unicode (instead of ANSI), this leaves me with only three possible options.

1) rebuild all of RM-X Core from the ground up in VS8 w/ unicode support and hope and pray that I can get this to work with the four other active media players (as well as the three or more other media players i'm adding support for on the side)

2) fork the RM-X Media Edition tree between foobar2000 vs all other media players.

3) abandon foobar2000 support completely.


problems:

1) The RM-X Core is used in more then just RM-X Media Edition.  I have several projects that use it now.  Forcing VS8 + Unicode would mean abandoning Windows 9x/ME support completely, and possibly hurting Windows NT4 support.  While this may not bother the majority of users out there, one of the build of RM-X is designed to run on legacy hardware/software to have a very cheaply built home-automation system.

2) For a fork, the entire RM-X Core and vBase SDK would need to be forked, not just the media player interaction.  This would mean I would have to actively manage twice as much code for every single update.  Plus going this route, there would no longer be that guarantee that all of the RM-X plugins would work in both the normal build of RM-X as well as in the foobar2000 specific build.

3) not supporting foobar2000 would be the easist course of action for me, however, i dont want to lose support for this player after all of the work i have already put into it.


I think the biggest issue right now is that RM-X has grown too large and is out of hand now.  There are currently (i think) 8 media player plugins/components in R&D, and about 30 RM-X plugins in the active development tree. This doesnt count the work being done on RM-X Stand-Alone, the IPC, and networking tools in development.

Both time and money are extremely limited for me right now, so its been a struggle for prioritizing what does or doesnt get worked on.  If I do get around to getting an updated version of RM-X for foobar2000, I have no idea when I would even begin such a project. 
-=- Darkain Dragoon -=-

  • optimuz
  • [*][*]
foo_rmx beta
Reply #117
This means I'm going back to 0.8.3 because this plugin is the most important out there!

Too bad, I really liked 0.9 until now

  • david_dl
  • [*][*][*][*][*]
foo_rmx beta
Reply #118
VS8 can build ANSI apps fine. The only difference is it uses unicode *by default*, ie. you actually have to select ANSI if you want it. If it is too hard to use VS8, would it not be possible to build a 'proxy plugin' for foobar, using VS8, which loads the rmx functionality from another module? IMHO this would be a good way to go especially when multiple media players are involved, they could all share the same RMX core modules, new versions of the media player plugins would not be needed unless you wanted to add new features dependant on that particular media player's api.

  • Duble0Syx
  • [*][*][*][*]
foo_rmx beta
Reply #119
Quote
VS8 can build ANSI apps fine. The only difference is it uses unicode *by default*, ie. you actually have to select ANSI if you want it. If it is too hard to use VS8, would it not be possible to build a 'proxy plugin' for foobar, using VS8, which loads the rmx functionality from another module? IMHO this would be a good way to go especially when multiple media players are involved, they could all share the same RMX core modules, new versions of the media player plugins would not be needed unless you wanted to add new features dependant on that particular media player's api.
[a href="index.php?act=findpost&pid=378866"][{POST_SNAPBACK}][/a]

I'm no programmer, but that sounds pretty good.  I can't switch to 0.9 without my remote functioning properly.  If it won't work, couldn't someone write a similar component just for foobar?  I'd imagine the hardest part would be adding support for different remotes.

  • Seldaek
  • [*][*][*]
foo_rmx beta
Reply #120
Quote
it seems to be a very common arguement for people to just use another app for their "remotes", and therefor "rm-x isnt needed".  but if we kept up w/ this mentatlity, we would all still be using MIDI files played on our sound-blaster 16's, right?  RM-X does a hell of a lot more then just give a few remotes access to a media player.  it is an entirely dynamic programming API + scripting envoirnment with features only limited by ones imagination.
[a href="index.php?act=findpost&pid=377263"][{POST_SNAPBACK}][/a]

Girder is kinda that too, but don't get me wrong, I'm not trying to say "don't use RM-X", I was just pointing that other solutions exist while they way for a .9 port of RM-X so no-one kills himself because of a missing plugin

  • darkain
  • [*][*]
foo_rmx beta
Reply #121
OKAY!!  Time for some beta testing RM-X on Foobar 0.9.

For now, there is no installer for the beta, so you have to do a few steps to get it to work.

Step 1:
Download and install the old RM-X for foobar 0.8 from this URL: http://www.darkain.com/Download/index.php?download_id=15

Step 2:
Replace foobar2000\components\foo_RMX.dll with the one contained at the following URL: http://www.darkain.com/Download/foo_RMX.dll

Step 3:
ENJOY! 
-=- Darkain Dragoon -=-

  • marc2003
  • [*][*][*][*][*]
foo_rmx beta
Reply #122
are there any pre-requisites for this to work? do i need to install any creative software for my rm1000? (shudders)
  • Last Edit: 20 September, 2006, 05:58:45 PM by marc2003

  • darkain
  • [*][*]
foo_rmx beta
Reply #123
are there any pre-requisites for this to work? do i need to install any creative software for my rm1000? (shudders)



RM-X does all device detection on start-up, so it doesn't matter what order things are installed in.

as for the RM-1000 specifically, if its an external reciever (such as the Extigy), you will need creative's software installed and use the Remote Center plugin.  (make sure this plugin gets installed when installing RM-X).  If its an internal reciever (such as SB-Live Platinum), then you can use the IntelliRemote plugin.
-=- Darkain Dragoon -=-

  • marc2003
  • [*][*][*][*][*]
foo_rmx beta
Reply #124

are there any pre-requisites for this to work? do i need to install any creative software for my rm1000? (shudders)



RM-X does all device detection on start-up, so it doesn't matter what order things are installed in.

as for the RM-1000 specifically, if its an external reciever (such as the Extigy), you will need creative's software installed and use the Remote Center plugin.  (make sure this plugin gets installed when installing RM-X).  If its an internal reciever (such as SB-Live Platinum), then you can use the IntelliRemote plugin.


ah ok. i have an external box for my platinum ex. guess i need the creative software.......   

thanks for the quick reply.