Skip to main content

Topic: Will language plugin support ever come? (Read 55805 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • kalmark
  • [*][*][*][*][*]
Will language plugin support ever come?
Reply #25
One big problem of translation is the inconsistent string length.

The layout of the  preferences page (of each plugin) is usually tuned to the length of the English phrase.

Well, somehow they manage to make complete operating systems in a wide variety of languages... And even smaller programs, like the IM client Gaim for instance, come (more or less) fully localised, so this problem can definitely be solved.... somehow
Life is Real...
(But not in audio :) )

  • Peter
  • [*][*][*][*][*]
  • Administrator
Will language plugin support ever come?
Reply #26
To start with, foobar2000 was never meant to be usable for everyone.
We simply don't care whether specific userbase finds it useful or not. We would probably care if we earned money from it, but we don't, and don't plan to as it would ruin too many good aspects of the project.
There's plenty of other players around, I don't see why people who don't understand our UI as-is have to use foobar2000. I guess it's a problem for some fanboys who want to convert everyone in the world to use foobar2000, but that doesn't mean it's worth our (unpaid) work time to write and then maintain with each new version.

Other than that, I fully agree with Moneo's reply earlier in this thread.

Translation support is not planned.

Again, if you don't like our decisions, you are free (and encouraged) to use one of other players instead.

Topic closed.


2011 addendum
You can now use my other audio player app which - while being much simplified compared to foobar2000 - fully supports localization.
  • Last Edit: 29 November, 2011, 10:25:02 AM by Peter