Skip to main content

Topic: Otachan's in_!mpg123 (Read 186049 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Raptus
  • [*][*]
Otachan's in_!mpg123
Reply #100
Very nice,

in_mpg123 + ASIO output @24bit are working great, gapless.

Am I stupid or is this the only decoder except foobar's that doesn't ignore ReplayGain tags? MAD and in_mp3 do

I installed mp3infp to get file info functionality and it's great, i'm only missing the ability  to show the RG info like the mpc winamp plugin has.

  • fileman
  • [*][*][*]
Otachan's in_!mpg123
Reply #101
My crash on opening file info dialog still happens with version 0.70.

Perhaps it's a winamp bug, because the gen_ff module is being reported when it crashes - but I didn't get a solution or answers in the winamp forum when I posted a bug report.

Did anybody inform the author of this plugin of this thread? Because it really seems to be the only place on the english speaking web where you can find any information about this plugin. Perhaps it would be interesting for the author to participate in this thread? (Then he also could acknoledge the bug I'm suffering  )

Regards, fileman.

  • witt
  • [*][*][*]
Otachan's in_!mpg123
Reply #102
Quote
Am I stupid or is this the only decoder except foobar's that doesn't ignore ReplayGain tags?

MADPlay(v0.15.2b) can use the replaygain info in the LAME tag.
  • Last Edit: 09 June, 2004, 07:33:44 AM by witt
foobar2000 Wiki for Japanese Users
http://foobar.s53.xrea.com/fbwiki/

  • Raptus
  • [*][*]
Otachan's in_!mpg123
Reply #103
Quote
Quote
Am I stupid or is this the only decoder except foobar's that doesn't ignore ReplayGain tags?

MADPlay(v0.15.2b) can use the replaygain info in the LAME tag.

Your right. But MADplay is useless for me. I should've asked explicitely for Winamp decoder plugins.

I supose RG functionality could easily be implemented in in_mad... but anyway, I'm quite happy with in_mpg123 
  • Last Edit: 09 June, 2004, 12:59:06 PM by Raptus

  • TakuSkan
  • [*][*][*][*]
Otachan's in_!mpg123
Reply #104
Quote
Quote
  • Tag editing functions are disabled; T-Matsuo's mp3infp is called externally instead. You need to install mp3infp to edit tags.

You can't use Winamp's default file info view if you use Otachan's in_mpg123.

That works....  great! Thanks
Geopoliticus Child Watching the Birth of the New Man

  • TakuSkan
  • [*][*][*][*]
Otachan's in_!mpg123
Reply #105
Quote
Quote
    T-Matsuo's mp3infp is called externally instead. You need to install mp3infp to edit tags.[/li][/list]


    Now I just wish this, or some other Winamp tag editor plugin would support editing APE tags put into MP3 files for ReplayGain and Lyric values.
    Geopoliticus Child Watching the Birth of the New Man

    • Shandra
    • [*]
    Otachan's in_!mpg123
    Reply #106
    Well... as this one thread (as already said here) seem to be the only (worthwile) en-speaking place to talk about this plugin....

    I used it now for one month and without the external app needed to do the tagging from within WinAmp (I never used WinAmp to modify tags (taged by EAC, RGed by Foo, if needed additional info added with MP3Ext) - still not sure if they finally stoped from adding "0" in empty fields (anyone who remembers the Nullsoft Joke ?) ).... ok, back on topic: I only make it work (the in_mpg123) by removing the regular in_mp3 file from the plugin-directory (only then I actually recognize the Replaygain working, as long as the regular mp3 decoder is in the plugin directory all songs play - well, as if the in_mpg123 isn't activated (though I had checked the "enable" box in its config-dialogue)) - so far, as I understand it, this shouldn't be the case (plain WinAmp5.03 with only Geiss and *123 added).
    Ok, I can live with that - but maybe someone has a hint for me what could be conflicting

    (this experience I made on all of my 4 PCs (Win95B,Win98SE,2KPro&XPHome)+that one of my Girl-friend - so I assume there is something I am doing basically wrong on it)

    Thanks,
    SHAnDRA

    EDIT: Grmpf... blind me.... MP3 extention in in_mp3.... sigh... - sorry!
    • Last Edit: 26 July, 2004, 10:42:57 AM by Shandra

    • amano
    • [*][*][*][*]
    Otachan's in_!mpg123
    Reply #107
    Ver. 1.18y ot71 is out!

    The only change seems that the compiler is updated to Visual C++ Ver. 8.0.40607.16 Beta1.

    • amano
    • [*][*][*][*]
    Otachan's in_!mpg123
    Reply #108
    Ver. 1.18y ot72 is out!

    From what I can guess from babelfish, a streaming problem with some file extensions (?) was fixed.

    EDIT: Thanks Kjoonlee for updating the start post again.
    • Last Edit: 15 August, 2004, 08:57:38 PM by amano

    • WarBird
    • [*][*][*]
    Otachan's in_!mpg123
    Reply #109
    says it fixes a problem where, when streaming, files would recieved a nsa extention

    • amano
    • [*][*][*][*]
    Otachan's in_!mpg123
    Reply #110
    Ver. 1.18y ot73a is out. Get it HERE!.

    Some problem with VBRI tags seems to be solved.
    • Last Edit: 20 September, 2004, 11:02:27 AM by amano

    • Raptus
    • [*][*]
    Otachan's in_!mpg123
    Reply #111
    Bump! 

    Is there any news regarding this project?

    Is in_mpg123 still the only RG-enabled winamp decoder?

    A request to the makers of out_asio: Could you please include documentation in english?
    • Last Edit: 23 September, 2004, 06:25:24 AM by Raptus

    • amano
    • [*][*][*][*]
    Otachan's in_!mpg123
    Reply #112
    Quote
    Bump!  

    Is there any news regarding this project?


    Yes. Ver. 1.18y ot74 is out! Get it Here!
    It seems to correct a problem with the VBR header not being recognized.

    Quote
    Is in_mpg123 still the only RG-enabled winamp decoder?

    AFAIK, yes 

    Quote
    A request to the makers of out_asio: Could you please include documentation in english?
    [a href="index.php?act=findpost&pid=243842"][{POST_SNAPBACK}][/a]


    Rather send an e-mail to him, maybe with a link to this thread. I would wish to be able to edit the tags of a song while I am listening to it in winamp, but this is probably rather a "mp3infp" problem.
    • Last Edit: 26 September, 2004, 07:21:23 PM by amano

    • Enig123
    • [*][*][*]
    Otachan's in_!mpg123
    Reply #113
    I only found ot74 in Otachan's web page.
    http://www3.cypress.ne.jp/otachan/in_mpg123_118ot74.zip



    Edit: sorry for reposting news.
    • Last Edit: 26 September, 2004, 08:59:15 PM by Enig123

    • amano
    • [*][*][*][*]
    Otachan's in_!mpg123
    Reply #114
    Never mind

    Thanks go out to Kjoonlee for still maintaining the thread starting post.

    • man
    • [*][*]
    Otachan's in_!mpg123
    Reply #115
    I'm surprised as well that there are not more people using this.

    It works very well for me, and I find it very usefull (RG support especially). Thanks to the developers  .

    Otachan's in_!mpg123
    Reply #116
    404 with the other URLs, this one should work

    http://www3.cypress.ne.jp/otachan/in_mpg123_118ot74a.zip

    Otachan's in_!mpg123
    Reply #117
    mp3infp Ver.2.47e is out. It now supports ape2 tags on mp3 (in a fashion), and generally starts to look quite useable...
    "ONLY THOSE WHO ATTEMPT THE IMPOSSIBLE WILL ACHIEVE THE ABSURD"
           - Oceania Association of Autonomous Astronauts

    • beagle72
    • [*]
    Otachan's in_!mpg123
    Reply #118
    Quote
    I'm surprised as well that there are not more people using this.

    It works very well for me, and I find it very usefull (RG support especially). Thanks to the developers   .
    [a href="index.php?act=findpost&pid=245081"][{POST_SNAPBACK}][/a]


    I am having a strange problem installing in_mpg123.dll on a second PC. It worked without difficulty on the first PC, with WinAmp 5.03. Exact same WinAmp installed on 2nd PC. I copy the in_mpg123.dll into the plugins folder, but it won't show up in WinAmp's Input filters page. I tried many times. I am using the "normal" compile although I also tried the SSE versions. The 2nd PC is an older Athlon 900 -- could it have anything to do with that?

    thanks,
    beagle

    • k.eight.a
    • [*][*][*][*]
    Otachan's in_!mpg123
    Reply #119
    Hi guys!

    I have a problem and I hope you would help me to solve it.

    I've downloaded mpg123 plugin for WinAmp (I'm still using 2.91) and mp3infp for editing ID3Tags, if I understand well...

    I'm using only ID3v1.0 or 1.1 (no ID3v2.xx) and I have my MP3's adjusted by MP3Gain which means that they have APE (RG) Tag at the end (If I understand it well...).
    The problem is that when I try to play my MP3's through WinAmp with mpg123 plugin and mp3infp for taging, the files at my playlist are losing Tag so for example the song which is normally (with WinAmp's native MP3 decoder) viewed as:

    130. On Thorns I Lay - The Threat of Seduction 5:12

    ...so when WinAmp plays the file it becomes "130  -  5:12", because it reads ID3v2 Tag by default although I have no ID3v2 present or it tries to view APE Tag which is also empty as there's only a ReplayGain value.

    So can anyone suggest me how to use my WinAmp 2.91 with mpg123 decoder to view (and edit) my tags properly (in my point of view)?

    Yes, it's true that I'm pretty new to the decoder related topics but I hope the advice could help to many people including me...

    Thanks in advance!
    Sorry for my poor English, I'm trying to get better... ;)
    "The greatest trick the Devil ever pulled, was convincing the world he didn't exist."

    • Hyperion
    • [*][*][*]
    Otachan's in_!mpg123
    Reply #120
    It's My Life,
    It's Now Or Never,
    I Ain't Gonna Live Forever,
    I Just Want To Live While I'm Alive.

    • TakuSkan
    • [*][*][*][*]
    Otachan's in_!mpg123
    Reply #121
    Quote
    mp3infp Ver.2.47e is out. It now supports ape2 tags on mp3 (in a fashion)...[{POST_SNAPBACK}][/a]

    Terrific!  Glad I just read back through this thread.  I'd been asking about something that could copy data from ID3v2 tags to the APE tags FB2K creates for ReplayGain [a href="http://www.hydrogenaudio.org/forums/index.php?showtopic=28612&view=findpost&p=248011]in a FB2K thread here[/url] from a while back.

    mp3infp doesn't do mass tagging though, does it?  It'd nice to be able to copy over a ID3v2 tags from MP3s for an entire album to corresponding APE tags after FB2K has set RG values.  Sometimes I like making custom ID3v1 tags for my portable MP3 player, and if I use FB2K's masstagger to create tags based on file names to get around ID3v1's limitation of 30 characters, FB2K will write over the custom ID3v1 tags I've created at the same time.
    Geopoliticus Child Watching the Birth of the New Man

    Otachan's in_!mpg123
    Reply #122
    Quote
    mp3infp Ver.2.47e is out. It now supports ape2 tags on mp3 (in a fashion), and generally starts to look quite useable...
    [a href="index.php?act=findpost&pid=252275"][{POST_SNAPBACK}][/a]


    I requested APEv2 support a while back on the win32labs BBS. The developer said he would look into it. I was definitely happy to see it worked out. 
    "We live as if the world were as it should be, to show it what it can be..." - Angel

    • TakuSkan
    • [*][*][*][*]
    Otachan's in_!mpg123
    Reply #123
    Quote
    ot75c is out.

    So what's the difference between the in_mpg123_118otXXx versions.  Nothing I can see in the readmes.

    Quote
    I was definitely happy to see it worked out.   [a href="index.php?act=findpost&pid=261710"][{POST_SNAPBACK}][/a]


    Yeah Noah... thanks 2u2
    Geopoliticus Child Watching the Birth of the New Man

    • k.eight.a
    • [*][*][*][*]
    Otachan's in_!mpg123
    Reply #124
    Anyone can help me with my problem
    • Last Edit: 27 December, 2004, 07:14:38 PM by k.eight.a
    Sorry for my poor English, I'm trying to get better... ;)
    "The greatest trick the Devil ever pulled, was convincing the world he didn't exist."