Skip to main content

Topic: foo_mp4 - error (Read 3396 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Skibbi
  • [*][*]
foo_mp4 - error
Hi,
Today I tried to play an aac file, compressed long, long time ago with one of the first aac compressors. Unfortunately foo_mp4 gives me the following error:
Code: [Select]
ERROR (foo_mp4) : Channel coupling not yet implemented

I'am just wondering if there is a chance to play those files in the future using foo_mp4?
Regards.

  • menno
  • [*][*][*][*][*]
  • Developer (Donating)
foo_mp4 - error
Reply #1
Your file probably has the old ADTS format. You can convert them to new format with some switch on FAAD2:

faad.exe -t -a output.aac input.aac

Menno

  • Skibbi
  • [*][*]
foo_mp4 - error
Reply #2
I've downloaded faad binaries from RareWares, but it seems don't have the following swithes "-t -a"?
Regards.

  • menno
  • [*][*][*][*][*]
  • Developer (Donating)
foo_mp4 - error
Reply #3
Try searching for some newer binaries. For example on Case's site. You will find the address when doing a search on this forum. (Can't find it right now).

Menno

  • Skibbi
  • [*][*]
foo_mp4 - error
Reply #4
Unfortunately faad gives me the same error  I suppose my old aac files are totally incompatible with the new aac compressors/decompressors.
Regards.