Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: wiki 404 Not Found (Read 2995 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

 

Re: wiki 404 Not Found

Reply #1
We think it has been compromised and have removed it as a temporary measure


Re: wiki 404 Not Found

Reply #3
well thats not good.

Re: wiki 404 Not Found

Reply #4
Problem was bad behavior (CPU usage + warning log flooding disk space) after mysql update, the server wasn't compromised.
Wiki will be restored shortly.
Microsoft Windows: We can't script here, this is bat country.

Re: wiki 404 Not Found

Reply #5
While you're at it, maybe consider updating Mediawiki? Last time I checked it was very outdated. I don't know how many of the updates are security-related, but still.
Music: sounds arranged such that they construct feelings.

Re: wiki 404 Not Found

Reply #6
Update:
I'm actively working on restoring it and upgrading to latest mediawiki.
No worries about the content, it's been thoroughly backed up.
Microsoft Windows: We can't script here, this is bat country.

Re: wiki 404 Not Found

Reply #7
Sorry it took me so long.
It's back and mostly working, running on latest mediawiki.
If things go haywire, it's been thoroughly backed up and can be reverted to current state.
Some things look weird, front page clickpic in particular. Looks like clickpic template isn't working properly, I've not been able to figure out why, hopefully someone can enlighten me or edit it.
User account registration is currently disabled until I get all glitches ironed out.
Microsoft Windows: We can't script here, this is bat country.

Re: wiki 404 Not Found

Reply #8
At first glance I noticed fewer installed extensions but assumed it was still a work in progress.
User groups are a bit different too.
korth

Re: wiki 404 Not Found

Reply #9
but assumed it was still a work in progress.
Yeah I know obviously (it takes time to finish up the restoration and even upgrade this wiki to latest MediaWiki), especially the infobox templates now showing the text "[[File:" above and "|256px]]" below the actual image, as I've seen on this one but not just that

Re: wiki 404 Not Found

Reply #10
Taken offline because someone/something appears is DoSing the server. Will be back shortly.

Extensions will be restored, I'm looking at them one by one, if they're actually still needed. This stuff was set up over 10 years ago and I wasn't in charge of it then.
Microsoft Windows: We can't script here, this is bat country.

Re: wiki 404 Not Found

Reply #11
Some things look weird, front page clickpic in particular. Looks like clickpic template isn't working properly, I've not been able to figure out why, hopefully someone can enlighten me or edit it.
I hope I fixed that correctly
Music: sounds arranged such that they construct feelings.

Re: wiki 404 Not Found

Reply #12
That didn't fix the clickpic template
which means the fb2k template is still broke.
korth


Re: wiki 404 Not Found

Reply #14
@Peter
Template:Clickpic
Looks like you might need to check localSettings.php
https://meta.wikimedia.org/wiki/User:CharlesC/Template_for_navigational_images_on_Mediawiki_websites#If_you_want_to_use_an_image_that_is_contained_within_the_wiki

[...] the infobox templates now showing the text "[[File:" above and "|256px]]" below the actual image, as I've seen on this one

I've made an adjustment to the Template:Infobox foobar2000 component
I've also asked the template author @beardgoggles  to have a look.
korth

Re: wiki 404 Not Found

Reply #15
Okay, clickpic fixed by copying $wgAllowExternalImagesFrom from old config, thanks for the tip.
Microsoft Windows: We can't script here, this is bat country.

Re: wiki 404 Not Found

Reply #16
clickpic still doesn't appear to be working (maybe after a wiki restart?)
The main page image link was changed by @ktf  so the current main page is not a representation of the working template.

korth

Re: wiki 404 Not Found

Reply #17
Silly me. I used Template:Fb2k as an indication clickpic wasn't working.
The image linked in Template:Fb2k was http://
Template:Clickpic is not working with http://
but works fine with https:// external image links

Changed image link in Template:Fb2k (now working)
Reverted edits by @ktf on wiki Main Page


korth