Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_vis_spectrum_analyzer (Read 101034 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: foo_vis_spectrum_analyzer

Reply #600
I know this isn't strictly related to the component, but do you have any idea why I can't get it to run past ~64fps?
The component uses a high-resolution timer which has no restrictions but I *assume* it is caused by the Direct3D swap chain being tied to the monitor refresh rate (60Hz). Anyone with a variable or higher refresh rate monitor that can confirm this?
Love the component. Thanks for your effort!
Thx

Re: foo_vis_spectrum_analyzer

Reply #601
Sneak preview: Peak Meter (Peak and RMS)


Re: foo_vis_spectrum_analyzer

Reply #602
I know this isn't strictly related to the component, but do you have any idea why I can't get it to run past ~64fps?
The component uses a high-resolution timer which has no restrictions but I *assume* it is caused by the Direct3D swap chain being tied to the monitor refresh rate (60Hz). Anyone with a variable or higher refresh rate monitor that can confirm this?
I have 144 Hz monitor. Update rate seems to max out here at 100 fps. The frame counter goes crazy and shows anything between 99.xx and 100.xx.
By the way, the built-in frame display has too little space when the fps goes above 100. The "fps" string jumps to a new line.

Re: foo_vis_spectrum_analyzer

Reply #603
I know this isn't strictly related to the component, but do you have any idea why I can't get it to run past ~64fps?
The component uses a high-resolution timer which has no restrictions but I *assume* it is caused by the Direct3D swap chain being tied to the monitor refresh rate (60Hz). Anyone with a variable or higher refresh rate monitor that can confirm this?
I have 144 Hz monitor. Update rate seems to max out here at 100 fps. The frame counter goes crazy and shows anything between 99.xx and 100.xx.
By the way, the built-in frame display has too little space when the fps goes above 100. The "fps" string jumps to a new line.
Thx. for the confirmation and the bug report.

Re: foo_vis_spectrum_analyzer

Reply #604
The component uses a high-resolution timer which has no restrictions but I *assume* it is caused by the Direct3D swap chain being tied to the monitor refresh rate (60Hz). Anyone with a variable or higher refresh rate monitor that can confirm this?

I'm on a 144hz VRR monitor (Gsync) with a high-end GPU. Using 32-bit Foobar with the latest drivers, DX, etc. The FPS counter keeps oscillating between 60 and 64 fps for every refresh rate limit >= 60HZ.

Thanks for looking into it.

Re: foo_vis_spectrum_analyzer

Reply #605
v0.7.5.0-beta2, 2024-03-31

* New: Peak Meter visualization.
* Improved: Edge cases for the scaling and position of the spectrum bars and curve vs. the X-axis.

While in beta testing you can only download it from GitHub.

Re: foo_vis_spectrum_analyzer

Reply #606
v0.7.5.0-beta2, 2024-03-31

* New: Peak Meter visualization.
* Improved: Edge cases for the scaling and position of the spectrum bars and curve vs. the X-axis.

While in beta testing you can only download it from GitHub.

There is a problem with the gap between the two sides of the Y-axis when resizing the visualization panel, check out the video below:

Re: foo_vis_spectrum_analyzer

Reply #607
v0.7.5.0-beta2, 2024-03-31

* New: Peak Meter visualization.
* Improved: Edge cases for the scaling and position of the spectrum bars and curve vs. the X-axis.

While in beta testing you can only download it from GitHub.
There is a problem with the gap between the two sides of the Y-axis when resizing the visualization panel, check out the video below:
That's how it's supposed to react: The width of a bar adapts to the available space as an whole number; no more fractional bar widths and rounding errors.

When the available space becomes width enough through resizing or through disabling the Y-axis for a wider bar the graph re-calculates and occupies the available space.

Re: foo_vis_spectrum_analyzer

Reply #608
@pqyt,

Quote:
1. All of the above has been fixed or stabilized a couple of releases ago,
2. This is way off-topic. This thread is for foo_uie_peakmeter_spectrum.
End quote.

Moving to proper topic,
I used your newest beta2 and all those 3 bugs are still present. I checked on two different laptops with two versions of foobar (32bit and 64bit).

- Nyquist line still in wrong position
- art still appearing/disappearing
- right end of the spectrum/peak meter disapearing and never coming back.

I really double checked the issue and it is there.

Re: foo_vis_spectrum_analyzer

Reply #609
@pqyt,

Quote:
1. All of the above has been fixed or stabilized a couple of releases ago,
2. This is way off-topic. This thread is for foo_uie_peakmeter_spectrum.
End quote.

Moving to proper topic,
I used your newest beta2 and all those 3 bugs are still present. I checked on two different laptops with two versions of foobar (32bit and 64bit).

- Nyquist line still in wrong position
- art still appearing/disappearing
- right end of the spectrum/peak meter disapearing and never coming back.
I really double checked the issue and it is there.
@wojak , can you send me a preset file? Which sample rate is the track that causes a problem? I really can not reproduce this.

Re: foo_vis_spectrum_analyzer

Reply #610
@pqyt,

Quote:
1. All of the above has been fixed or stabilized a couple of releases ago,
2. This is way off-topic. This thread is for foo_uie_peakmeter_spectrum.
End quote.

Moving to proper topic,
I used your newest beta2 and all those 3 bugs are still present. I checked on two different laptops with two versions of foobar (32bit and 64bit).

- Nyquist line still in wrong position
- art still appearing/disappearing
- right end of the spectrum/peak meter disapearing and never coming back.
I really double checked the issue and it is there.
@wojak , can you send me a preset file? Which sample rate is the track that causes a problem? I really can not reproduce this.

Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).

Re: foo_vis_spectrum_analyzer

Reply #611
Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).
Preferably from beta2. You can attach it to a reply here. It does not contain any personal data.

Re: foo_vis_spectrum_analyzer

Reply #612
Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).
Preferably from beta2. You can attach it to a reply here. It does not contain any personal data.

I still do not know how to attach a file here. I do not see any option to do that yet people do it and even their images are directly visible in the posts. How to do all of this?

Re: foo_vis_spectrum_analyzer

Reply #613
Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).
Preferably from beta2. You can attach it to a reply here. It does not contain any personal data.

You will find the link to my preset from beta2.
https://we.tl/t-5ibmkGscka

I checked once more and it was like that:
I start a 96/24 file, then bring the component window up. The preferences are set to display from 1Hz to 96kHz and with an art. But what I see if just the left side of the spectrum up to 1,8kHz with art on the right. With no Nyquist line. Then I make it fullscreen, nothing changes. Then I make it normal, nothing changes. Then I click on the file in the palylist to play it from the begining and the spectrum changes to proper (to 96kHz) with proper Nyquist line but the cover art disapears.
It seems that the behaviour is somewhat different each time but always wrong. I did not change in my Windows nor Foobar nor your component.

Re: foo_vis_spectrum_analyzer

Reply #614
I still do not know how to attach a file here. I do not see any option to do that yet people do it and even their images are directly visible in the posts. How to do all of this?

When you are composing a post, directly below the composition window is a bar saying "Add files by dragging & dropping or selecting them."  Clicking "selecting them" will open the usual browse dialog allowing you to pick a file from your PC.

Image files added this way will show up as small images in the post that if clicked on will open to full size.  You can also use an image upload site like Imgur to upload an image, then create a "link to image file" from your browser's context menu and copy it to the "Insert an Image" button at the top of the message pane, which will make the full image appear in the post where you want it.  That can be checked using the "Preview" button before posting, however images attached via the Forum method will not be viewable from Preview.

Re: foo_vis_spectrum_analyzer

Reply #615
Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).
Preferably from beta2. You can attach it to a reply here. It does not contain any personal data.

You will find the link to my preset from beta2.
https://we.tl/t-5ibmkGscka

I checked once more and it was like that:
I start a 96/24 file, then bring the component window up. The preferences are set to display from 1Hz to 96kHz and with an art. But what I see if just the left side of the spectrum up to 1,8kHz with art on the right. With no Nyquist line. Then I make it fullscreen, nothing changes. Then I make it normal, nothing changes. Then I click on the file in the palylist to play it from the begining and the spectrum changes to proper (to 96kHz) with proper Nyquist line but the cover art disapears.
It seems that the behaviour is somewhat different each time but always wrong. I did not change in my Windows nor Foobar nor your component.
This is as close as I can get based on your description. Works as expected, AFAIK.

Re: foo_vis_spectrum_analyzer

Reply #616
Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).
Preferably from beta2. You can attach it to a reply here. It does not contain any personal data.

You will find the link to my preset from beta2.
https://we.tl/t-5ibmkGscka

I checked once more and it was like that:
I start a 96/24 file, then bring the component window up. The preferences are set to display from 1Hz to 96kHz and with an art. But what I see if just the left side of the spectrum up to 1,8kHz with art on the right. With no Nyquist line. Then I make it fullscreen, nothing changes. Then I make it normal, nothing changes. Then I click on the file in the palylist to play it from the begining and the spectrum changes to proper (to 96kHz) with proper Nyquist line but the cover art disapears.
It seems that the behaviour is somewhat different each time but always wrong. I did not change in my Windows nor Foobar nor your component.
This is as close as I can get based on your description. Works as expected, AFAIK.

I will try to post a clip of my case later but maybe there is a problem with scalling? Remember when you introduced the plugin, there was a problem that when you expanded the settings with new options it seized to fit on my screen? I use 125% because I have to (and I will not change it because I just can't).
Nevertheles in my case it does not look/work as in your video attached above.

Re: foo_vis_spectrum_analyzer

Reply #617
Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).
Preferably from beta2. You can attach it to a reply here. It does not contain any personal data.

You will find the link to my preset from beta2.
https://we.tl/t-5ibmkGscka

I checked once more and it was like that:
I start a 96/24 file, then bring the component window up. The preferences are set to display from 1Hz to 96kHz and with an art. But what I see if just the left side of the spectrum up to 1,8kHz with art on the right. With no Nyquist line. Then I make it fullscreen, nothing changes. Then I make it normal, nothing changes. Then I click on the file in the palylist to play it from the begining and the spectrum changes to proper (to 96kHz) with proper Nyquist line but the cover art disapears.
It seems that the behaviour is somewhat different each time but always wrong. I did not change in my Windows nor Foobar nor your component.
This is as close as I can get based on your description. Works as expected, AFAIK.

I will try to post a clip of my case later but maybe there is a problem with scalling? Remember when you introduced the plugin, there was a problem that when you expanded the settings with new options it seized to fit on my screen? I use 125% because I have to (and I will not change it because I just can't).
Nevertheles in my case it does not look/work as in your video attached above.


I am sorry but I am unable to record what is going on my monitor. I start foobar and use win+alt+g and start recording. But when I bring up the popup with your componet or anything else it is not on the recording - only the main foobars window is there.
How am I supposed to record all other "layers" of what is on the screen?

Re: foo_vis_spectrum_analyzer

Reply #618
Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).
Preferably from beta2. You can attach it to a reply here. It does not contain any personal data.

You will find the link to my preset from beta2.
https://we.tl/t-5ibmkGscka

I checked once more and it was like that:
I start a 96/24 file, then bring the component window up. The preferences are set to display from 1Hz to 96kHz and with an art. But what I see if just the left side of the spectrum up to 1,8kHz with art on the right. With no Nyquist line. Then I make it fullscreen, nothing changes. Then I make it normal, nothing changes. Then I click on the file in the palylist to play it from the begining and the spectrum changes to proper (to 96kHz) with proper Nyquist line but the cover art disapears.
It seems that the behaviour is somewhat different each time but always wrong. I did not change in my Windows nor Foobar nor your component.
This is as close as I can get based on your description. Works as expected, AFAIK.

OK, VLC did the trick.
In the attached video you will see that I play 96/24 file then bring up the popup with your componet and it ends at 2kHz with cover art to the right (which probably is center but the right side is cut out). There is also no Nyquist line. Then I restart the track and the component windows becomes OK, with full scale (to 96kHz) and proper Nyquist line but the art disappeared. Then I change it to Peak Meter which is OK up to the moment when I make it full screen. Once again the right part is cut out and never comes back until I restart the track.

 

Re: foo_vis_spectrum_analyzer

Reply #619
Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).
Preferably from beta2. You can attach it to a reply here. It does not contain any personal data.

You will find the link to my preset from beta2.
https://we.tl/t-5ibmkGscka

I checked once more and it was like that:
I start a 96/24 file, then bring the component window up. The preferences are set to display from 1Hz to 96kHz and with an art. But what I see if just the left side of the spectrum up to 1,8kHz with art on the right. With no Nyquist line. Then I make it fullscreen, nothing changes. Then I make it normal, nothing changes. Then I click on the file in the palylist to play it from the begining and the spectrum changes to proper (to 96kHz) with proper Nyquist line but the cover art disapears.
It seems that the behaviour is somewhat different each time but always wrong. I did not change in my Windows nor Foobar nor your component.
This is as close as I can get based on your description. Works as expected, AFAIK.

OK, VLC did the trick.
In the attached video you will see that I play 96/24 file then bring up the popup with your componet and it ends at 2kHz with cover art to the right (which probably is center but the right side is cut out). There is also no Nyquist line. Then I restart the track and the component windows becomes OK, with full scale (to 96kHz) and proper Nyquist line but the art disappeared. Then I change it to Peak Meter which is OK up to the moment when I make it full screen. Once again the right part is cut out and never comes back until I restart the track.
You were right. It had to do with the DPI setting. I don't know yet what changed for the DPI calculation to be ignored. But at least I know where to look.

Re: foo_vis_spectrum_analyzer

Reply #620
Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).
Preferably from beta2. You can attach it to a reply here. It does not contain any personal data.

You will find the link to my preset from beta2.
https://we.tl/t-5ibmkGscka

I checked once more and it was like that:
I start a 96/24 file, then bring the component window up. The preferences are set to display from 1Hz to 96kHz and with an art. But what I see if just the left side of the spectrum up to 1,8kHz with art on the right. With no Nyquist line. Then I make it fullscreen, nothing changes. Then I make it normal, nothing changes. Then I click on the file in the palylist to play it from the begining and the spectrum changes to proper (to 96kHz) with proper Nyquist line but the cover art disapears.
It seems that the behaviour is somewhat different each time but always wrong. I did not change in my Windows nor Foobar nor your component.
This is as close as I can get based on your description. Works as expected, AFAIK.

OK, VLC did the trick.
In the attached video you will see that I play 96/24 file then bring up the popup with your componet and it ends at 2kHz with cover art to the right (which probably is center but the right side is cut out). There is also no Nyquist line. Then I restart the track and the component windows becomes OK, with full scale (to 96kHz) and proper Nyquist line but the art disappeared. Then I change it to Peak Meter which is OK up to the moment when I make it full screen. Once again the right part is cut out and never comes back until I restart the track.
You were right. It had to do with the DPI setting. I don't know yet what changed for the DPI calculation to be ignored. But at least I know where to look.
Fixed it. An unfortunate regression...

Re: foo_vis_spectrum_analyzer

Reply #621
Right now I reverted to last stable version. I can send a preset file if you tell me how to do such thing on this forum. Do I need to use external "cloud" (please name any - I do not do such things so I have little knowledge) and copy the link or smth else? Do you prefer the file from last stable or the latest beta?
The sample rate does not matter, the Nyquist line is always at 22,05 if I enable the popup while playing the file (no matter if 44,1, 48, 82,2, 96, 176,6, 192 or DSD). It jumps to proper position only if I start to play next (or the same song) from the begining when the popup window is already active.
The cover art problem seems random (you already explained that it is not random but it just looks random to the common user like me - I just do not see any pattern).
Preferably from beta2. You can attach it to a reply here. It does not contain any personal data.

You will find the link to my preset from beta2.
https://we.tl/t-5ibmkGscka

I checked once more and it was like that:
I start a 96/24 file, then bring the component window up. The preferences are set to display from 1Hz to 96kHz and with an art. But what I see if just the left side of the spectrum up to 1,8kHz with art on the right. With no Nyquist line. Then I make it fullscreen, nothing changes. Then I make it normal, nothing changes. Then I click on the file in the palylist to play it from the begining and the spectrum changes to proper (to 96kHz) with proper Nyquist line but the cover art disapears.
It seems that the behaviour is somewhat different each time but always wrong. I did not change in my Windows nor Foobar nor your component.
This is as close as I can get based on your description. Works as expected, AFAIK.

OK, VLC did the trick.
In the attached video you will see that I play 96/24 file then bring up the popup with your componet and it ends at 2kHz with cover art to the right (which probably is center but the right side is cut out). There is also no Nyquist line. Then I restart the track and the component windows becomes OK, with full scale (to 96kHz) and proper Nyquist line but the art disappeared. Then I change it to Peak Meter which is OK up to the moment when I make it full screen. Once again the right part is cut out and never comes back until I restart the track.
You were right. It had to do with the DPI setting. I don't know yet what changed for the DPI calculation to be ignored. But at least I know where to look.
Fixed it. An unfortunate regression...

Will there be another beta to test the fixes?

Re: foo_vis_spectrum_analyzer

Reply #622
v0.7.5.0, 2024-04-04

* New: Spectogram visualization.
  * Static or scrolling
* New: Peak Meter visualization.
* New: Built-in SoX color scheme and corresponding non-linear amplitude color map suited for the spectogram visualization.
* New: The context menu can be used to load a preset.
* New: Artwork Fit mode. Defaults to "Fit Big".
* Improved: Double-clicking a preset activates it.
* Improved: Edge cases for the scaling and position of the spectrum bars and curve vs. the X-axis.
* Improved: LED Mode is also applied to the bar background.
* Improved: The LED size and gap can be configured.
* Improved: The font of the X and Y-axis can be configured in all visualizations.
* Fixed: Privacy issue: The preset path will no longer be saved to a preset file.
* Fixed: The spin buttons were not updated when switching between multiple graphs in the configuration dialog.
* Fixed: Inconsistent state of the color buttons and values when switching between styles in the configuration dialog.
* Fixed: User interface colors were not activated after loading a preset.
* Fixed: The custom Solid color was not always saved correctly.
* Fixed: Deadlock condition specific to CUI when playback was set to resume at startup.
* Fixed: Memory leak in tool tips when resizing the component.
* Fixed: Artwork should now consistently be rendered when requested.

You can download it from the Component repository or from GitHub.

Re: foo_vis_spectrum_analyzer

Reply #623
Hi,

thank you for the new version.

I have tested it a bit and here are my observations:
- Spectrum: when playing 96/24 files and then bringing the popup - the art is there from the begining but the Nyquist line is still in the wrong place (22,05). Changing to full-sreen and back changes nothing. That is good that the art does not disappear but the Nyquist is still wrong. But if I then click to restart the file - the Nyquist line goes to proper position but the art disappears. But then if I click to full screen the art appears but the Nyquist goes back to wrong position (22,05) and it stays there. Everything is fine now with 44,1 files though.
- Peak meter: I use it in horizontal position. It works well even if I change to full-screen and back. One drawback (it only appears in horizontal option) is when I want to disable either top or bottom digits. They all disappear (meaning I can only see either both or none). It is the same with left/right digits - disabling left or right really disables both. It only happens in the peak meter mode and only when horizontal. Plus it would be nice to be able to set the top value larger than 0 here in order to see some blank space on the top end or to see the whole bar when peak is higher than 0. Just like in built-in meter (but with less "head room").
- It would be really cool to be able to have independent options for Spectrum, Peak and Spectrogram - for example to set the max  to 0 in Spectrum and to 1 or 2 in Peak meter. Or to set different amplitude steps to them (to see either more digits or less of them when using in small window - ex. Spectrum in large window with many digits and Peak meter in smaller one with not so many).  You made it possible to set different styles (colours) which is really great. The same would be great with other options.

Re: foo_vis_spectrum_analyzer

Reply #624
Hi,

thank you for the new version.

I have tested it a bit and here are my observations:
- Peak meter: I use it in horizontal position. It works well even if I change to full-screen and back. One drawback (it only appears in horizontal option) is when I want to disable either top or bottom digits. They all disappear (meaning I can only see either both or none). It is the same with left/right digits - disabling left or right really disables both. It only happens in the peak meter mode and only when horizontal. Plus it would be nice to be able to set the top value larger than 0 here in order to see some blank space on the top end or to see the whole bar when peak is higher than 0. Just like in built-in meter (but with less "head room").
Confirmed. Must be due to some last minute optimizing. It has worked all through development.