Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_vis_spectrum_analyzer (Read 119217 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: foo_vis_spectrum_analyzer

Reply #550
Just updated to 0.7.4.1.

I've never reported this, but it's been true for many version updates, including this one. When I update the component to a new version it often has what appears to be background color refresh issues, that is it looks like the background color inherits the color of the bar or bar peak color. I typically have to reset my entire setup and recreate it from scratch to get it to function properly after an update. I suspect this might have to do with me typically having background colors set to none, but I'm not sure that's relevant, just guessing.

To reproduce (1) import my preset using component version 0.7.3.0 (2) update to component version 0.7.4.1


Re: foo_vis_spectrum_analyzer

Reply #551
The configuration file saved when the color source is set to the user interface, after the configuration file is loaded, the colors don't load correctly and need to be rendered correctly after playing a new track or going full screen once

Re: foo_vis_spectrum_analyzer

Reply #552
Hi, I am new to the forum and I apologize if this is not the right place for this message.
Thanks pqyt for your work, I find it a very powerful and perfect component for our Foobar and it works great.
In my old 32Bit version I used the Peakmeter Spectrum Visualisation component (foo_uie_vis_peakmeter_spectrum) to know the DB signal of the left and right channel (I attach photo). Which has no updates.
I would like to ask you, if it would be possible in the future to implement this new component horizontally for 64Bit.
Thank you very much.
I think I can reuse most of the code. I'll put it on the To Do list.

Re: foo_vis_spectrum_analyzer

Reply #553
Just updated to 0.7.4.1.

I've never reported this, but it's been true for many version updates, including this one. When I update the component to a new version it often has what appears to be background color refresh issues, that is it looks like the background color inherits the color of the bar or bar peak color. I typically have to reset my entire setup and recreate it from scratch to get it to function properly after an update. I suspect this might have to do with me typically having background colors set to none, but I'm not sure that's relevant, just guessing.

To reproduce (1) import my preset using component version 0.7.3.0 (2) update to component version 0.7.4.1
Color mode "None" for the background is a leftover from a failed experiment with a transparent background and should fallback to color mode "Solid". I left it in for consistency and for when I have time to try another technique.

Re: foo_vis_spectrum_analyzer

Reply #554
The configuration file saved when the color source is set to the user interface, after the configuration file is loaded, the colors don't load correctly and need to be rendered correctly after playing a new track or going full screen once
Can you provide the steps you take when you have this issue? I tried a couple of things based on your description but I am not able to reproduce it.

Re: foo_vis_spectrum_analyzer

Reply #555
The configuration file saved when the color source is set to the user interface, after the configuration file is loaded, the colors don't load correctly and need to be rendered correctly after playing a new track or going full screen once
Can you provide the steps you take when you have this issue? I tried a couple of things based on your description but I am not able to reproduce it.
I made a gif, you can take a look at it. After loading, the correct color of the user interface is not displayed.

Re: foo_vis_spectrum_analyzer

Reply #556
The configuration file saved when the color source is set to the user interface, after the configuration file is loaded, the colors don't load correctly and need to be rendered correctly after playing a new track or going full screen once
Can you provide the steps you take when you have this issue? I tried a couple of things based on your description but I am not able to reproduce it.
I made a gif, you can take a look at it. After loading, the correct color of the user interface is not displayed.
@yeyo, Thx. I'll look into it.

Re: foo_vis_spectrum_analyzer

Reply #557
Hi, I am new to the forum and I apologize if this is not the right place for this message.
Thanks pqyt for your work, I find it a very powerful and perfect component for our Foobar and it works great.
In my old 32Bit version I used the Peakmeter Spectrum Visualisation component (foo_uie_vis_peakmeter_spectrum) to know the DB signal of the left and right channel (I attach photo). Which has no updates.
I would like to ask you, if it would be possible in the future to implement this new component horizontally for 64Bit.
Thank you very much.
I think I can reuse most of the code. I'll put it on the To Do list.

Thank you very much for showing interest in the requested component. I am sure that many users will like it.
I look forward to hearing from you when it is your turn on your list. I hope you have time to do it and give me a big surprise.
 :)  ;)

Re: foo_vis_spectrum_analyzer

Reply #558
For me with the last couple versions (v0.7.4.0 and v0.7.4.1) the artwork will randomly turn off (appear blank) when I play a track, even though Show artwork on background is checked. It doesn't behave like this with v0.7.3.0.

Re: foo_vis_spectrum_analyzer

Reply #559
For me with the last couple versions (v0.7.4.0 and v0.7.4.1) the artwork will randomly turn off (appear blank) when I play a track, even though Show artwork on background is checked. It doesn't behave like this with v0.7.3.0.

Video... (Just copy and paste)

youtu.be/9IwTvMeumL8


Re: foo_vis_spectrum_analyzer

Reply #560
@pqyt
When the Left of the Y-axis is not checked, the left of the X-axis Bans and Decibel is not fully displayed.

Re: foo_vis_spectrum_analyzer

Reply #561
Work in progress: Scrolling spectogram with the SoX color scheme


Re: foo_vis_spectrum_analyzer

Reply #562
Useless, extremely low resolution spectrogram.
Please remove my account from this forum.


Re: foo_vis_spectrum_analyzer

Reply #564
dude... this component gets 1658741 new bugs every time you update it.
0.7.4.1X

Re: foo_vis_spectrum_analyzer

Reply #565
X


Re: foo_vis_spectrum_analyzer

Reply #567
Thanks for your latest update. This thing has made a lot of head-way in a short period of time. However, I'm still getting the disappearing artwork issue.

www.youtube.com/watch?v=hNOVmdDHDb4

Re: foo_vis_spectrum_analyzer

Reply #568
Thanks for your latest update. This thing has made a lot of head-way in a short period of time. However, I'm still getting the disappearing artwork issue.

www.youtube.com/watch?v=hNOVmdDHDb4
The origin of all these problems is the different behavior of CUI.  Not a blame as such but it is very difficult and time-consuming to test multiple configurations. I use DUI only. F.e. the nagging lock-up problem only occurs with CUI (but has been fixed finally).

Rant aside, I'll try to fix it. I underestimated the popularity of CUI.

Re: foo_vis_spectrum_analyzer

Reply #569
Thanks for your latest update. This thing has made a lot of head-way in a short period of time. However, I'm still getting the disappearing artwork issue.

www.youtube.com/watch?v=hNOVmdDHDb4
The origin of all these problems is the different behavior of CUI.  Not a blame as such but it is very difficult and time-consuming to test multiple configurations. I use DUI only. F.e. the nagging lock-up problem only occurs with CUI (but has been fixed finally).

Rant aside, I'll try to fix it. I underestimated the popularity of CUI.

I guess you did.

Now things are getting stable I hope you did not forget about transparency.
To refresh your memory, I was able to issue screen refreshes that repainted my background art behind your plugin (0.7.0.0-beta-4) on screen resizes.

Current issues you are having with art disappearing seem to be quite similar to what I encountered in the old version and was able to "fix" by putting a $showpanel_c(PQRT,0) the line above $showpanel_c(PQRT,1) where the panel is actually displayed.

Only things that did not work was coming back from your plugin in full screenmode (which I won't use) and restoring from being minimized. In case that is not solved yet I most probably have a workaround for that now since Marc3k made some general tags that allow me to detect that fooBar is coming back from being minimized.

So, I'd like to have a new go if you're up to it?

Re: foo_vis_spectrum_analyzer

Reply #570
Thanks for your latest update. This thing has made a lot of head-way in a short period of time. However, I'm still getting the disappearing artwork issue.

www.youtube.com/watch?v=hNOVmdDHDb4
The origin of all these problems is the different behavior of CUI.  Not a blame as such but it is very difficult and time-consuming to test multiple configurations. I use DUI only. F.e. the nagging lock-up problem only occurs with CUI (but has been fixed finally).

Rant aside, I'll try to fix it. I underestimated the popularity of CUI.
So, I'd like to have a new go if you're up to it?
If it's all the same to you, not for the upcoming release. Adding the spectogram required additional internal rewiring, e.g. a scrolling X-axis. Reducing the release tempo and focusing more on stability and polishing should be a priority, imho.

Re: foo_vis_spectrum_analyzer

Reply #571
Thanks for your latest update. This thing has made a lot of head-way in a short period of time. However, I'm still getting the disappearing artwork issue.

www.youtube.com/watch?v=hNOVmdDHDb4
The origin of all these problems is the different behavior of CUI.  Not a blame as such but it is very difficult and time-consuming to test multiple configurations. I use DUI only. F.e. the nagging lock-up problem only occurs with CUI (but has been fixed finally).

Rant aside, I'll try to fix it. I underestimated the popularity of CUI.
So, I'd like to have a new go if you're up to it?
If it's all the same to you, not for the upcoming release. Adding the spectogram required additional internal rewiring, e.g. a scrolling X-axis. Reducing the release tempo and focusing more on stability and polishing should be a priority, imho.

I understand.

I'll install current version to see if I can "fix" the disappearing art thingy, which most probably will also be an issue in my skin as well.


Re: foo_vis_spectrum_analyzer

Reply #573
Thanks for your latest update. This thing has made a lot of head-way in a short period of time. However, I'm still getting the disappearing artwork issue.

www.youtube.com/watch?v=hNOVmdDHDb4
The origin of all these problems is the different behavior of CUI.  Not a blame as such but it is very difficult and time-consuming to test multiple configurations. I use DUI only. F.e. the nagging lock-up problem only occurs with CUI (but has been fixed finally).

Rant aside, I'll try to fix it. I underestimated the popularity of CUI.

You could try another approach and put a transparency option. Then the existing artwork can coexist with the spectrum.

Re: foo_vis_spectrum_analyzer

Reply #574
 How do I set spectrogram visualization to static?  Like spek.  I only found scrolling.