Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foobar2000 v2.0 bugs (Read 41470 times) previous topic - next topic
0 Members and 14 Guests are viewing this topic.

Re: foobar2000 v2.0 bugs

Reply #25
Yes, as you can see there is only 1 file found. Take a look at the screenshot.


Re: foobar2000 v2.0 bugs

Reply #26
You need to update it to

Code: [Select]
rating IS 5

Without the %%, it uses metadata directly from your files.

With fb2k v2, it has playback statistics built in (previously foo_playcount) and this takes over %rating% for its own internal database.

Re: foobar2000 v2.0 bugs

Reply #27
Thanks for clarification, it works!

Re: foobar2000 v2.0 bugs

Reply #28
Also, if you used to display %rating% in any playlist column / display panel, it now needs updating to use $meta(rating).

Re: foobar2000 v2.0 bugs

Reply #29
Help. Error in the Media Library.

I have updated to version 2.0 Betta 3, 32bits and something that had never happened to me has happened to me since Foobar, more than 10 years ago.

If I open Foobar without having connected the external hard drive my music offers me at the Album List Panel all my music and in the Library View when I select an artist offers me all the albumes of her. And the following occurs:
- The first time offers albumes correctly
- Change to another artist and when I return to the previous one, all the tracks of all the albums have doubled.
- If I do this operation 10 times I double them 10 times, if I do 50 I duplicate them 50.

The attached image reflects the problem.

As the tracks duplicate, it takes more to respond to all actions.

The only solution is to click the hard drive and wait for monitoring (8 TB hard drive).

It has also happened to me with the connected hard drive, after using Re-Facets. Logically, it has been slowed in such a way that it did not respond and I had to stop the process. But when Foobar launched again, he did not respond and had to disconnect the hard drive to load the foobar and monitor the hard drive.

Re: foobar2000 v2.0 bugs

Reply #30
I just realized that after being without using Foobar, he has continued to double every track with which he has become so slow that he hardly responds.

 

Re: foobar2000 v2.0 bugs

Reply #31
Time to add to the list. Found these using beta 3, 64-bit. Will update as I find more.

  • Theme layout isn't imported from 1.6 to 2.0
  • Importing themes doesn't preserve layout
  • Layout splitters can't be locked anymore (to prevent accidental panel resizing) in layout editing mode
  • Artwork panel flickers when resizing
  • Properties dialog tab font is too large
  • Console text area appears to be disabled
  • UI freezes while playlist is being drawn/populated. This, coupled with the fact that the entire library is scanned again on first launched caused lots of UI freezing.
  • Playlists take much longer to draw/populate (causes the above)
  • Date Added playback statistic is not imported from 1.6 for a majority of files - 1.6 installation has foo_playcount and every track has an associated added date yet less than 10% of tracks had their date added successfully copied. This breaks autoplaylists that rely on %added%. Entire library (except for that 10%) is considered "added" on the first launch of 2.0
  • Edit menu sometimes shows nothing - to reproduce, select a track in a playlist, click Edit in the main menu, press escape, then click Edit again
  • The cancel changes modal that appears seems to have the wrong colors, as if it's disabled (and an older, Vista-style icon?), similar to Console issue

Re: foobar2000 v2.0 bugs

Reply #32
Deleted about ~10 files in Autoplaylist (about 400,000 items). (File Operations - Delete file)
Until I noticed (about 5-10 minutes) fb2k 2.0 beta 3 was using 100% CPU(1 core) and was constantly writing disks to a specific .tmp file. (loop)
It looks like there is something wrong with sqlite processing.

Re: foobar2000 v2.0 bugs

Reply #33
  • Artwork panel flickers when resizing

I'm sure this will be fixed soon enough but I might as well pimp my album art replacement while I can.

It doesn't flicker
Uses the same preferences.
Shows tooltips with size/path info...



Customisable double click action and other bits available on the menu...



Like the new DUI panel, it uses WIC for handling exotic image formats (ignore if you have no idea what this is) and can also display album art from certain radio streams.

One thing it does not do is display library viewer selections. That was a conscious choice by me as I don't like it. It tracks playlist items only - preferring the playing item if playing, selected item if not. Can be configured to always track the selected item if you want.

JScript Panel 3, link in sig. 32bit/64bit available. Add to layout as usual, right click>Configure. Click the Samples button>Album Art.

Re: foobar2000 v2.0 bugs

Reply #34
Class not registered for aif files

I installed v2 32bit beta 3
when using aif files I get class not registered
then i'm back at 1.6.12 it handles .aif files normally

i'm on Windows 10 64bit build 19041

Re: foobar2000 v2.0 bugs

Reply #35
I think a little bit more info is needed. AIFF is a container and can contain data compressed with several different methods. A sample file would be great but telling what type of compression is used may be minimum requirement.

Re: foobar2000 v2.0 bugs

Reply #36
1) Some items when selected in Preferences turn the whole preferences window into "Light" mode even when the system is running in "dark" mode. Selecting unaffected options return the window to dark mode.

Notable examples in the the whole "Columns UI" section and sub-options below it, others option do it also including options added by some plugins.

2) Selecting the Advanced preference and typing something into the filter will often (but not always) cause foobar to CTD a few seconds after finishing typing.  Doing this while a track is playing seems to increase the chance (but again not always).
 

This is on 32 bit version of v2 beta 3.


Re: foobar2000 v2.0 bugs

Reply #37
Components with preference pages are entirely responsible for rendering the area marked with the rectangle. fb2k can't take it over and automagically apply dark mode.



fb2k renders the rest and components have to advertise they are dark mode capable. This is because many components will never be updated.

If fb2k assumed all components were dark mode capable and rendered the bits it is responsible in dark mode while the components themselves are not updated, you'd end up with a terrible situation like this...



This is why the whole window changes to match what the component is capable of.

And just because the entire CUI layout/playlist/panels supports dark mode, it doesn't mean the preferences are dark mode capable (yet). We'll have to wait. Remember CUI 2.0 is still marked as alpha.

Just for fun, components can update their own area but not tell fb2k they are dark mode capable and this happens...



I assume there is a special place in hell for anyone who released a component abusing these options.  :))


Re: foobar2000 v2.0 bugs

Reply #38
Hello, thank you for 2.0 version, Peter.

32-bit version works well with my portable DarkOne installation which I have backed up on 1.6 version. Then foo_input_monkey and foo_playcount remained and caused error and were uninstallable - uninstall option faded out. I returned to backed up 1.6 version and uninstalled these two, then upgraded without any error, everything is running well - skin, playback, all settings and playlist too.

One note though. There should be some speed up coming from used SQlite DB. I can't confirm that. Foobar start is significantly longer, pasting folders from explorer, sorting playlist and removing duplicates is taking up more time too and now I have faded out window with hourglass and waiting time about 15s even when switching between playlists, which was under one second in 1.6. I don't use library or watched folder at all, only one huge whole collection playlist consisting of 11TB and almost half million tracks from my NAS and one temporary playlist for converting etc.

I also hoped for native .webp cover art, but it's not so important.

Re: foobar2000 v2.0 bugs

Reply #39
About .webp cover art support, foobar2000 v2.0 uses Windows Imaging Component interface that allows it to support all image formats that your OS supports. You can for example download HEIC and WEBP support codecs from the Microsoft Store to get them working instantly.

I see that portable install using the old way without "profile" subdirectory causes the component uninstall to be disabled.

All the slow operations you talk about point that you have pre-2.0 UI components active that do some heavy metadata displaying or processing. For reference over here v1.6.12 console reports "Startup time : 0:00.306176" and v2.0 beta 3 reports "Startup time : 0:00.125752". Autoplaylists or library monitoring are not supposed to be a problem, the player is meant to start practically instantly.
Perhaps keeping compatibility with the old components was a mistake.

Re: foobar2000 v2.0 bugs

Reply #40
For windows store averse people or those on windows 7/8.1, you can get webp working by installing this...

https://storage.googleapis.com/downloads.webmproject.org/releases/webp/WebpCodecSetup.exe

edit: not sure that first part made sense. webp is bundled for 10/11 users. You have to go out of your way to remove it.

Re: foobar2000 v2.0 bugs

Reply #41
Album art showing covers is inconsistent - there are times - that it shows not cover or front jpg - it shows random picture



I think it just uses the first picture in folder.

Re: foobar2000 v2.0 bugs

Reply #42
^ got any more pixels bro? Not sure what you're trying to show us. But check File>Preferences>Display>Album Art>Front. Remove any patterns that don't match your own images or move your to the top. Also, it might help if you said it was the playlist or album art panel??

---

Beta 4 is out...


Quote
    MP4 tagging: do not set Various Artists if itunescompilation is present but set to 0.
    Crash bugs fixed.
    Made installer refuse to upgrade old non-portable installs containing profile data in application folder, which is no longer supported.
    Fixed metadb lock up with large queryInfoMulti() batches.
    Fixed library search by rating not working.
    Added ReFacets to library viewers list.
    Fixed missing double click to fullscreen in Default UI visualisations.
    Fixed disappearing live playback info on playback statistics update.
    Fixed longer-than-necessary gap when reopening exclusive-mode output on format change.
    Fixed seekbar & visualisation glitches when playing very short audio tracks with exclusive-mode output.

https://www.foobar2000.org/download

Re: foobar2000 v2.0 bugs

Reply #43


left only front.* and cover.*  ande removed all other files from the folder - it just doesnt load nor in the playlist nor in album art





Re: foobar2000 v2.0 bugs

Reply #44
found something - front.* works and folder* shows black squares until put first in list. on 1.16.12 it used to work even with folder.* listed as last in settings

Re: foobar2000 v2.0 bugs

Reply #45
I presume this displayed fine on v1.6.1.2? There have been changes in image handling with v2 where the windows imaging component (WIC) is used for loading images. If you could put the image inside a zip and attach it, I could test it with other components.

Just to be clear, I can't do anything about it. I'm just curious.

Re: foobar2000 v2.0 bugs

Reply #46
I presume this displayed fine on v1.6.1.2? There have been changes in image handling with v2 where the windows imaging component (WIC) is used for loading images. If you could put the image inside a zip and attach it, I could test it with other components.


Just to be clear, I can't do anything about it. I'm just curious.

Thank you for an explanation!


Re: foobar2000 v2.0 bugs

Reply #48
Looks like Beta 4 has the album art column removed from the playlist view??

But I tested Beta3 and it displays just fine. (edit: I must be high, my console is showing Beta4 - I have another Beta4 install with no album art columns. I need a lie down :/ )



Sorry (not sorry) about the girly pop music.  ;D

another edit: no columns.


Re: foobar2000 v2.0 bugs

Reply #49
The performance of version 2.0 is inadmissible. I don't know if it will be a problem of Columns UI or Foobar.

The problem appears when you have an external hard drive connected by USB. Mine has 5 tb of music

- If I have the external hard drive off and open foobar the tracks multiply continuously in the Playlist View (see image) and you cannot get well because it takes a long time to respond as the tracks multiply. You change to another artist and continue to multiply. In the Album List Panel the tracks appear correctly without multiplication.

- You have no choice but to plug the hard drive that had already been monitored the previous day. It takes to monitor 50 minutes. And until the monitoring ends any album that you put new on the hard disk the album list panel does not recognize it.

I have also experienced this problem in my wife's portatile and fails the same. So I think it's not difficult to check the problem by developers.