Skip to main content

Topic: Mp3Gain, W2k SP2 and the old MSCOMCTL.OCX (Read 5462 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • enolC
  • [*]
Mp3Gain, W2k SP2 and the old MSCOMCTL.OCX
Hello people,

I just installed Mp3Gain 1.2 Beta and when I start the program
I only receive this error message and nothing happens:

"Failed to load control "ImageList" from MSCOMCTL.OCX.
Your version of MSCOMCTL.OCX may be outdated.
Make sure you are using the version of the control that was
provided with your application."

I am using Windows 2000 with SP2 installed, the version number
of the MSCOMCTL.OCX is 6.0.88.92, dated May 11, 2000.
I have tried using and older version, 6.0.84.98, dated May 14,
1999, I believe and I have also tried with version 1.0 (stable),
neither worked.

Done a lot of searching on Google and on Microsoft, neither has
a newer version that I could find and after talking about this on
another forum I heard that some other people have had the
same problem, but apparently they had no solution either.

Anyone else have this problem?
I can't think of anything that would cause this, but I do have
quite a few tweaks to the system, so if you have any idea what
could cause this, that would be great, thanks in advance.

  • Jan S.
  • [*][*][*][*][*]
Mp3Gain, W2k SP2 and the old MSCOMCTL.OCX
Reply #1
Did you install the full version (and not normal)? The files should be included with that.
  • Last Edit: 09 August, 2003, 07:29:32 PM by Jan S.

  • enolC
  • [*]
Mp3Gain, W2k SP2 and the old MSCOMCTL.OCX
Reply #2
oh, sorry, yeah, it's full on both 1.2 Beta and 1.0.

  • Snelg
  • [*][*][*]
  • Developer
Mp3Gain, W2k SP2 and the old MSCOMCTL.OCX
Reply #3
Quote
I just installed Mp3Gain 1.2 Beta and when I start the program
I only receive this error message and nothing happens:

"Failed to load control "ImageList" from MSCOMCTL.OCX.
Your version of MSCOMCTL.OCX may be outdated.
Make sure you are using the version of the control that was
provided with your application."

I am using Windows 2000 with SP2 installed, the version number
of the MSCOMCTL.OCX is 6.0.88.92, dated May 11, 2000.
I have tried using and older version, 6.0.84.98, dated May 14,
1999, I believe and I have also tried with version 1.0 (stable),
neither worked.

I built MP3Gain using Win2K SP2. My copy of MSCOMCTL.OCX is 6.0.88.62, dated May 11, 2000.

Just in case there's something strange in your copy of MSCOMCTL.OCX, I've uploaded a copy of the file directly from my machine:

http://home.comcast.net/~snelg/mp3gain/MSCOMCTL.zip

Unzip that file directly into your MP3Gain folder and try again. If it still doesn't work, then... uh, I'm not sure yet...

-Glen

  • enolC
  • [*]
Mp3Gain, W2k SP2 and the old MSCOMCTL.OCX
Reply #4
Quote
I built MP3Gain using Win2K SP2. My copy of MSCOMCTL.OCX is 6.0.88.62, dated May 11, 2000.

Just in case there's something strange in your copy of MSCOMCTL.OCX, I've uploaded a copy of the file directly from my machine:

http://home.comcast.net/~snelg/mp3gain/MSCOMCTL.zip

Unzip that file directly into your MP3Gain folder and try again. If it still doesn't work, then... uh, I'm not sure yet...

-Glen


Nope, didn't help either, hmm, this is odd.

Anything else that could cause it, maybe that is not causing the error?
Maybe it's just reporting it wrong, I don't even think there is a newer
version of that ocx?
And since you build it with it, I see no reason for it not to work with it.

I wonder if it is somehow related to not having IE?
But then, I had the same problem when I did have it, I used
IEradicator to remove it, I wonder if that removes something that
could effect it and it isn't replaced with a new install of IE?

Here's what IEradicator removes, from the readme file:

THIS FILE WILL UNCONDITIONALLY DELETE ALL OF THE FOLLOWING
DIRECTORIES AND ALL FILES THEY CONTAIN WITHOUT PROMPTING.
BACKUP ANY PERSONAL FILES YOU MAY WANT TO KEEP; INTERNET
EXPLORER "FAVORITES" WILL BE DELETED IN THIS OPERATION SO
BACK THEM UP IF NEEDED.

ENGLISH
  %root%\program files\internet explorer
  %root%\program files\uninstall information
  %windir%\application data\microsoft\internet explorer
  %windir%\application data\microsoft\welcome
  %windir%\catroot
  %windir%\cookies
  %windir%\desktop\online services
  %windir%\downloaded program files
  %windir%\favorites
  %windir%\history
  %windir%\java
  %windir%\subscriptions
  %windir%\temporary internet files
  %windir%\web
  %windir%\system\oobe
  %windir%\system\catroot
  %windir%\occache
  %root%\program files\common files\triedit

Could there be something in one of that affects Mp3Gain?
  • Last Edit: 09 August, 2003, 09:21:11 PM by enolC

  • Snelg
  • [*][*][*]
  • Developer
Mp3Gain, W2k SP2 and the old MSCOMCTL.OCX
Reply #5
Quote
Nope, didn't help either, hmm, this is odd.

Anything else that could cause it, maybe that is not causing the error?
Maybe it's just reporting it wrong, I don't even think there is a newer version of that ocx?

Sorry, I'm really not sure. My best guess is that mscomctl.ocx depends on another file, and _that_ file is screwed up on your computer.

I'm really not an expert at all the myriad inner workings of Windows, but when I get back to my laptop I can at least try doing a dependency check on mscomctl.ocx to see what files it depends on.

-Glen

  • enolC
  • [*]
Mp3Gain, W2k SP2 and the old MSCOMCTL.OCX
Reply #6
Quote
Sorry, I'm really not sure. My best guess is that mscomctl.ocx depends on another file, and _that_ file is screwed up on your computer.

I'm really not an expert at all the myriad inner workings of Windows, but when I get back to my laptop I can at least try doing a dependency check on mscomctl.ocx to see what files it depends on.

-Glen


That would be great, thanks

I really want to get this to work.
  • Last Edit: 12 August, 2003, 10:30:54 PM by enolC

  • enolC
  • [*]
Mp3Gain, W2k SP2 and the old MSCOMCTL.OCX
Reply #7
@Snelg

Don't worry about this anymore, I installed my system again cos
of some other stuff and now MP3Gain works fine again, I didn't
remove IE tho, so that might have something to do with it as well.

  • Snelg
  • [*][*][*]
  • Developer
Mp3Gain, W2k SP2 and the old MSCOMCTL.OCX
Reply #8
Quote
@Snelg

Don't worry about this anymore, I installed my system again cos
of some other stuff and now MP3Gain works fine again, I didn't
remove IE tho, so that might have something to do with it as well.

I'm glad you got it fixed, even if I didn't help

-Glen