Skip to main content
Topic: Open... dialog goes mad (Read 392 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Open... dialog goes mad

  • Install fb2k and:
    foo_input_tfmx
    foo_input_vgmstream
    foo_input_zxtune
  • Start fb2k, choose File | Open..., then click on File types drop-down list
It'll take a lot of time and blinking until the list will be shown. If there are even more input plugins installed (try attached set) the list can't be shown at all.
Magically yours
Raistlin

Re: Open... dialog goes mad

Reply #1
Are you running Windows XP? The Windows Vista and higher file open dialogs have no problems with the literal hundreds of file types reported by foo_input_vgmstream. Although, if you like, I can try trimming it down to a single file type listing all of the literal hundreds of filename extensions as a single entry, without also including them in the name of the file type item.

Re: Open... dialog goes mad

Reply #2
No I use Windows 8.1 x64.
Magically yours
Raistlin

Re: Open... dialog goes mad

Reply #3
kode54, the issue actually only affects newer OSes. Since GCRaistlin still doesn't know that bug reports require details I was forced to test the problem on several systems. Even on my super slow emulated Pentium II machine running XP the open dialog showed no issues. Windows 7 was fine too.

Peter has been made aware of the problem. I believe he can work around it without changing components, or at least I hope so.

Re: Open... dialog goes mad

Reply #4
What further details can be provided here? I described all steps in the first post (except the OS being used).
Magically yours
Raistlin

Re: Open... dialog goes mad

Reply #5
Nothing anymore but had you said your OS in the first post you would have saved a lot of my time. I started testing with Windows XP and went up from there.

Re: Open... dialog goes mad

Reply #6
I only tested on Windows 10, without constraining the processor speed.

Re: Open... dialog goes mad

Reply #7
@Case : your aggressiveness is uncalled for - @GCRaistlin provided enough details to start diagnosing the issue, he is not a QA tester nor there is a template for bug reports available here.
The bug might have been affecting all the OSes or might have even been a known bug for some component that he used for all he knows.

Re: Open... dialog goes mad

Reply #8
The support forum has a pinned post Support forum rules that states everything one needs to mention when reporting problems. It gets very frustrating when majority of problem reports don't mention a single helpful extra detail and one has to either specifically request for details or try his luck in reproducing the error.

He had posted another problem report just a day before where I spent quite some time verifying. I had to create albums with CUE sheets and tested various foobar2000 versions only to come back to report that I can't reproduce his problem.

If you search my post history I think majority of them consists of posts asking for more details. It gets tiresome after a while when people this day should know better.

Re: Open... dialog goes mad

Reply #9
> It gets tiresome after a while...
It sure does =)

> ... people this day should know better.
Haha, only in our dreams... IMO, the only way to get full info (or at least more than usual) is to have a must-fill bug report template (like in GitHub issues), but I'm not sure if it's possible to implement it in forum engine.

Re: Open... dialog goes mad

Reply #10
Workaround added for version 1.4.2 final. Thanks for reporting.

 
SimplePortal 1.0.0 RC1 © 2008-2019