Skip to main content
Topic: PC foobar2000 v1.4 - not picking up proxy settings (Read 864 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

PC foobar2000 v1.4 - not picking up proxy settings

In the Networking section of fb2k, you can choose "No proxy", "Use Internet Explorer settings" (aka the Windows system proxy) or "Specify proxy address".

Up to and including v1.3, "Use Internet Explorer" settings worked great. However in v1.4 this function seems to be broken - you have to always manually specify the proxy address. Inheriting the proxy details from Windows / Internet Explorer doesn't work. This is on Windows 7 64-bit.
Don't forget International Talk Like A Pirate Day! September the 19th!

Re: PC foobar2000 v1.4 - not picking up proxy settings

Reply #1
Works for me. Any specific settings or specific proxy I should try? Please send me a private message if you do not wish to post it in public.

Re: PC foobar2000 v1.4 - not picking up proxy settings

Reply #2
Works for me. Any specific settings or specific proxy I should try? Please send me a private message if you do not wish to post it in public.

Sorry for delay in reply. I'm using corporate HTTP proxy (Squid), so not much use me giving you the details. Via either our 'normal' (round-robin load balanced Squid cluster) or our 'sticky' alternate (which routes your traffic through the same endpoint for duration of browsing session), it no longer streams.

After normal connect timeout, I see the error:
Unable to open item for playback (Network error): "http://url.to/file"

Here's my steps to reproduce on my current fb2k v1.4 portable install.

  • Set to use No proxy.
  • Select "Use Internet Explorer settings", hit Apply, then hit OK (or just hit OK): no connectivity.
  • Using Microsoft Network Monitor, I can see fb2k still attempting to connect directly to the file host (which will never work).

Are there any debug flags I can set so that fb2k logs its attempts to read the system proxy info and what it's attempting to use?

I normally rely on the system proxy settings for regular internet access: in Chrome I use SwitchyOmega, which also relies on the system proxy settings. My work supplies a utility which detects whether you're on the corporate network/VPN or another network and simply toggles the proxy settings on/off in Internet Options; this works quite fine for everything. Previously fb2k has coexisted quite happily, set to use Internet Explorer settings.

Manually overriding the app (closing it and forcibly defining proxy settings in IE / system proxy) doesn't make any difference, fb2k v1.4 doesn't want to inherit the system proxy server settings. It's like it can't see they're set; it only streams if it has the proxy details defined in the fb2k Networking options.

For testing purposes, I installed fb2k 1.3.20 portable and set it to use Internet Explorer proxy settings. I added the same MP3 file to the playlist - it connects and streams immediately using the inherited system proxy settings.

Another interesting side-effect: v1.4 seems much less stable streaming files than 1.3. When I manually provide proxy settings (identical to those used by the system) and start streaming, the audio will usually stop streaming after 66/67 seconds. (?!) Using 1.3 with system proxy detection, the file streams fine. This happens irrespective of whether dynamic track titles are enabled or not.

I'm progressive streaming this MP3 file for testing (URL shortened as it has square brackets in the filename which the forum incorrectly parses) - but it happens on whatever files I throw at it. Streams seem a bit more stable, but they also occasionally disconnect without warning.
Don't forget International Talk Like A Pirate Day! September the 19th!

Re: PC foobar2000 v1.4 - not picking up proxy settings

Reply #3
New beta version posted.

One seemingly harmless change in proxy handling made between 1.3 and 1.4 has been reverted.
Debug logging of proxy server handling has been added- please look for [PROXY DEBUG] lines in the console and report what they say when you try to play a file using autodetected proxy settings.

Also, 1.4.1 should be less prone to playback interruptions over HTTP again, compared to 1.4; a new buffering scheme has been introduced.

Re: PC foobar2000 v1.4 - not picking up proxy settings

Reply #4
Just tested with 1.4.1b5 - bug still present.

With autodetected proxy settings:

Opening track for playback: "http://equinox.shoutca.st:8702/"
[PROXY DEBUG] initRequest()
[PROXY DEBUG] mode auto
[PROXY DEBUG] autoproxy returned: corporateproxy:80
Unable to open item for playback (Network error):
"http://equinox.shoutca.st:8702/"

With manually defined proxy:
[PROXY DEBUG] initRequest()
[PROXY DEBUG] mode user
[PROXY DEBUG] user URL corporateproxy:80

and the stream works. Also manually specified the proxy with http;// - still works fine.

I then tried prepending http:// to the proxy setting in Internet Options, tried removing the port, no change in behaviour.

In Internet options, I have an HTTP proxy specified with port 80. There's an autoproxy PAC also defined, but disabling it makes no difference to fb2k.
Don't forget International Talk Like A Pirate Day! September the 19th!

Re: PC foobar2000 v1.4 - not picking up proxy settings

Reply #5
Should be fixed in 1.4.1 beta 6.
Thanks for your patience.

 
SimplePortal 1.0.0 RC1 © 2008-2019