Skip to main content

Topic: recordingto mp3 with mp3DirectCut (Read 2452 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • AndyH-ha
  • [*][*][*][*][*]
recordingto mp3 with mp3DirectCut
I installed the latest program version on a Windows 10 Pro system. My need on this machine is to record in mp3 format using the LAME encoder. I have done this quite easily under Windows XP and Windows 7.

Here, in Windows 10, the main problem is that there is no record button. But that isn't all.

When I first installed the program and configured it, the only input device listed was wave mapper. Wave Mapper does not seem to actually be a source of anything. The only really valid input, 'line in', doesn't show anywhere until something is actually plugged into the input jack.

I did load, and play, an mp3 file in mp3DirectCut but didn't attempt to do any operations on it.

Once I plug a hardware player into the input jack and told the system it is to be a line in jack (not a microphone jack), line-in becomes a selectable input for recording. However, when I opened mp3DirectCut, with line-in selected as its input device, the record button was no longer there. After that, no matter what I do, the record button stays AWOL.

Also now, when I open an existing mp3 file with the program, all the operation controls are gone. I can not play the file nor do anything else with it. If I close the mp3 file, all controls, except the record button, reappear. Open a file, the controls disappear again.

I installed CoolEdit 2000. It records properly from line in and plays back what it records. Everything seem normal.

Can anyone use mp3dDirectCut, especially for recording, in Windows 10?
Any ideas about the strange behavior on my computer?

  • probedb
  • [*][*][*][*][*]
Re: recordingto mp3 with mp3DirectCut
Reply #1
Silly question but I assume you have pointed it at the lame.dll?

  • AndyH-ha
  • [*][*][*][*][*]
Re: recordingto mp3 with mp3DirectCut
Reply #2
The program is set up with a copy of lame_end.dll in its own directory, the program's Encoder tab setting seems to recognize it, and the program's Device tab setting points to line-in. The problem is the lack of any way to record (or playback) from within the program.

Below the audio display is a panel normally full of icons. One of these is a red record button. It was there initially but disappeared somewhere between first display and getting the configuration in place.

The rest of the icons are displayed -- prior to opening an mp3 file. When I open a file, all of them disappear.

Re: recordingto mp3 with mp3DirectCut
Reply #3
Andy I tried this yesterday for you and could not get the program to recognize lame_enc.dll. I did run the program before putting the dll into the programs folder. I deleted everything and gave up!

Today I ran the installer for ver 2.23 as administrator, downloaded lame_enc.dll from http://lame.buanzo.org/#lamewindl and put it into the program folder before I ran the program for the first time and all was good. The only thing that's different for me is that the record button is always white. Loaded mp3's and they played fine. Recorded a quick snippet and that as also fine.

I could not get Lame_enc 3.99.5 to  work so settled on 3.99.3 above.

Win 10 Home - Version 1703 - OS Build 15063.483

  • AndyH-ha
  • [*][*][*][*][*]
Re: recordingto mp3 with mp3DirectCut
Reply #4
Considering Steve's information, I deleted the lame dll from the mp3DirectCut folder. Opening the program I saw the record button but it did not work. There was a message on the Configuration/Decoder tab that it could not find lame ... .

I closed the program and again copied the same lame_enc.dll to the mp3DirectCut folder. Now the record button is present and recording works. Also, all icons are again shown when any mp3 file is open in the program although I have not yet tried to use any of them.