Skip to main content
Topic: Biography (Read 24518 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Biography

Reply #25
New Version: JScript Biography 0.8.2

Requirements are unchanged.

Please post discussion here.

Re: Biography

Reply #26
Thanks WilB!

Re: Biography

Reply #27
New Version: JScript Biography 0.8.3

Requirements are unchanged.

Re: Biography

Reply #28
New Version: JScript Biography 0.8.4

Requirements are unchanged.

 

Re: Biography

Reply #29
New Version: JScript Biography 0.8.4.1

Requirements are unchanged.

Re: Biography

Reply #30
New Version: JScript Biography 0.8.4.2

Requirements are unchanged.

Re: Biography

Reply #31
New Version: JScript Biography 0.8.5

Requirements are unchanged.

Re: Biography

Reply #32
New Version: JScript Biography 0.8.5.1

Requirements are unchanged.

Re: Biography

Reply #33
New Version: JScript Biography 0.8.5.2

Requires JScript Panel 1.3.0+ for full functionality. Will work with JScript Panel 1.1.0+ except tag writing won't be available.

Re: Biography

Reply #34
^^^ Note that JScript Biography 0.8.5.2 and earlier versions won't work with JScript panel v2+.

Re: Biography

Reply #35
New Version: JScript Biography 0.9

REQUIREMENT: JScript panel 2.01+

Existing users: If updating from v0.8.5.1 or v0.8.5.2, you just need to install v0.9. If updating from v0.8 to v0.8.5, to retain settings, install 0.8.5.2 first and before updating JScript Panel to v2+.


Re: Biography

Reply #37
Hello WilB!

I get this error when trying to install JScript panel 2.0.1+
https://frupic.frubar.net/shots/36392.jpg
JScript panel 1.3.2.2 and JScript Biography 0.8.5.2  works just fine.
Using foobar2000 v1.3.17

More info:
Also tried "DarkOne v4.0 - Tedgo - JScript Biography Version (0.9.01) - Modified by WilB.fcl"
and get this error:
https://frupic.frubar.net/shots/36393.png

What can I do?

Best regards

Re: Biography

Reply #38
JScript Panel 2 requires foobar2000 1.4 (currently beta) and above.

Re: Biography

Reply #39
How did you force that? Just so anyone knows, the current SDK defaults to only requiring 1.3 or newer.

Re: Biography

Reply #40
JScript panel is used to run it, and that now requires foobar2000 1.4. You would need to get an answer from marc2k3 as to how and why he did it, as JScript panel is his plug-in.



Re: Biography

Reply #43
JScript Panel 2 requires foobar2000 1.4 (currently beta) and above.
OK, that explains it. I'll probably wait for a stable realease of foobar2000.


DarkOne v4.0 only works with JScript Panel 1.3.0+
All Scripts have to be updated for newer JScript Panel Versions. But I have nothing heard from Tedgo for about a year...

Re: Biography

Reply #44
Quote
DarkOne v4.0 only works with JScript Panel 1.3.0+
All Scripts have to be updated for newer JScript Panel Versions. But I have nothing heard from Tedgo for about a year...
Do you mean DarkOne v4.0 won't work with foobar2000 1.4 and JScript Panel 2 and WilB JScript Biography 0.9.0.1?

Re: Biography

Reply #45
Quote
DarkOne v4.0 only works with JScript Panel 1.3.0+
All Scripts have to be updated for newer JScript Panel Versions. But I have nothing heard from Tedgo for about a year...
Do you mean DarkOne v4.0 won't work with foobar2000 1.4 and JScript Panel 2 and WilB JScript Biography 0.9.0.1?
Sorry, meant DarkOne4Mod. It uses JScript Panel for several UI Elements. But the Scripts were not actualized for a long time
The older v4 uses WSH Panel Mod for those UI Elements.  JScript Biography 0.9.0.1 seems to work.

Re: Biography

Reply #46
Quote
Sorry, meant DarkOne4Mod. It uses JScript Panel for several UI Elements. But the Scripts were not actualized for a long time
The older v4 uses WSH Panel Mod for those UI Elements.  JScript Biography 0.9.0.1 seems to work.
Ok, great! Thanks for the clarification! Got a bit worried 'cause I just love DarkOne v4!

Best regards


Re: Biography

Reply #48
Hi...
is it possible to auto cylce artist bio und pics only for the current track (feat. Artist or the Solist, Orchestra etc.)  and not between similar artist???
Thanks!
LG Frank

Re: Biography

Reply #49
Right click > sources > server settings. Opens biography.ini. Set the number of similar artists to display to 0 as shown below:

[ADVANCED: MORE MENU ITEMS]
...
...
Similar Artists: Number to Display(0-10)=0

Save biography.ini & restart foobar2000.

It should then auto-cycle bios and pics for tag items of the current track; e.g. artist, composer and performer, including items in multi-value fields, etc.

HTH

 
SimplePortal 1.0.0 RC1 © 2008-2018