Skip to main content
Topic: foo_youtube (Read 200420 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_youtube

Reply #375
@Clauu
In default configuration without FFmpeg for audio playback used best available audio from formats suported by foobar. This is your case because FFmpeg is not configured - not enough to setup 'Decode it's own', need also provide FFmpeg binaries. For HD videos best available audio will be within huge 720p videos so they are used as audio sources at playback. And separately one more 720p video used at video playback by your settings. So maybe this is just bandwidth problems. If the only problem is audio/video synchronisation - try 'Synchronize video' and 'Synchronize playback' actions in video window context menu. Otherwise select smaller quality for audio and video and select foobar2000 in 'Media downloading'. Or download preconfigured component version and reset Decoder and Features tabs.

@ernstblaauw
If URL contains both playlist id and single clip id then the component treats it as a single clip URL (more info).  In your case http://youtu.be/BPtdSr6OwJA is a single clip URL so component adds just this clip. For youtu.be shortener I don't know a way for shortening a playlist URL without single clip id so the only way I can suggest - use canonical playlist URL. In this case it will be http://youtube.com/playlist?list=RDBPtdSr6OwJA

foo_youtube

Reply #376
Where should I report the following problems?

Resume playback should re-load video if the break was long
If I'm listening to a long mixtape and I pause playback and forget about it for a few minutes, resuming playback will play a little longer (what's buffered) then skip to the next track. I should mention that I have Foobar set to Save playback state, and when I close and restart Foobar playback resumes from where I left off without a hitch.

Can't save .m3u/.m3u8 playlist
When I create a playlist in foobar filled with YouTube songs (3dydfy:// paths) and try to save it as my-playlist.m3u it produces an empty file. Saving as .fpl works, so I guess it's a paths issue. Manually pasting the song URLs in a text file and saving it as my-playlist.m3u also works!

In closing, I'd like to reinstate my plea for a new feature: subreddit playlists!
Thank you for the component!!

foo_youtube

Reply #377
Subreddit Playlists
Subreddit to YouTube Source Bookmarklet - Play YouTube music from subreddits in Foobar
Generates .M3U playlist of all YouTube videos in current subreddit listing for use in foobar2000 with the foo_youtube component.

How to install
  • Copy the contents of the second file Subreddit-to-YouTubeSource.min.js
  • Add a new bookmark
  • Name it something like Subreddits to YouTube Source, or however you want
  • In the URL field paste what you copied and Save

How to use
  • Go to Reddit, pick your favorite music subreddit and look for the listing you want.
  • Hot, new, top, try sorting. You can even add &limit=100 to the address to load 100 songs per page instead of the usual 25. Optionally if you don't wanna mess about you can edit the bookmarklet's default which is subredditLimit = 50
  • When you're happy with the list click on the bookmarklet.
  • A file will be generated and you'll be prompted to save it (or it will start downloading automatically).
    The filename will look like <coolsubreddit>-<hot>-<50>.m3u8.
    Optionally you may also use the console reddit.toM3U('myplaylist.m3u')
  • Open this file with Foobar and enjoy the tunes!
    You may notice after it finishes Processing the tracks, the playlist fewer tracks than the filename says. That's because in time YouTube deletes songs and foo_youtube no longer loads those.


Thanks again @3dyd for the component and I hope this humble hack makes it into a proper feature!

foo_youtube

Reply #378
Would it be possible to add an option so that searches from UI element send results to the specified playlist instead of the active playlist?

Maybe search within component main window can help? (menu View -> Youtube Source -> Search tab) It has more options related to destination playlist, check there context menu of the search results. In any case itegrated search will remain to use only active playlist but I can extend options in this context menu if need.
Hi and apologies for the late reply.

I wasn't aware of that menu entry, but I'm afraid it's not what I was looking for. I would like to give the possibility to search YT from fb2k to a non-tech savvy user and, at the same time, be sure that no playlists are accidentally wiped.

A tab with a dedicated panel seemed to me the most user friendly option: if forcing a destination playlist there is not possible, I think I'll stick with the context menu search (right click on a song -> Yoututbe Source -> Search artist songs), although this solution is not as flexible as a free text search.

Thanks anyway.

Alessandro

foo_youtube

Reply #379
If I'm listening to a long mixtape and I pause playback and forget about it for a few minutes, resuming playback will play a little longer (what's buffered) then skip to the next track.

Yes, it plays what was buffered before you hit pause. And does not continue playing because connection after some time becomes invalid. It's the same as for example with online radio. Decoder does not know when next audio portion requested from it - after long pause or at usual playback workfow or by any other scenario. So this cannot be fixed without uncertain workarounds.

Can't save .m3u/.m3u8 playlist

Interesting. If save playlist with 3 tracks (file, online radio URL and 3dydfy:// Youtube link) then resulting file will contain 2 tracks: local file path and online radio URL. Unofficial m3u specification (as I googled) allows local file paths and URLs so probably this is the explanation.

I'd like to reinstate my plea for a new feature: subreddit playlists!

Nothing else than Youtube itself within this component, sorry. But I glad to add any stuff which will help to make other things over this component, as it was with metadata overriding (feature request for last.fm Youtube radio [1], [2])

I wasn't aware of that menu entry, but I'm afraid it's not what I was looking for. I would like to give the possibility to search YT from fb2k to a non-tech savvy user and, at the same time, be sure that no playlists are accidentally wiped.

I think this is not a problem. If playlists was accidentally wiped then you always can turn it back by menu Edit -> Undo (or Ctrl+Z in default configuration).

foo_youtube

Reply #380
Sorry if this has been asked before, but is it possible to use this plugin and search and play youtubevideos within foobar, whilst controlling foobar through an ipad remote app?

I'm trying to figure out how I can sit in my livingroom (where my stereo is) and play music from my computer (which is in another room). Everything works perfect when I control foobar through a remote app, but I'm not sure what to do if I want to play something off youtube.

foo_youtube

Reply #381
This plugin works for me and I hear audio.  But where is the video output played back (I don't see any video clip - just static album art in my album art viewer)?  Is there a video display window that I am not seeing for some reason?

foo_youtube

Reply #382
Sorry if this has been asked before, but is it possible to use this plugin and search and play youtubevideos within foobar, whilst controlling foobar through an ipad remote app?

I'm trying to figure out how I can sit in my livingroom (where my stereo is) and play music from my computer (which is in another room). Everything works perfect when I control foobar through a remote app, but I'm not sure what to do if I want to play something off youtube.

If Youtube clips are already in the playlist then there will be no problems, they are usual tracks so remote app does not need anything additional to control them (play, pause, retrieve album art etc).
About Search on Youtube - this is not standard thing thus it cannot be controlled from the outside.

This plugin works for me and I hear audio.  But where is the video output played back (I don't see any video clip - just static album art in my album art viewer)?  Is there a video display window that I am not seeing for some reason?

Video displaying is separated, independent of audio thing which should be enabled explicitly. Use checkbox 'Enable video playback' in Preferences -> Youtube Source -> Features. After this video window will be available in View -> Visualizations -> Youtube Video.

foo_youtube

Reply #383
Amazing plugin, thank you for your work! The best thing is that I can finally use my sound effects from foobar in youtube playback.

It would be really great if it also could record and cache previously played songs instead of downloading them every time.

foo_youtube

Reply #384
Hi, 3dyd!

Recently I did some tests of YouTube audio encoding quality (in Russian; also see: Google-translated version). First time I couldn't get VP9 encoding (especially WebM Vorbis AO), but then I got it by quickly rising the popularity of my test video.

In your manual you write:

Quote
Also note that not every format may be present on particular clip page, it depends of original quality of the video and few other reasons.


Do you know what this reasons exactly are?

Because also you are saying about Opus AO files, but I have not encountered them at the service at all. And if conditions for VP9 encoding are something like enough traffic (as I understand), then what may be the conditions for Opus encoding?

Also do you have some examples of videos with Opus AO?

Thanks!

foo_youtube

Reply #385
And some feedback.

foobar2000 1.3.4 + foo_youtube 1.3.1_preconf with this video.

1. Plugin can't find MP4 stream when Playback Start: Slow is selected. There is also some strange behavior with Fast and Medium: if I select to prefer MP4, it plays M4A, but when I additionaly select to ignore everything but MP4, it finally begins to play MP4.

(Prefer AO is disabled)

2. You say that for FFmpeg Media downloading M4A seeking should work, but actually it doesn't. With foo_youtube or FFmpeg Medi downloading type I'm able to seek MP4, but not M4A (MP4 AO). Console shows 3dydfy, opening m4a (http): download - ffmpeg, decode - ffmpeg, but seeking is not available.


Hopefully you will fix it.

Thanks.


P.S. Where do foo_youtube and FFmpeg cache downloaded files?

foo_youtube

Reply #386
It would be really great if it also could record and cache previously played songs instead of downloading them every time.

Noted, however I would not expect this anytime soon, sorry.

Recently I did some tests of YouTube audio encoding quality (in Russian; also see: Google-translated version).

Interesting article!

In your manual you write:

Quote
Also note that not every format may be present on particular clip page, it depends of original quality of the video and few other reasons.


Do you know what this reasons exactly are?

Nope. Also Youtube changes available formats quite often. It is additional reason for so many options for playback source tuning.

Because also you are saying about Opus AO files, but I have not encountered them at the service at all.

It appears randomly for the same clip. I.e. you can open the clip 20 times and see it just once. The same thing was with VP9 codec when it just started. After few months VP9 become constantly available for the clips where it presented. Maybe it is a kind of beta testing in real conditions by Youtube. This also means that Opus may just stop to appear (or already stopped) as it currently seems so for soft-made 3D versions of the clips and for many usual (video+audio) qualities.

Also do you have some examples of videos with Opus AO?

Not much, anyway look in PM.

foobar2000 1.3.4 + foo_youtube 1.3.1_preconf with this video.

1. Plugin can't find MP4 stream when Playback Start: Slow is selected.

I.e. no MP4 at all (check View -> Youtube Source -> History tab) or component just does not select it for playback?

There is also some strange behavior with Fast and Medium: if I select to prefer MP4, it plays M4A, but when I additionaly select to ignore everything but MP4, it finally begins to play MP4.

(Prefer AO is disabled)

'Priority of formats' used if there are more than one media with best match to preferred quality. E.g. you selected to play 'nearest to 128kbps audio' and there are two streams AAC and Vorbis with this bitrate. Probably in your case source determines before 'Priority of formats' used because best MP4 there has only 96kbps quality.

2. You say that for FFmpeg Media downloading M4A seeking should work, but actually it doesn't. With foo_youtube or FFmpeg Medi downloading type I'm able to seek MP4, but not M4A (MP4 AO). Console shows 3dydfy, opening m4a (http): download - ffmpeg, decode - ffmpeg, but seeking is not available.

Thanks for report, I'll check this. But note that with seeking it also gives big delay at opening (depends of clip duration, e.g. in my case approximately +1 second for every 2 minutes of duration).

P.S. Where do foo_youtube and FFmpeg cache downloaded files?

Temp files used only by foo_youtube from Media downloading combobox. They are '3dydfy<number>.tmp' files in temp folder of current user.

 

foo_youtube

Reply #387
Got video working great.  Been waiting for someone to make a plugin like this for years - respect to you 

One further question - is it possible to scrub the playing track with video (preferably with waveform seekbar, but if not, with the built in scrubber)?

foo_youtube

Reply #388
Thanks for reply.

foobar2000 1.3.4 + foo_youtube 1.3.1_preconf with this video.

1. Plugin can't find MP4 stream when Playback Start: Slow is selected.

I.e. no MP4 at all (check View -> Youtube Source -> History tab) or component just does not select it for playback?


It shows that there is MP4 360p Audio+Video stream:



but in the console I see:

Quote
3dydfy, opening matroska (http): download - foo_youtube, decode - foobar2000
Unable to open item for playback (3dydfy: unexpected media format (matroska|ogg)):
"3dydfy://www.youtube.com/watch?v=o4wWfkzBND0"


Note that I selected to download and decode everything with ffmpeg:


foo_youtube

Reply #389
One further question - is it possible to scrub the playing track with video (preferably with waveform seekbar, but if not, with the built in scrubber)?

Scrub - you mean seek simultaneously with moving some slider or dragging the mouse? Yet not sure that this is possible and will work well with online resources, need check. And it can be done only using some built in solution.


@Steve Forte Rio
Now all clear. At 'Playback Start -> Slow' component probes each media file with FFmpeg to get its exact quality info. FFmpeg from LAV returns little different (unexpected, I'll fix this) format string for WebM so component just uses first part of format string as is (and you see 'matroska'). But this format works as others: you can manually add 'matroska' in 'Formats to ignore' to disable it or in 'Decode its own' to decode it with FFmpeg. Currently by your settings is is not ignored so it selects for playback (because has better audio bitrate, 128 vs 96 in mp4). And it is not selected to decode by FFmpeg so decodes by foobar and you see this error (in this case component need provide for foobar MIME type and it can do this only for known formats).

Btw, you can use 'Help -> Youtube Source -> Copy settings to Clipboard' to do not waste your time with making a screenshot.

foo_youtube

Reply #390
Thank you. I added matroska to "Decode it's own" and to the preferred formats. But  ffmpeg also doesn't want to deocde it:

Quote
3dydfy, opening matroska (https): download - ffmpeg, decode - ffmpeg
Unable to open item for playback (Unsupported file format):
"3dydfy://www.youtube.com/watch?v=o4wWfkzBND0"

foo_youtube

Reply #391
This is another issue. In 'Media downloading' you select how to download the data. In 'Decode its own' - how to decode it. FFmpeg can decode it. But it cannot download from https (at least builds from Zeranoe and LAV Filters). Since some time the same clip may return http at first opening and https and next, I don't know any reasons or the way to control this (even check your Console quotation in this thread, in last one was https when in previous http). So select in 'Media downloading' foobar2000 or foo_youtube, they both can use https.

foo_youtube

Reply #392
So select in 'Media downloading' foobar2000 or foo_youtube, they both can use https.


But I need MP4 seeking

Quote
Seeking disabled (and playback start is fast) only if use foobar2000 or foo_youtube in option Media downloading described above.


foo_youtube

Reply #393
Since last night I get a lot of errors like these:
Code: [Select]
Unable to open item for playback (Forbidden (403)):
"3dydfy://youtube.com/watch?v=_w7lkQoJmqY"

It happens with old items as well as tracks that I've just added.

foo_youtube

Reply #394
@Steve Forte Rio
Ok. I'll add checkbox to allow this in Advanced preferences. I thought that all prefer fast playback start than seeking possibility.

@ArchCarrier
Not seen it for a long time. Ok, checking.

foo_youtube

Reply #395
New version 1.4

Changelog:
- additional formats for Youtube and several fixes (including 403 error)
- option for allow seeking over M4A in Advanced preferences
- video playback completely rewritten in more proper way. Should be more stable and allows to add new stuff more easely. Video window UI moved to main UI thread (video opening goes in another thread)
- video background settings extended and moved to separated dialog. See video context menu Window -> Appearance
- possibility to lock video window relative to the main window. See video context menu Window -> 'Lock relative to main window'
- simple seekbar in video fullscreen. Shows when mouse is at the bottom of the window

Also note that minimal required FFmpeg version now is 2.3

foo_youtube

Reply #396
Like new version  video window now stays in foobar panel.
Only i would like to see solution for 'playback stop' when go to next track..

foo_youtube

Reply #397
Seems like the new patch fixed the broken You-Tube songs that just recently popped up.
Awesome fast work... Keep up the awesome work.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Still it seems like 30% of the songs in my playlist have "Artist" as "?", tried to edit song, change info, save and next time that song comes in the playlist it resets the saved song artist and replaces it with "?"

Here is a song that does not work for me reg renaming ( 3dydfy://www.youtube.com/watch?v=AH9L5I6N-ZU )

foo_youtube

Reply #398
Still it seems like 30% of the songs in my playlist have "Artist" as "?", tried to edit song, change info, save and next time that song comes in the playlist it resets the saved song artist and replaces it with "?"

Such manually edited fields are stored in tech info fields of the track, thereby they exist only until exist the track. If remove the edited track from all playlists and close the program then manually edited tags will be lost (if not close the program then they will be available till it keeps data for Undo).

foo_youtube

Reply #399
New version 1.4

Changelog:
- additional formats for Youtube and several fixes (including 403 error)
- option for allow seeking over M4A in Advanced preferences
- video playback completely rewritten in more proper way. Should be more stable and allows to add new stuff more easely. Video window UI moved to main UI thread (video opening goes in another thread)
- video background settings extended and moved to separated dialog. See video context menu Window -> Appearance
- possibility to lock video window relative to the main window. See video context menu Window -> 'Lock relative to main window'
- simple seekbar in video fullscreen. Shows when mouse is at the bottom of the window

Also note that minimal required FFmpeg version now is 2.3


Thank you! Now foo_youtube downloading through HTTPS works well with seeking.

 
SimplePortal 1.0.0 RC1 © 2008-2019