Skip to main content

Topic: Fulllscreen Games "steal" Volume Control (Read 847 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Schuldi
  • [*]
Fulllscreen Games "steal" Volume Control
Hello Guys,

I have set up my foobar successfully and while i am using desktop applications everything works fine and i can control the Volume of foobar exclusively by the Volume buttons on my keyboard.
But when i start a fullscreen application (tested with games) the volume buttons on my keyboard don't control foobar anymore and change the Windows Volume, which is pretty annoying.

do you know a fix for that? i tried to remap the keys via registry and "keytweak", which didn't work and your wiki says, that you can change keyboard settings in the "keyboard control panel" but i don't really know what that is.

please don't tell me to google or use forum search, as i did this before and doesn't solve my problem... thank you

Schuldi

  • Propheticus
  • [*][*][*]
Fulllscreen Games "steal" Volume Control
Reply #1
You can try binding <cntrl>+<up> and <cntrl>+<down> for volume up and down instead of your media key in Foobar2000's preferences -> keyboard shortcuts. Be sure to tick the 'global hotkey' box.

  • Schuldi
  • [*]
Fulllscreen Games "steal" Volume Control
Reply #2
hmm, doesn't work either... if i press the buttons in normal windows everything works fine. as soon as i launch a game the shortcuts don't work anymore. global hotkey is checked in both shortcut confugirations

  • Propheticus
  • [*][*][*]
Fulllscreen Games "steal" Volume Control
Reply #3
Strange, works flawlessly here...

  • Kohlrabi
  • [*][*][*][*][*]
  • Global Moderator
Fulllscreen Games "steal" Volume Control
Reply #4
This depends on the game in question and how it handles input. Sometimes it works, sometimes it doesn't.
It's only audiophile if it's inconvenient.

  • Schuldi
  • [*]
Fulllscreen Games "steal" Volume Control
Reply #5
yeah at the moment i assume that the DirectX games "steal" the control. in an OpenGL game everything works fine...
What i don't understand, that WinAMP worked fine before. I will check the issue tomorrow on my Laptop with a clean install of windows. probably the behavior is different.